Subject: [Tsvwg] Chunk and ParameterId Conflict

From: "Khan, Mohammad" <[email-masked]>
Date: Wed, 20 Mar 2002 22:38:51 -0800

Hi All,
In the draft for Dynamic Ip modification
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-addip-sctp-04.txt two
new chunks have been introduced as ASCONF and ASCONF-ACK with chunktypes as
0xc1 and 0x80 respectivily. As per the RFC 2960 first two bits of the chunk
types specify the action to be taken when the chunk type is unspecified. So
following confusion in the chunk Ids would be observed.

	ChunkType	ChunkId		ChunkId with two MSBs
Observation
	ASCONF	0xc1		
	INIT		0x01		0xc1(Both the MSBs Set)	It matches
with ASCONF Chunk Type
	ASCONF-ACK	0x80
	DATA		0x00		0x80(One MSB set)		It
matches with ASCONF-ACK Chunk Type

As per the SCTP Implementors Guide
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpimpguide-03.txt
2.4.2 - e "Each parameter type must be unique across all chunks". In the
draft
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-addip-sctp-04.txt six
new parameters have been added few of  which does not contain unique
parameter types considering the existing parameter types with two of the
MSBs set to specify action when peer does not recognize it. Following are
the observation.

	Parameter Type		ParameterId	ParameterId with twoMSBs
Observation
	IPV4 Address		0x0005		0xC005(Both MSBs set)
	Success report		0xC005
It matches with IPV4 address when two
msbs are set
	IPV6 address		0x0006		0xC006(Both MSBs set)
	Adaptation Layer Indication 0xC006
It matches with IPV6 address when two
	
msbs are set

Please comment.

Regards
kashif

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 21 Mar 2002 08:52:56 -0600

Khan:

I think you miss a fundamental point in the RFC.

The upper level bits are NOT removed in the consideration of
a chunk type as unique.

So chunk type 0x80 is NOT the same as chunk type 0x00.
Nor is chunk type 0xC0 the same. 

What the upper bits do is partition the UNIQ 256 chunk types
into 4 catagories. These catagories tell you WHAT you should do
when you DON'T understand the chunk type. This does  NOT mean
you ignore the bits in any consideration you do...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)