Subject: [Tsvwg] RE: draft-riegel-tuexen-mobile-sctp-00.txt

From: Tuexen Michael <[email-masked]>
Date: Thu, 14 Mar 2002 11:19:57 +0100

Hi Armando,
see my comments below.
Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CS SE 5    E-mail: [email-masked]

> -----Original Message-----
> From:	Armando L. Caro Jr. [SMTP:[email-masked]]
> Sent:	Thursday, March 14, 2002 2:46 AM
> To:	[email-masked]
> Cc:	[email-masked]; [email-masked]
> Subject:	draft-riegel-tuexen-mobile-sctp-00.txt
> 
> Hi,
> 
> I have 2 questions about the mobile sctp draft...
> 
> In section 4.1: "During the time where the mobile client is reachable via
> two different access networks it has to make sure that it uses both
> links."  Why is this requirement necessary?
> 
	[Tuexen Michael]  We want the client to use two paths
	whenever it is possible. Then the client can also use SCTP
	parameters to compare the two paths (round trip time, 
	retransmission counter, ...). However, if you do not want
	to do this you can use SCTP also in a single-homed setup.

> In section 4.2: "The server must use multiple IP-addresses and a SCTP
> implementation supporting the extension [ADDIP]."  Why must the server be
> multihomed?
	[Tuexen Michael]  The server must be multihomed because
	we want the client to have two paths towards the server 
	(see above) to be able to make use of both network connections
	of the client. But if you only want to use single homed setup...

> Thanks...
> 
> ~armando
> 
> 0--                                                --0
> | Armando L. Caro Jr.     |       [email-masked] |
> | University of Delaware  |  www.cis.udel.edu/~acaro |
> 0--                                                --0

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Thu, 14 Mar 2002 09:20:09 -0500 (EST)

> 	to do this you can use SCTP also in a single-homed setup.

Well the example given in the document is that one link is used for
sending and the other for receiving. Using both links this way doesn't
give the client parameters to compare. Instead, both links would have to
be used for sending and receiving is some sort of load-balancing fashion.
Is this what you mean? Also, since the client is multihomed only during
the transient phase when handing off, is it likely that the client will
have enough time to determine these network parameters for comparison?

> 	of the client. But if you only want to use single homed setup...

Ok, I see that, but I don't see the advantage. Again, the client is
multihomed only during the transient phase when it is handing off... So
how useful is it that the client has 2 distinct paths?

~armando

0--                                                --0