Subject: [Tsvwg] Adjustment of the outstanding data counts

From: Guanhua Ye <[email-masked]>
Date: Thu, 28 Mar 2002 13:29:03 -0800 (PST)

Hi,

Can anyone help to explain the following wording in
SCTP RFC2960(page 79)?

Retransmission do not affect the total outstanding
data count. However, if the DATA chunk is
retransmitted onto a different destination address,
both the outstanding data counts on the new
destination address and the old destination address to
which the data chunk was last sent shall be adjust
accordingly.

So, what should be the appropiate procedure to adjust
the outstanding data counts on the "old destination
address"? 

Thanks,

Guanhua Ye

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Thu, 28 Mar 2002 16:57:18 -0500 (EST)

Hi Guanhua,

The idea is that the TSNs should be outstanding on the destination address
that they were last sent to. So when a retransmission is done, the
outstanding bytes for the OLD destination should be decremented to reflect
the size of the retransmission. Also, the NEW destination's oustanding
bytes is incremented to reflect the retransmission. In essence, the sender
moves the oustanding bytes (for the retransmitted TSNs) from the old
destination address to the new destination address.

As far as: "Retransmission do not affect the total outstanding data
count." ...the TOTAL oustanding remains unchanged.

Hope this helps!

~armando

0--                                                --0
| Armando L. Caro Jr.     |       [email-masked] |
| University of Delaware  |  www.cis.udel.edu/~acaro |
0--                                                --0