Subject: [Tsvwg] FW: [Sigtran] SCTP: receiving unsend messages

From: "Ong, Lyndon" <[email-masked]>
Date: Thu, 14 Mar 2002 15:00:40 -0800

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Thursday, March 14, 2002 3:01 PM
To: [email-masked]
Subject: [Sigtran] SCTP: receiving unsend messages

Hi,

In RFC2960 RECEIVE_UNSENT primitive does not have the context field (even
not as optional). This field might be very usefull to save us from redoing
(or doing in same ASP implementations) RK analysis, when we switchover to a
new association from a broken one. Was there a reason why it is not added or
just forgotten?

Another thing is, how is it possible to retrieve unsent messages by using
"Sockets API Extensions for SCTP" <draft-ietf-tsvwg-sctpsocket-03.txt>?

     Tolga

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Fri, 15 Mar 2002 05:37:37 -0600

> new association from a broken one. Was there a reason why it is not added or

Hmm..

I think this is a complete oversight. Not that we envisioned
implementing
exactly to the API example...

> "Sockets API Extensions for SCTP" <draft-ietf-tsvwg-sctpsocket-03.txt>?

In the sockets draft you do the following:

1) You subscribe to data_io_events
2) This  will get you a the events up the read
   pipe described in 5.3.1.4. Note included in this is
   the struct sctp_sndrcvinfo which INCLUDEs the context.
3) The flags field of this notification will tell you if
   the message was SENT or UN-SENT. Sent means it was
   put on the wire at least once but never ack'd. Unsent
   would mean it was in queue but NEVER got put on the wire.

This should give you BOTH your context and all of your messages... You
basically retrieve them by reading them off the socket :-)

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)