Subject: [Tsvwg] Fast Retransmission

From: "Khan, Mohammad" <[email-masked]>
Date: Wed, 6 Mar 2002 23:23:48 -0800

Hi All,
I have some confusion in SCTP improvement guide section 2.8.2 (New Text for
section 7.2.4 - 4).
It says "When fast retransmition is performed SCTP should ignore the value
of cwnd while sending the missed datagrams in one sctp packet(lesser than
the size of PMTU) and those datagrams which are still left for fast
retransmission would be retransmitted only when cwnd allows"
So is cwnd ignored for the first fast retransmission packet and later fast
retransmission packets must take care of cwnd?
Regards
kashif

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: [email-masked]
Date: Thu, 7 Mar 2002 09:49:25 +0200

Hi Kashif!

> -----Original Message-----
> From: ext Khan, Mohammad [mailto:[email-masked]]
> Sent: 07 March 2002 09:24
> To: [email-masked]'
> Subject: [Tsvwg] Fast Retransmission
> 
> 
> Hi All,

	The point is that you always allow at least one packet to be sent. One Fast Retransmission happens, you decrease your cwnd, and it is highly probable that when you have to send the FR packets, your cwnd will be completely used, and thus you wouldn't be able to send anything at all following the normal rules.

	What is meant in that paragraph is that you can always sent one packet. If the cwnd was already being used, you would be able to send just that single packet. The rest of TSNs will be marked for retransmission and will be sent later, when cwnd allows to do so (normally upon receipt of some SACKs).

	But this applies every time you mark packets for fast retransmission...

	I hope this clarifies your doubt...

	Bye!

	BR Iván Arias Rodríguez