Subject: RE: [Tsvwg] AddIP Clarification..

From: [email-masked]
Date: Sat, 2 Mar 2002 12:43:19 +0200

Hi Sandeep!

> Hi All, 
>   I need a clarification on AddIp draft . 
> 
> In section 4.3 D3a, the statment says " If an endpoint 
> receives an Error
> Cause TLV indicating that the IP address Add or IP address Deletion
> parameters was not understood, the endpoint MUST consider the 
> operation
> failed and [ MUST NOT attempt to send any subsequent Add or 
> Delete requests
> to the peer]. "
> 
> I would like to clarify the statment in the brakets [ ]. Does 
> above statment
> means that
> 
> a) Don't try resending the same request for Add/Del IP to peer.  OR 
> b) Don't send any Add/Del Ip request to peer for the life time of the
> association. ( In effect Disable the feature of Add/Del IP on 
> that assoc). 

I would say that the expected behavior is the b) one. If the peer doesn't support the extension, then it will never understand the ASCONF chunk and will always send you back an ERROR chunk. So you must disable the feature. As there is no need for previous exchange of parameters to check if the peer supports or not the AddIP extension, the real negotiation comes when you send an ASCONF chunk and the peer understand it or not. If it does, then it means that can make subsequent requests, if it does not, then no matter what you do, your ASCONF chunk will be always sent back in an ERROR chunk.

Sorry, you are speaking about parameters, not chunks. But basically you are in the same case...

However, I have a small doubt... Are Add/Delete and SetPrimary "different" extensions? I mean, if the ASCONF chunk is not understood, then of course you disable all the features provided by the draft, but, if and AddIP address is rejected and included in an ERROR chunk, does it mean that you can still try with the Set Primary parameter (I assume that AddIP and DeleteIP are both supported or not)? This is what I do (the peer in any case understands the ASCONF chunk, so...)

BR Iván Arias Rodríguez

> Thanks
> Sandeep 
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Sun, 03 Mar 2002 16:07:22 -0600

> However, I have a small doubt... Are Add/Delete and SetPrimary "different" extensions? I mean, if the ASCONF chunk is not understood, then of course you disable all the features provided by the dra…

Ivan:

We wrote this with the idea that you MAY only suport a piece of the
ASCONF.. aka set-primary or add/delete... but this may not make
sense... I mean after all if you go to the trouble to understand
an ASCONF why not understand all the parameters... 

But then that leaves the question of what you do if the peer
does do this silly thing and only 1/2 implement the draft?

I think this is why we left it this way..

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Tue, 5 Mar 2002 00:45:20 -0500 (EST)

> an ASCONF why not understand all the parameters...

It may not make much sense to support add ip and not delete ip (or
vice-versa)... however, supporting set-primary without supporting
add/delete is not that unthinkable.

> I think this is why we left it this way..

yeah, there really isn't any harm (or is there?) in letting the
implementation implement only part of the draft.

~armando

0--                                                --0
| Armando L. Caro Jr.     |       [email-masked] |
| University of Delaware  |  www.cis.udel.edu/~acaro |
0--                                                --0