Subject: RE: [Tsvwg] End point and association Address conflict

From: "Balani, Sandeep" <[email-masked]>
Date: Tue, 23 Apr 2002 18:18:21 -0700

Thanks Randy & Qiaobing, 
  Although i would like to add something here.  

So the inference of this discussion is : The source IP Addresses in an
association can be subset of Endpoint addresses.   Is this statment correct
? 

In the above case an Implmentation "MUST" make sure that whatever source IP
addresses are communicated during association intialisation should be used
while sending outoing packets. ( I.e. control U'r Src IP Addresses )

Also to extend the same logic, In the example I have shown below If i
terminate Association A1, I should also delete the entry of IP-C address in
Endpoint E1 Correct ????? 

Lastly this may never be TRUE but I would like to ask this question anyways.
In the example below I did'nt communicated IP-C on Association A2, But Lets
take a wild case that somehow I receive a SCTP packet on [ IP-C, Port-X,
D2, Port-P2] then SCTP will accept this Packet Is'nt it ?  As u will find
endpoint valid & Association  also .

Thanks
Sandeep

-----Original Message-----
From: Randall Stewart [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 5:46 PM
To: Balani, Sandeep
Cc: 'Qiaobing Xie'; Khan, Mohammad; [email-masked]
Subject: Re: [Tsvwg] End point and association Address conflict

The same scenario could exist outside of addip..

If I bind-all addresses.

setup an assocation (with IP-A/IP-B .. the ones I have)

now we hot-plug in a card.

I now setup a second association with all the
addresses I have (now IP-A/IP-B and IP-C).

You end up in the same place.. .and you must,
as Qiaobing said, assure that you only use IP addresses
that the peer knows about for sources..

Our ADDIP/DEL-IP allows this to happen as well.. we make
it so the user has to disable auto-asconf though to reach this state.

R

"Balani, Sandeep" wrote:
> 
> Hi Qiaobing,
>     I think the reason for asking such question was we have ADDIP &
DELETEIP
> procedure on an Association.
> 
> Now Assume we have an Endpoint
> 
> E1 =  [ IP-A, IP-B, and Port-X ] .
> 
> Now lets say i have 2 associations on endpoint E1.
> 
> A1 = [ Endpoint-E1 , DstAddr= D1, DstPort-P1 ]
> A2 = [ Endpoint-E2, DstAddr=D2,  DstPost-P2 ]
> 
> Now when i do an  ADDIP [ for Address IP-C ] on association A1, actually i
> am adding a source  IP address in Endpoint E1 i.e. [ IP-A, IP-B, IP-C,
> Port-X ], so that I will find an Endpoint for an incoming packet.
> 
> But IP-C is only used by Association A1, Not by A2.  That's the reason we
> have an Association using Subset of IP addresses from an Endpoint.
> 
> My Question is : Is it the intended behaviour in ADDIP/DELETEIP case ????
> 
> Many thanks
> sandeep
> -----Original Message-----
> From: Qiaobing Xie [mailto:[email-masked]]
> Sent: Tuesday, April 23, 2002 7:50 AM
> To: Khan, Mohammad
> Cc: [email-masked]; Pillai, Hari
> Subject: Re: [Tsvwg] End point and association Address conflict
> 
> Hi, Kashif,
> 
> Yes, you are allowed to do so, as long as you can guarantee that this
> endpoint will never use Z as the source IP address in any packet sent
> over this association. This is not hard to prevent if the endpoint has
> full control over the source IP address selection routine.
> 
> -Qiaobing
> 
> "Khan, Mohammad" wrote:
> >
> > Hi All,
> > I have following querry regarding endpoint and association source
> addresses.
> >
> > Suppose an Endpoint has three addresses X, Y and Z.
> >         An association which uses this endpoint and specifies only X and
Y
> > addresses as source IP addresses. Is it allowed?
> >
> > Regards
> > kashif
> >
> > _______________________________________________
> > tsvwg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/tsvwg
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Arun Prasad <[email-masked]>
Date: Wed, 24 Apr 2002 10:27:44 +0530

hi sandeep,

> while sending outoing packets. ( I.e. control U'r Src IP Addresses )

    Yes thats true, but its not always that easy to implement ie., if we implement
a generalised SCTP stack, covering many OS... then its really tough to keep track
of this feature (full control of Src IP Addresses) in the OS....
for example:
    Windows 2000 supports IP_HDR_INCL option ( ie., adding our own Source
Ip Addresses) in its raw socket implementation, but it doesnt guarentee that the
Src address filled by the user will be going in the IP Packet sent from that machine...
In this case the subset concept will fail.....
But for Linux, the OS guarentees the source Ip Address given by the user will be
filled in the IP packet sent.....
So Its more of the OS dependent... (and the OS can change this implementation
any time....) ... The thing is, we should have a generalised API for Raw sockets, as
we have for other protocols (like TCP, UDP etc...)

> endpoint valid & Association  also .

    The Receiving endpoint will search the Association for which the packet has
come with the following parameters { SrcAddr, SrcPort, RemAddr, RemPort}
In the above case since the SrcAddr is a different one (that is not in the Association's
pool) the received packet will not hit on the Association A2...
So no probs....

Thanks
-arun

--
****************************************************************
V.Arun Prasad
HCL Technologies Ltd.
51, Jawaharlal Nehru Road,
Ekkattuthangal,
Guindy Industrial Estate,
Chennai - 600097.

Contact # : 9144 - 2334174
            9144 - 2334181
            extn : 233
****************************************************************

---

From: Randall Stewart <[email-masked]>
Date: Wed, 24 Apr 2002 06:09:59 -0500

> while sending outoing packets. ( I.e. control U'r Src IP Addresses )
Yes. If you don't use ALL source addresses then you must
tightly control what you place in your outbound IP packets :>

This CAN causes issues with some O/S's.. for those you may
only be able to allow the bind-all type symantic..

> Endpoint E1 Correct ?????

I am a bit confused by the above. Does E1 have IP-C or not? 

I thought your example was that E1 bound all 3 A/B/C but for
some strange reason did NOT send C on one but did on another.

For our implementation an ENDPOINT binds a SET of addresses or
ALL addresses. So the address IP-C would NOT leave the
endpoint once the association ended...

> endpoint valid & Association  also .
Well, I am not sure how this could even happen.. the peer only knows
A/B so it is really a non-issue. But I will say the answer is
implementation dependant. Some implementations MAY not find the
association... Others MAY.. I think the point is moot since the
situation is not possible...

R