Subject: RE: [Tsvwg] End point and association Address conflict

From: "Balani, Sandeep" <[email-masked]>
Date: Tue, 23 Apr 2002 11:54:46 -0700

Hi Qiaobing, 
    I think the reason for asking such question was we have ADDIP & DELETEIP
procedure on an Association. 

Now Assume we have an Endpoint 

E1 =  [ IP-A, IP-B, and Port-X ] . 

Now lets say i have 2 associations on endpoint E1. 

A1 = [ Endpoint-E1 , DstAddr= D1, DstPort-P1 ] 
A2 = [ Endpoint-E2, DstAddr=D2,  DstPost-P2 ] 

Now when i do an  ADDIP [ for Address IP-C ] on association A1, actually i
am adding a source  IP address in Endpoint E1 i.e. [ IP-A, IP-B, IP-C,
Port-X ], so that I will find an Endpoint for an incoming packet. 

But IP-C is only used by Association A1, Not by A2.  That's the reason we
have an Association using Subset of IP addresses from an Endpoint.  

My Question is : Is it the intended behaviour in ADDIP/DELETEIP case ????

Many thanks
sandeep 
-----Original Message-----
From: Qiaobing Xie [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 7:50 AM
To: Khan, Mohammad
Cc: [email-masked]; Pillai, Hari
Subject: Re: [Tsvwg] End point and association Address conflict

Hi, Kashif,

Yes, you are allowed to do so, as long as you can guarantee that this
endpoint will never use Z as the source IP address in any packet sent
over this association. This is not hard to prevent if the endpoint has
full control over the source IP address selection routine.

-Qiaobing

"Khan, Mohammad" wrote:
> 
> Hi All,
> I have following querry regarding endpoint and association source
addresses.
> 
> Suppose an Endpoint has three addresses X, Y and Z.
>         An association which uses this endpoint and specifies only X and Y
> addresses as source IP addresses. Is it allowed?
> 
> Regards
> kashif
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Tue, 23 Apr 2002 19:46:17 -0500

The same scenario could exist outside of addip..

If I bind-all addresses.

setup an assocation (with IP-A/IP-B .. the ones I have)

now we hot-plug in a card.

I now setup a second association with all the
addresses I have (now IP-A/IP-B and IP-C).

You end up in the same place.. .and you must,
as Qiaobing said, assure that you only use IP addresses
that the peer knows about for sources..

Our ADDIP/DEL-IP allows this to happen as well.. we make
it so the user has to disable auto-asconf though to reach this state.

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 23 Apr 2002 14:42:52 -0500

"Balani, Sandeep" wrote:
> But IP-C is only used by Association A1, Not by A2.  

You imply here that, after the ADDIP call on E1, IP-C will start to
appear as the src addr in some packets sent to D1 over A1, but will
_never_ show up in packets sent to D2 by E2 over A2. If so, there should
be no problem and everything should work as intended.

As far as the above behavior is guaranteed, you have implemented it
right.

> That's the reason we

ditto.

-Qiaobing