Subject: RE: [Tsvwg] End point and association Address conflict

From: "Balani, Sandeep" <[email-masked]>
Date: Wed, 24 Apr 2002 15:21:31 -0700

Hi Randy, 

" No if E2 exists and has bound IPC/IPB your SHOULD NOT ALLOW IPC to be
added to A1E1... E1 does NOT have IPC bound.

The basic concept is that a ENDPOINT must BIND the address FIRST
BEFORE you can use the dynamic IP address add. If the IP address
exists in another ENDPOINT then it is the same as if you try
to bind an address that someone else has... i.e. you get an error.

In the case of binding all ... there is no problem. you always
get all IP addresses on the machine... But once you start subset
binding the ENDPOINT must bind the address BEFORE you can add it
to ANY of the ENDPOINTS associations..."

[ Sandeep ] I like this.  

Let me understand it, When u ADDIP address on an association, U add the new
IP address on then ENDPOINT first & then Add new IP address on the
Association which was specified by the user.  Correct ?

E1 = [ IPa, IPb, Port-X]
A1 = [ E1, IPz, Port-P1 ] 
A2 = [ E1, IPy, Port-P1 ]

For Adding IPc address on association A1, First Modify endpoint as follows :

ADDIP  [ IPc]
E1 = [ IPa, IPb, IPc, Port-X] 
A1 = [ E1, IPz, Port-P1 ] ( ASCONF for Adding IPc ) 
A2 = [ E1, IPy, Port-P1 ] ( This association will only be using IPa, IPb )

But when u delete an IP address from an Association U will ONLY Delete IP
Address, from Association NOT from ENDPOINT.  Correct ?? 

Now When I do a DELETEIP of IPc from  Association A1 :  

DeleteIP [ IPc] 

E1 = [ IPa, IPb,IPc, Port-X]  ( No Change in Endpoint )
A1 = [ E1, IPz, Port-P1 ]  ( ASCONF for Deleting IPc )
A2 = [ E1, IPy, Port-P1 ]  ( No Change this assoc is using IPa, IPb ) 

Is the above example correct ??

thanks
sandeep 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 25 Apr 2002 06:22:18 -0500

> to ANY of the ENDPOINTS associations..."

ok :>

> A2 = [ E1, IPy, Port-P1 ]

Yes.. the endpoint MUST gain the IP address BEFORE any of its
associations.
I guess one could do it at the same time too...

> Address, from Association NOT from ENDPOINT.  Correct ??
I suppose you COULD allow the endpoint to remove an address
BUT you would first probably want all of its associations to
remove the IP address... or all at the same time :>

> Is the above example correct ??

Yes, that would be ok

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)