Subject: Re: [Tsvwg] delayed SACK when sender is retransmitting

From: Mark Allman <[email-masked]>
Date: Tue, 02 Apr 2002 14:46:10 -0500

> Mark thinks its ok to SACK right away IF and only IF you have a
> gap that is being filled in.

Almost.

Mark thinks its OK to SACK immediatly if we are filling in all or
part of a gap **or** the incoming segment creates or enlarges a gap.

From RFC 2581:

   Out-of-order data segments SHOULD be acknowledged immediately, in
   order to accelerate loss recovery.  To trigger the fast retransmit
   algorithm, the receiver SHOULD send an immediate duplicate ACK when
   it receives a data segment above a gap in the sequence space.  To
   provide feedback to senders recovering from losses, the receiver
   SHOULD send an immediate ACK when it receives a data segment that
   fills in all or part of a gap in the sequence space.

allman

--
Mark Allman -- BBN/NASA GRC -- http://roland.grc.nasa.gov/~mallman/

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Wed, 03 Apr 2002 16:40:45 -0600

Mark:

I guess I was being a bit un-specific...

if a gap exists RFC2960 requires that you send a
SACK with no delay.. So the only case not covered that
you are stating needs to be SACK'd without delay is
when a TSN arrives and completes all outstanding
data. 

If there are still holes.. RFC2960 is going to make a
SACK go out right away.. so the only case not covered
is the "fills in the missing piece" case. 

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)