Subject: [Tsvwg] Retransmission Query

From: "Khan, Mohammad" <[email-masked]>
Date: Mon, 8 Apr 2002 00:24:02 -0700

Hi All,
Following is the querry regarding retransmission improvement described in
section 2.8 of
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpimpguide-03.txt .
What is the difference between normal retransmission and fast
retransmission? 
In section 2.8.2 of the same draft where new section has been added for RFC
2960 section 7.2.4
	In step 3 it says that Ignore the value of cwnd while performing the
fast retransmission.
	In step 5 it says that Mark the data chunks as being fast
retransmitted and thus ineligible for a subsequentfast 	retransmit but only
those allowed by cwnd would be retransmitted.
	Do the above two statements contradict?

Regards
kashif khan

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Arun Prasad <[email-masked]>
Date: Mon, 08 Apr 2002 13:41:17 +0530

hi kashif,
    Comments inline...

>         Do the above two statements contradict?

        I think the answer for the above question  could be understood once we
know the difference between "Packets marked for Fast Retransmission" and
"First Packet which is fast Retransmitted"......
    In step 3,  draft says about the "First Fast Retransmitted packet" and in
        step 5,  draft says about the " Waiting Marked Fast Retransmit packets"....

ie., Only the first packet sent  during Fast Retransmition should have the privilage
      to override the Congestion rules...... The rest of the data chunks which are
marked for Fast Retransmition , but couldnot be sent due to PMTU restriction,
will be waiting till the CWND allows it to send data....

I think there is no contradiction.....   Hope I didnt miss any point...

Thanks
-arun

--
****************************************************************
V.Arun Prasad
HCL Technologies Ltd.
51, Jawaharlal Nehru Road,
Ekkattuthangal,
Guindy Industrial Estate,
Chennai - 600097.

Contact # : 9144 - 2334174
            9144 - 2334181
            extn : 233
****************************************************************