Subject: RE: [Tsvwg] SCTP Unreliable Data Mode Extension

From: [email-masked]
Date: Wed, 8 May 2002 15:08:52 -0400

Doug,

Every ID states:

"Internet-Drafts are draft documents valid for a maximum of six months
and MAY be updated, replaced, or obsoleted by other documents at any
time.  It is inappropriate to use Internet-Drafts as reference
material or to cite them other than as 'work in progress'."

Barry Nagelberg

"Douglas Otis" <[email-masked]>
Sent by: [email-masked]
05/08/02 03:13 PM

        To:     "Tsvwg" <[email-masked]>
        cc: 
        Subject:        RE: [Tsvwg] SCTP Unreliable Data Mode Extension

Michael,

At the last Connect-A-Thon (worth 10 points for performance above and
beyond) were three implementations that correctly performed U-SCTP and two
implementations that handled the Add-IP/ASCONF draft.  Three 
implementations
would seem sufficient for IETF consideration.  What changes were you
expecting to make?  Any changes affecting operation under the current 
draft
would be a setback from a compliance standpoint.

 -Doug

On May 8, 2002 7:32 AM Michael Tuexen ([email-masked]) 
wrote:
>
> Doug,
>
> what do you mean by 'there is already interchange'?
>
> Best regards
> Michael
>
> Michael Tuexen    Tel.:   +49 89 722 47210
> Siemens AG        Fax:    +49 89 722 48212
> ICN WN CC SE 7    E-mail: [email-masked]
>
> > -----Original Message-----
> > From:                Douglas Otis [SMTP:[email-masked]]
> > Sent:                Wednesday, May 08, 2002 4:26 PM
> > To:          [email-masked]
> > Subject:             RE: [Tsvwg] SCTP Unreliable Data Mode Extension
> >
> > Michael,
> >
> > Why is a new ID needed?  There is already interchange with the current
> > draft.
> >
> >  -Doug
> >
> > On May 8, 2002 6:49 AM Michael Tuexen
> ([email-masked]) wrote:
> > >
> > > There should show up a new ID for PR-SCTP soon.
> > >
> > > Best regards
> > > Michael
> > >
> > > Michael Tuexen    Tel.:   +49 89 722 47210
> > > Siemens AG        Fax:    +49 89 722 48212
> > > ICN WN CC SE 7    E-mail: [email-masked]
> > >
> > > > -----Original Message-----
> > > > From:            [email-masked]
> > > [SMTP:[email-masked]]
> > > > Sent:            Wednesday, May 08, 2002 3:31 PM
> > > > To:              [email-masked]
> > > > Subject:                 [Tsvwg] SCTP Unreliable Data Mode 
Extension
> > > >
> > > > Does anyone know what is the current state of the proposals
> > > > that were in the Internet Draft titled "SCTP Unreliable Data
> > > > Mode Extension" <draft-ietf-sigtran-usctp-01.txt>?
> > > >
> > > > Barry Nagelberg
> > > >

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Douglas Otis" <[email-masked]>
Date: Wed, 8 May 2002 12:55:24 -0700

Barry,

That may well be, but for whatever reason, this 'orphaned' draft has
fostered implementations.  Change when there is interchange is still change
when there is interchange.  This draft could be recognized based on normal
merits.  Does anyone know why it has not been?  This does seem like an odd
situation.  What change to this draft is still required?

 -Doug

On May 8, 2002 12:09 PM Barry Nagelberg ([email-masked]) wrote:
> beyond) were three implementations that correctly performed U-SCTP and
> two implementations that handled the Add-IP/ASCONF draft.  Three
> implementations would seem sufficient for IETF consideration.  What
> changes were you expecting to make?  Any changes affecting operation
> under the current draft would be a setback from a compliance standpoint.
>
>  -Doug
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 8 May 2002 16:37:22 -0500

Randall,

On Wed, 08 May 2002, Randall Stewart wrote:
> 
> Note for bakeoff goers.. there will be points awarded for
> compliance to both this draft and the forthcoming -05 addip draft.
> 
> Hey.. I will even buy each team that has both working
> at the start of the bake-off a good German Beer :-)
> 

What I really need to know is: Would that be one beer
per team, or one beer per team member?  Is the transport
of beer reliable, or unreliable in this stream?

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Randall Stewart <[email-masked]>
Date: Wed, 08 May 2002 16:21:41 -0500

Barry:

I fully agree. drafts will change ... even though
these are fairly solid...

The new document should be out tommorrow for PR-SCTP (note
it is nolonger called U-SCTP)... it will be

draft-stewart-prsctp-00.txt

Note we blew it and failed to address it to the tsvwg... but
please all you tsvwg folks.. have a read tommorrow and provide
feedback..

Best Regards

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Randall Stewart <[email-masked]>
Date: Wed, 08 May 2002 18:08:44 -0500

> of beer reliable, or unreliable in this stream?

I will buy a beer for each of the developer's who
wrote code for the features :> (one beer per developer).

Of course they have to work first time correctly with
no bugs :>

And of course the beer is reliable... but unstable since
it will quickly disappear .. at least I would think :>

R

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 8 May 2002 20:50:49 -0500

Randall,

> it will quickly disappear .. at least I would think :>

Allrighty then.

--brian

---

From: "La Monte Henry Piggy Yarroll" <[email-masked]>
Date: Wed, 08 May 2002 22:50:49 -0500

> > it will quickly disappear .. at least I would think :>

Free software meets free beer?  Will code for beer?

---

From: "Phillip T. Conrad" <[email-masked]>
Date: Wed, 08 May 2002 18:10:13 -0400

>please all you tsvwg folks.. have a read tommorrow and provide

Or you can have a read right now if you are impatient...

http://netlab.cis.temple.edu/prsctp/draft-stewart-prsctp-00.txt

Enjoy!

Cheers,
Phill

PS: If you prefer, HTML and XML versions are also available:

http://netlab.cis.temple.edu/prsctp/draft-stewart-prsctp-00.html
http://netlab.cis.temple.edu/prsctp/draft-stewart-prsctp-00.xml

(The XML is the source code... the .txt and .html versions are produced
automatically by the software available from http://xml.resource.org. This 
is a really helpful tool for writing Internet-Drafts... it will
produce the final NROFF for the RFC-Editor too, if/when your draft gets to
that stage. Thanks to Marshall Rose and everyone else who made that
method possible!)