Subject: RE: [Tsvwg] Another Possible Argument for IFT over MPA

From: "Raghurama 'REDDY'" <[email-masked]>
Date: Thu, 31 Oct 2002 13:08:19 -0500

>> True.  But I am assuming that it is quite rare
>> in practice that IP actually delivers out of order.  Is
>> this correct?

some of the newer routers with parallel routing engines reorder packets
quite a lot.

--rr

From:	SMTP%"[email-masked]"  "Williams, Jim" 31-OCT-2002 13:02:31.76
To:	[email-masked]
CC:	[email-masked], [email-masked]
Subj:	RE: [Tsvwg] Another Possible Argument for IFT over MPA

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> 
> [...]
>
> A secondary reason is that IP does not guarantee in-order delivery.

True.  But I am assuming that it is quite rare
in practice that IP actually delivers out of order.  Is
this correct?

> [...]
> 
> Down != 0. Even ECN drops packets.

True again.  But if dropped packets are sufficiently
rare, the endpoint can handle them inefficiently
(but correctly) without significantly affecting
overall performance.  Hence my concern about
how rare they will actually be.
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 31 Oct 2002 12:56:39 -0600

Jim,

Does the path you're using touch the Internet? There are a number of "whoops, the Internet DOES reorder packets" papers available, if so.

(signed) curious