Subject: RE: [Tsvwg] Another Possible Argument for IFT over MPA

From: "Williams, Jim" <[email-masked]>
Date: Thu, 31 Oct 2002 12:54:57 -0500

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> 
> [...]
>
> A secondary reason is that IP does not guarantee in-order delivery.

True.  But I am assuming that it is quite rare
in practice that IP actually delivers out of order.  Is
this correct?

> [...]
> 
> Down != 0. Even ECN drops packets.

True again.  But if dropped packets are sufficiently
rare, the endpoint can handle them inefficiently
(but correctly) without significantly affecting
overall performance.  Hence my concern about
how rare they will actually be.
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Joe Touch <[email-masked]>
Date: Thu, 31 Oct 2002 10:39:21 -0800

> in practice that IP actually delivers out of order.  Is

It depends on the link. Some links are multiplexed or do load balancing; 
on those links, the out-of-order could be nontrivial. Either way, it's 
certainly a non-zero number.

There's at least some info at:
http://www-iepm.slac.stanford.edu/monitoring/reorder/

> how rare they will actually be.

See:

http://www.internettrafficreport.com/main.htm

(not rare enough, IMO).

----

Granted, the above are both selected 'anecdotally' from Google searches; 
if there are broader claims on which these assumptions are to be based 
in an ID, it would be useful to substantiate them with cited data, 
rather than speculation.

Joe