Subject: RE: [Tsvwg] Re: [SCTP]Congestion Control Parameters

From: [email-masked]
Date: Tue, 29 Oct 2002 14:14:36 +0200

> >	This is precisely the problem... If you change your 
> source address, logically the packets are sent from that 
> address... However, in most of the cases, physically nothing 
> changes: packets go out from the same network card with an 
> "artificial" change in the source address... :-/
> >
> So, in a typical IP implementation, is there not  IP "API 
> function" that 
> allows transport layer to choose outgoing interface?

	I'm afraid you cannot, in most of the cases... (I have never been able to do so). You set if you want the source address... Then the routing table chooses the network adapter depending on the destination... If you don't set the source address, the IP packet will carry the "real" IP address bound to the network adapter used...

	BR Iván Arias Rodríguez
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 29 Oct 2002 05:42:58 -0700

Ivan.Arias-Rodriguez,

Some do, some don't.  Pass IP_PKTINFO to sendmsg in Linux for
UDP or RAW sockets.

--brian

On Tue, 29 Oct 2002, [email-masked] wrote:

> 	I'm afraid you cannot, in most of the cases... (I have never been able
> 	to do so). You set if you want the source address... Then the routing
> 	table chooses the network adapter depending on the destination... If
> 	you don't set the source address, the IP packet will carry the "real"
> 	IP address bound to the network adapter used...
> 
> 	BR Iván Arias Rodríguez

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg