Subject: Re: [Tsvwg] AD review of: draft-ietf-sigtran-sctp-mib-07.txt

From: "La Monte Henry Piggy Yarroll" <[email-masked]>
Date: Fri, 04 Oct 2002 08:31:48 -0500

Sorry for the delayed response, but I just noticed a brief but
potentially critical issue.

On Mon, 2 Sep 2002 18:48:42 +0200 , "Javier Pastor-Balbas (ECE)" <javier.pastor
[email-masked]> wrote:
> Hi Bert, 
> 
> Please, see my comments inline...
> 
> > -----Original Message-----
> > From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> > Sent: Monday, August 26, 2002 5:45 PM
> > To: [email-masked]
> > Cc: Shawn Routhier (E-mail); Bert Wijnen (E-mail)
> > Subject: [Tsvwg] AD review of: draft-ietf-sigtran-sctp-mib-07.txt
...
> >   By the way, what is "Initiate Verification Tag" ??
> >   Probably known to SCTPers, but not to me... Maybe add a 
> >   REFERENCE clause to where it is defined.
> 
> Initiate Verification Tag is a unique value that could identify
> every assotiation univocally. We'll include the reference. 

I thought we ironed this out by the 2nd Bakeoff.  The Verification Tag
IS NOT a unique value that could identify every association
unequivocally.  It is STATISTICALLY unique, but NOT guaranteed unique.
It is a security mechanism to prevent blind connection hijacking, not
a mechanism for identifying associations.

The API draft introduces the concept of a 32 bit Association ID which
IS unique to an association on a given host.

If the MIB assumes that the Verification Tag is a unique identifier,
that is a serious flaw.
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Oct 2002 10:05:52 -0600

Yes, there is nothing in the RFC precluding two associations
on the same host from having the same Verficiation Tag.  In
fact, RFC 2960 says that it is generated "randomly".  The MIB
should not attempt to use this value as an index.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Fri, 04 Oct 2002 11:20:36 -0500

La Monte:

Great catch... you are 100% correct... you very well could
have V-Tags that are the same.. yours and when you consider
the peers... peer-a may choose the same tag as peer-b..

In fact  the local implementation can .. in theory choose the
same tag on different endpoints ..

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)