Subject: RE: [Tsvwg] Re: [SCTP]Congestion Control Parameters

From: [email-masked]
Date: Tue, 29 Oct 2002 13:43:01 +0200

snip...

> An endpoint cannot control completely the path used to send packets 
> (i.e. all routers), but can choose the source and destination 
> IP address.
> I believe that source-destination IP pairs identifies the path better 
> than only destination IP address.
> Why need I use different congestion control parameters for 
> different  IP 
> destination in SCTP ?
> Because if I change the IP destination address, probably the path 
> changes, and then all congestion control parameters MUST change.
> But the path changes also if  I change IP source address (if is it 
> possible..)  and, for the same reasons,  all congestion control 
> parameters MUST change.

	This is precisely the problem... If you change your source address, logically the packets are sent from that address... However, in most of the cases, physically nothing changes: packets go out from the same network card with an "artificial" change in the source address... :-/

	So, in most of the cases, changing the source address simply involves changes in the return path (the acks are sent back to the other address rather than the "real" source address).

	Besides, this situation in which you set your source address to an "artificial" ones is not really a nice thing... Imagine that you are in this situation, having two source addresses. In this case no matter which one of your network adapters stop working, the association will fail as soon as one of them crashes (you loss either the DATA or the SACKs, i.e., you never receive the SACKs for your DATA chunks). In this case the "reliability" added by the use of two adapters really becomes "unreliability" (you have about twice the possibilities of losing the connection).

	BR Iván Arias Rodríguez
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Andrea Senatore <[email-masked]>
Date: Tue, 29 Oct 2002 13:03:11 +0100

Hi Ivan,

>	This is precisely the problem... If you change your source address, logically the packets are sent from that address... However, in most of the cases, physically nothing changes: packets go out fro…
So, in a typical IP implementation, is there not  IP "API function" that 
allows transport layer to choose outgoing interface?

-- Andrea
========================================================
Andrea Senatore,     
Mail:    [email-masked],
Address: CoRiTeL c/o Università degli Studi di Salerno,
         Facoltà di Ingegneria,  via Ponte Don Melillo,
         84084 - FISCIANO (SA) - Italy
Tel:     +39 089 964012
Fax:     +39 089 964010
========================================================