Subject: Re: [rddp] Re: [Tsvwg] Re: "DO IT RIGHT", or "DON'T DO IT AT ALL"

From: Joe Touch <[email-masked]>
Date: Fri, 13 Dec 2002 08:51:52 -0800

Teisberg, Robert wrote:
...
> If it's *impossible* to achieve the desired behavior consistently with
> this definition, *that* may be an architectural flaw, but IMHO that
> hasn't been proved.
> 
> 
>>Hint: please read RFC793. Please check, especially, the rules 
>>for SEND 
>>and RECEIVE, and rules for when data can be made available.
>>
> 
> 
> And perhaps there is a valid interpretation of those rules that is less
> rigid than some here seem to believe.

Run it on your bank account and then I'll believe it.

The question is -

	- what breaks
	- what are the consequences

Joe

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Teisberg, Robert" <[email-masked]>
Date: Fri, 13 Dec 2002 10:47:29 -0600

> 
> Zero copy isn't the issue; availability of the data to the 
> layer above 
> TCP is. Delivering data to _ANY_ layer above TCP before all 
> data before 
> it has been received correctly is a violation of TCP semantics.

draft-culley-iwarp-mpa-01 defines Delivery as:

:   Delivery - (Delivered, Delivers) - For MPA, Delivery is defined as
:       the process of informing the ULP or consumer that a particular
:       PDU is ordered for use.  This is specifically different from
:       "passing the PDU to the ULP", which may generally occur in any
:       order, while the order of "Delivery" is strictly defined.

If the draft specifies behavior that is at odds with this definition,
it's a bug in the draft, not an architectural flaw.