Subject: RE: [Tsvwg] SCTP Message Fragmentation issue

From: [email-masked]
Date: Thu, 12 Dec 2002 14:35:55 +0200

Hi Iain!

	See my comments below...

> -----Original Message-----
> From: ext Iain.Thomson [mailto:[email-masked]]
> Sent: 12 December, 2002 13:32
> To: [email-masked]
> Subject: [Tsvwg] SCTP Message Fragmentation issue
> 
> 
> Forgive me if this has been discussed before.
> 
> If an SCTP sender is given a message to send which is larger 
> than the receiver's window, then this could result in a hang.
> The sender fragments the message and sends the fragments to 
> the receiver.
> The receiver is constrained to hold onto the fragments till 
> the whole message has been reconstructed.
> Eventually the receiver returns an a_rwnd of 0.  The 
> association hangs.
> 
> What's the solution?

	The only solution to this is making a partial delivery, and letting the upper user make the reassembly... Depending on your implementation you might be able to dynamically enlarge your window as well... :-/

	In any case, having a receiver with a receiver's window smaller than the maximum user message that the upper user can receive, is not really a very wise option...

> Perhaps during the initialisation of the association the 
> maximum message size can be negotiated/stated.

	I think this corresponds to the upper user. If you know that the messages can be up to X bytes, then try to establish an association having at least up to X bytes of receiver's window, or be ready for partial deliveries. If you are the server, you can set the default size to a big enough value...

	I hope it helps...

	BR Iván Arias Rodríguez

> Any ideas?
> Iain
> 
> =========================
>  Iain Thomson   
>  Thales Research & Technology (UK) Ltd                        
>            
>   [email-masked]    
> =========================
> 
> 
> 
> **********************************************************************
> This email and any files transmitted with it are intended solely for  
> the use of the individual or entity to whom they are addressed and may
> not be divulged to any third party without the express permission of 
> the originator.  Any views expressed in this message are those of the 
> individual sender, except where the sender specifically states them to
> be the views of Thales Research & Technology (UK) Ltd.
> **********************************************************************
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 12 Dec 2002 09:00:47 -0600

Ivan:

Actually our implementation has a break point.. where if you hit
a certain percentage of the rwnd and have a large message
being re-assembled it will kick off the partial delivery API...

This is the very reason it was put into RFC2960...

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)