Subject: RE: [Tsvwg] Re: [rddp] "DO IT RIGHT", or "DON'T DO IT AT ALL"

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 6 Dec 2002 08:58:32 -0600

Hi, Joe,

You mean most new protocols aren't running over HTTP? I'm thinking ftp://ftp.rfc-editor.org/in-notes/rfc3205.txt was written for a reason! :-}

I'm resisting the urge to ask what application prototocols have been widely deployed in the last two years that DON'T run over HTTP, but that's an APPS question, not a TSVWG question ... so I won't ...

Spencer

> -----Original Message-----
> From: Joe Touch [mailto:[email-masked]]
> Sent: Thursday, December 05, 2002 10:45 PM
> To: Caitlin Bestler
> Cc: Uri Elzur; Williams, Jim; [email-masked]; [email-masked]
> Subject: Re: [Tsvwg] Re: [rddp] "DO IT RIGHT", or "DON'T DO IT AT ALL"
>
> Caitlin Bestler wrote:
> >>
> > Most firewalls do not have port specific control of SCTP
> > associations. Ditto for load-balancers and NATs.
> 
> By that logic all new protocols should be embedded over HTTP, which 
> works through most firewalls.
> 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Joe Touch <[email-masked]>
Date: Fri, 06 Dec 2002 07:57:26 -0800

> I'm resisting the urge to ask what application prototocols have been widely deployed in the last two years that DON'T run over HTTP, but that's an APPS question, not a TSVWG question ... so I won't…

Instant messaging, which breaks NATs, but which people accepted anyway. 
It certainly is more widely deployed in the past year or two than 
before, and doesn't _usually_ run over HTTP.

Joe