Subject: RE: [Tsvwg] Concerns about SCTP

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 31 Dec 2002 08:18:20 -0600

Ummm, I've heard people say "should never be put on the Big-I Internet" in other contexts, but have NO idea how this could be a realistic expectation for a NIC...

Spencer

> -----Original Message-----
> From: Qiaobing Xie [mailto:[email-masked]]
> Sent: Monday, December 30, 2002 6:19 PM
> To: Caitlin Bestler
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Tsvwg] Concerns about SCTP
> 
> 
> Caitlin Bestler wrote:
> IMO, to be called a full compliant RFC2960 stack, you MUST do 
> the MUSTs
> in the spec. But this does not mean one is banned from 
> building his/her
> own not-full-compliant (i.e., customized) SCTP stack for his/her own
> special app uses. But such implementations should never be put on the
> "big I" Internet.
> > 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 31 Dec 2002 14:08:02 -0600

Not about the NIC itself, instead, it is about the specialized SCTP
stack used on the NIC. In such a scenario, the stack on the NIC is
stripped down (or feature-limited) to satisfy the resource constraints
and thus is not-fully-compliant to RFC2960, i.e., it will only works
well with that very particular type of application (RDDP in this case).
Such a stack should never be taken out of that environment and re-used
as a general purpose SCTP stack for building other types of applications
for big "I" Internet.

-Qiaobing