Subject: [Tsvwg] question on PDU alignment

From: "Williams, Jim" <[email-masked]>
Date: Wed, 4 Dec 2002 17:01:42 -0500

It has been proposed that is some cases
(i.e. RDDP) that PDUs be aligned with TCP segments.

I have a question as to how this interacts with
slow start and delayed ack.  I may be wrong
on some of my assumptions and welcome correction.

Certain TCP implementations may withhold sending
ACK until either 2*MSS data has been received, or
the delayed ack timer (up to 500ms) has expired.

At the beginning of slow start, the congestion
window will be 2*MSS which is normally sufficient
to trigger and ACK.  However with the addition
of alignment requirement, the sender may have
many PDUs to send which are (for instance) one
byte smaller than MSS.  So the sender must
either send two PDUs and wait for the delayed
ack timer on the remote end to expire before
sending any more data, or must send three
PDUs and violate the congestion window.

The right answer is probably to increase the 
initial size of the congestion window at the
beginning of slow start.

I may be all wet here, so I appreciate either
confirmation or correction.

Thanks, Jim
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Kevin Lahey <[email-masked]>
Date: Wed, 4 Dec 2002 15:45:23 -0800

On Wed, 4 Dec 2002 17:01:42 -0500 

> the delayed ack timer (up to 500ms) has expired.

My impression is that at least several modern TCP implementations have
moved away from sending ACKs based on the receiver's notion of the
MSS.  This can break badly in the face of path MTU discovery, when,
for instance, the receiver expects 1460-byte segments, but the path
permits only 536-byte segments.  Clearly, waiting for 2920 bytes before
ACKing would be problematic in this case.

IIRC, NetBSD sends an ACK for every two data packets, regardless of size.
I've heard (but can't confirm)  that Linux does all sorts of interesting 
stuff, including sending more frequent ACKs during what it guesses is
slow-start, to speed up the process.

In short, I would guess that this shouldn't be a concern.  I eagerly
anticipate my come-uppance.  :-)

Kevin
[email-masked]