Subject: Re: [Tsvwg] Re: "DO IT RIGHT", or "DON'T DO IT AT ALL"

From: Caitlin Bestler <[email-masked]>
Date: Thu, 12 Dec 2002 15:40:14 -0600

On 12/12/02, Joe Touch wrote:

>Lars Eggert wrote:
>> [email-masked] wrote:
>> 
>>> Our customers want a card that can connect to existing
>>> TCP nodes that don't support RDMA and connect to nodes
>>> using RDMA.
>> 
>> 
>> Make the new box dual-stack, so old boxes can talk to it
>> using the old protocol.
>
>FWIW, these proposals are basically "dual-stack in wolves
>clothing". They're dual stack buried deeply inside a
>single stack, IMO, for purely marketing purposes.
>

Most DDP implementers are planning on performing at least
DDP layer functions on the RNIC itself, and allowing the
same RNIC to handle non-DDP IP traffic.

That's an operational concern. Nobody wants to add
additional cables and consume extra switch ports just to
support RDMA.

There is also a desire to pass all non-DDP traffic through
the *existing* IP stack. The one that has already passed
security screens and QA tests with all of the existing
applications. Nobody wants to recertify all applications
because some new application needs a change to the existing
IP stack.

I would agree that sorting incoming Ethernet Frames to
determine which IP stack they are passed to is indeed being
buried pretty deeply. But the reasons are very technical,
and far from marketing fluff.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Joe Touch <[email-masked]>
Date: Thu, 12 Dec 2002 13:48:42 -0800

Caitlin Bestler wrote:
> the *existing* IP stack.

Anything that sends packets over IP does that, including SCTP. Creating 
a new transport protocol does that as well.

> and far from marketing fluff.

We were all talking about sorting within IP to a different transport 
layer, nobody had talked about sorting at the Ethernet layer.

The concept of dual stack here is at the transport layer and above, not 
at the entire network stack.

Joe