Subject: [Tsvwg] a query

From: amit somani <[email-masked]>
Date: Thu, 2 Jan 2003 20:50:00 +0000 (GMT)

Hello everyone,

We are a group of 3 students, Anup Deshpande, Prasad
Edlabadkar and Amit Somanai, from Pune Institute of
Computer Technology ,Pune , India. We are studying in
the 4th year(i.e. final year) of Electronics &
Telecommunication Engineering. We have a thrust for
cutting edge technology and love working on
challenging projects. We also like working on
innovative ideas. Right now we are working on our
final year project. The basic Project idea was to
transport SS7 signals using TCP. But then we came
across the disadvantages of TCP.
So we have three options with us :
1. Using SCTP instead of TCP at the transport level
2. Using Sigtran stack
3. Using UDP and develop some application level on it 

The problem is we don`t know which one is actually
feasible. We are implementing the project in Linux. Is
there any Linux Kernel that is supporting SCTP. Can
you suggest any small module that is still to
implemented?

Plz do reply 

________________________________________________________________________
Missed your favourite TV serial last night? Try the new, Yahoo! TV.
       visit http://in.tv.yahoo.com
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 02 Jan 2003 15:38:07 -0600

Amit:

A couple of suggestions for you:

1) Yes you can get a SCTP stack for linux (sourceforge I think) lk-sctp
    is the project name I think.

2) I do think this question is best addressed to the sigtran mailing
    list... (I think [email-masked] .. but please check on this). They
    specialize in SS7/IP ... tsvwg usually does not discuss SS7 but end
    to end transport issues..

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Sridhar Samudrala <[email-masked]>
Date: Thu, 2 Jan 2003 13:56:32 -0800 (PST)

> you suggest any small module that is still to

Yes. The 2.5 beta version of the linux kernel includes SCTP support.
You can download it from www.kernel.org. The latest release is 2.5.54. 
The SCTP implementation is currently under development but is in a usable
state. It supports the UDP-style SCTP sockets interface as defined
in the the following internet draft
   http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-05.txt
and will be compliant to RFC2960 when complete. 
You can find more information about the linux kernel SCTP project at
   http://sourceforge.net/projects/lksctp
 
Thanks
Sridhar