Subject: [Tsvwg] Re: [dccp] DCCP and UDP Lite

From: Dr G Fairhurst <[email-masked]>
Date: Fri, 31 Jan 2003 11:30:20 +0000

See in-line comments.

Michael Welzl wrote:
> 
> Hi everybody,
> 
> I just noticed the following sentences in the DCCP specification
> (page 11, section 5.1, "checksum length"):
> 
> "The checksum length field specifies what parts of the packet
> are covered by the checksum field. The checksum always covers
> at least the DCCP header, DCCP options, and a pseudoheader taken
> from the network-layer header (see below). If the checksum
> length field is zero, that is all the checksum covers."
> 
> The functionality of setting the checksum length field
> to zero closely resembles the capability of UDP Lite to
> receive erroneous payload packets and deliver them to the
> application.

The current rev of the ID (with IESG) for UDP-Lite is:
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-udp-lite-01.txt

This contains advice on this topic, that had not been previously
been included in draft-00. There is nothing dangerous with the
transport layer employing partial checksums providing:

   a) The checksum always protect the appropriate headers.

   b) It is the application that requests partial protection,
      it is not something that the transport layer decides to 
      use/not use.

> 
> I would say that:
> 
> EITHER:
> 
> - a comment should be included that states that erroneous
>   payload MUST NOT be delivered to the applications and may
>   only be used for congestion control purposes (or, possibly
>   better, the sentence about values other than 0 or 15 being
>   experimental should be changed to "values other than 15").
> 
> OR:
> 
> - UDP Lite should be accepted upon acceptance of DCCP.
> 

Option (1) declares this experimental.

Option (2)
Since UDP-Lite -01 is now with the IESG, awaiting AD action,
UDP-Lite should be published soon. Perhaps then, we should
look again at whether/how DCCP should follow this?
 
> This has nothing to do with personal preference - it's just
> similar functionality that caused a lot of discussions in
> the case of UDP Lite ...
> 
> Cheers,
> Michael
> 
> _______________________________________________
> dccp IETF mailing list: [email-masked]
> list info:  https://www1.ietf.org/mailman/listinfo/dccp
> wg charter: http://www.ietf.org/html.charters/dccp-charter.html
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Welzl <[email-masked]>
Date: 31 Jan 2003 09:34:08 +0100

Hi everybody,

I would say that:

EITHER:

OR:

Cheers,
Michael

---

From: Mark Handley <[email-masked]>
Date: Fri, 31 Jan 2003 09:51:40 -0800

>similar functionality that caused a lot of discussions in

It's not just similar - it was entirely inspired by UDP Lite.  We're
still rather undecided as to whether this is a useful function.  It
can easily be removed if there's pushback, but so far the comments
we've received have mostly been in favour.

It's clearly not a dangerous thing for a transport to allow this.
It's just rather pointless unless there are link-layers that might
take advantage of it, and applications that can make use of it.  

In our case it comes down to whether we have a better use for those
four bits.  Currently we think it's worth spending those 4 bits in
this way, given that the unreliable applications DCCP is primarily
intended to support are the sort of applications that might be able to
use this functionality.

 - Mark