Subject: [Tsvwg] question about SCTP

From: "Ling-Chih Kao" <[email-masked]>
Date: Wed, 14 May 2003 09:15:25 +0800

Hi, 

1. 
In the definition of RFC 2960, two SCTP endpoints MUST NOT have more than one SCTP association between them at any given time.

A host can configure into more than one SCTP assocations; therefore,
two Host can have more than one SCTP associations between them.
Is this statement correct?

2.
If SG accept 10000 call setup siganl from SS7, and the SG establish a SCTP association for these calls to a AS.
Some of the calls may be completed early, so the streams in the assocaition for these calls are idle. 
Can this idle streams be used for new SS7 setup calls? Or, new SS7 call setup must establish their new SCTP association.

Thanks

Ling-Chih Kao

---

From: Randall Stewart <[email-masked]>
Date: Wed, 14 May 2003 06:53:27 -0500

Ling-Chih:

Comments in line...

Ling-Chih Kao wrote:
> Hi,
>  
> 1.
> In the definition of RFC 2960, two SCTP endpoints MUST NOT have more 
> than one SCTP association between them at any given time.
>  

Yes, this is correct. To make it a real simple process think
in terms of TCP.. One can have a connection between two
TCP endpoints say:

Port:1111 IP-A  <------------------------->Port:1112 IP-Z

But one cannot have TWO seperate connections between the same
ports/host .. so you can't duplicate the above and have
two seperate connections identical..

The same is true for SCTP.. The only difference is that the
seperate sides may have more than one IP address i.e.:

Port:1111 IP-A1,IP-A2,IP-A3 <-------------->Port:1112 IP-Z1, IP-Z2

this is the only difference...

> 2.
> If SG accept 10000 call setup siganl from SS7, and the SG establish 
> a SCTP association for these calls to a AS.
> Can this idle streams be used for new SS7 setup calls? Or, new SS7 call 
> setup must establish their new SCTP association.
>  
This one is more of a sigtran question. It is up to the ULP to
decide how they will use the streams. One could envision doing
as you say.. a stream for each call and then at the termination
of a call reuse the stream for a new call.. however this MAY
not be how sigtran specified the ULP's for the SS7 adaption.. you
need to direct that question to the sigtran mailing list :>

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg