Subject: [Tsvwg] RE: PR-SCTP question.

From: [email-masked]
Date: Wed, 7 May 2003 15:20:01 +0300

Hi all!

	I cannot see that new document because it seems there is a problem with the server (HTTP 500 - Internal server error)

	However, I support the idea of Michael... If you treat the FWD-TSN as actually sending the TSNs, you just share the T3 timer and you don't add any extra complication...

	This way you continue keeping the "logic" of the protocol, not adding special rules for PR-SCTP that might not be very straightforward to guess...

	So I think that whenever you mark a TSN as dropped (probably when T3 timer expires or even due to FR), you send the FWD-TSN chunk (if possible to a secondary address as happens with the DATA chunks) and (re)start the T3 timer (of that address to which you sent the chunk). I'm thinking that if all your packets have a lifespan of let's say 200 ms, you could even modify the value of RTO.Min to that value so you quickly drop the stale TSNs...

	Everything is the same as when sending DATA chunks, except for the congestion parameters that don't change upon receipt of a SACK originated by a FWD-TSN. If the T3 timer expires again on already dropped TSNs (and so you have already sent the FWD-TSN) you should also update the RTO and cut down the cwnd and so on as usual, since this really means that the chunk was effectively lost (you didn't receive the SACK).

	This way, the stated problem would disappear, and in my opinion, everything would look more homogeneous and easier... What do you think?

	Thanks!

	BR Iván Arias Rodríguez

> -----Original Message-----
> From: ext Randall Stewart (cisco) [mailto:[email-masked]]
> Sent: Tuesday, 06 May, 2003 23:12
> To: Qiaobing Xie
> Cc: [email-masked]; Ronnie; [email-masked]'; Michael
> Tüxen; [email-masked]; Sctp-Impl (E-mail); Phillip T. Conrad; 
> Michael A.
> Ramalho
> Subject: Re: PR-SCTP question.
> 
> 
> Dear all:
> 
> I have made what I think are the appropriate changes and I would
> like you all to take a look. I have put up on
> 
> http://www.sctp.org
> 
> under the RFC page tab
> 
> A web link that will take you to a very nice diff of the 
> 02/03 version.
> 
> Please take a few moments to look at the diff's and suggest 
> any changes
> 
> I would like to get this sumbitted by Friday.
> 
> R
> 
> 
> 
> 
> Qiaobing Xie wrote:
> 
> >"Randall Stewart (cisco)" wrote:
> >  
> >
> >>Ronnie/Brian:
> >>
> >>I think this is the correct solution...
> >>
> >>It then requires:
> >>
> >>1) A note on the receiver side .. aka handle like data .. 
> you must start the
> >>    sack timer etc
> >>
> >>and
> >>
> >>2) A note on the sender side.. aka you don't stop the 
> t3-timer if there
> >>     is no outstanding data.. and when the t3-timer goes 
> off you should
> >>     send a fwd-tsn as well as any retransmmitted data..
> >>
> >>I will see if I can't cut and past from this email and do a bit
> >>of massaging to get the proper notes in the document..
> >>
> >>I too view the FWD-TSN as nothing but a compressed "heres the data
> >>I am skipping and not sending"...
> >>    
> >>
> >
> >This is indeed a good way to look at it. And I think the solution
> >summarized by Brian and Randy is the right approach.
> >
> >-Qiaobing
> >
> >
> >  
> >
> >>R
> >>
> >>
> >>    
> >>
> >
> >  
> >
> 
> 
> -- 
> Randall R. Stewart
> ITD
> Cisco Systems Inc.
> [email-masked] 815-342-5222(cell) or 815-477-2127(office)
> 
> 
> 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Wed, 07 May 2003 10:39:03 -0500

Hmm..

I will have to go have a look at what is going
on in my server..

I will send you (and anywone esle that requests it)
a copy of the html

Thanks

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)