Subject: [Tsvwg] Socket Programming

From: "Naveen.R.Ranga" <[email-masked]>
Date: Sat, 24 May 2003 12:53:07 -0700 (PDT)

Hi all,
   This is Naveen. New to the list. Anyways I was
curious in which document is it clear.. the concepts
of Socket Programming of SCTP of Multistreaming and
Multihoming. let me know if there are any particular
examples.thanks
naveen

=====
NAVEEN REDDY RANGA
600, South Webster Ave,#113
Norman,OK-73069.
Ph:(405)-329-5988
E-mail:
Personal: [email-masked]
College:[email-masked]

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Sat, 24 May 2003 18:00:44 -0500

You can have a look at

http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-06.txt

Also the upcoming edition (3rd) of Unix Network Programming Vol 1
will have about 3 chapters devoted to SCTP (available in Sept I think
... at least thats what amazon says)...

Happy reading

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: "Naveen.R.Ranga" <[email-masked]>
Date: Mon, 26 May 2003 13:25:02 -0700 (PDT)

Hi,
THanks for the reply. Actually I have this question.
Do we need to have root access in order to do socket
programming. Since I am trying to run the examples in
the package and also a few files I had written, but
they are not working.
Please advise me reg this.thanks
naveen

=====
NAVEEN REDDY RANGA

---

From: Randall Stewart <[email-masked]>
Date: Mon, 26 May 2003 16:41:43 -0500

> Please advise me reg this.thanks
Naveen:

I am unsure what you mean by "I am trying to run the
examples in the package"... what package?

If your kernel supports SCTP natively... you do not
need root access.

Linux as the lk-sctp project and I believe versions of
linux that are 2.5.xxx have a version of SCTP included.

For BSD systems you need to add the KAME IP stack .. get it
at
http://www.kame.net

After adding you must enable the option in your
kernel config.
options SCTP

Sun has a SCTP implementation as well.. but I do not know
the state of it.. it used to be something you picked up for Solaris
at the sun playground site.. maybe Kachong Poon can reply and
advise..

If you are attempting to use the Univ of Essen's code, I believe
they DO run in user space and thus need to have a
superuser ability to open a raw socket.

Regards

R

---

From: "Naveen.R.Ranga" <[email-masked]>
Date: Tue, 27 May 2003 11:52:54 -0700 (PDT)

Hi,
 I am all confused again. Let me know this. Does 
this
package I downloaded(from www.sctp.de) and set up in
my box support 
the
draft 
 draft-ietf-tsvwg-sctpsocket-06.txt 
if not where are all the system calls and the
functions to be used are defined. I am unable to
understand, whether there are two versions of 
socket
programming. or the same. The socket call(is this
defined here or not)...
"socket(int sd, SOCK_STREAM,IPPROTO_SCTP)"
   
 will this work if I include "sctp.h" in my 
files. if
not where could I get those. Please let me know the
user library to download and install. I am running on
a Red Hat Linux 9.x. I have read all of the socket api
draft and I find it easy using the actual system
calls. But I am unable to run the files of the sctp.de
packages. Prob all the system calls defined in the
draft are not used and I am confused with all this.
Please let me know which package to download and do
the socket programming for the SCTP(thats my goal). 
Please
let me know soon. THanks

nav

--- Randall Stewart <[email-masked]>

=====
NAVEEN REDDY RANGA

---

From: Randall Stewart <[email-masked]>
Date: Tue, 27 May 2003 16:16:19 -0500

Naveen:

This discussion really belongs on

[email-masked]

Not on the tsvwg.. but let me say what little I know..

You are using then a user space implementation.. My understanding
of there socket implementation is you hit their library instead
of the normal system lib that holds the socket api....
The folks from u of essen (Andreas)  or Michael Tuexen of munester
(who all belong to the sctp-impl list and have there own
   list as well if I remember right) would be better to answer
how their socket api works...  You would need to be root to
run it I am sure since it must open a raw socket...

If you want to get a TRUE socket api you need to either get
the
- KAME for BSD implementation (www.kame.net)
- Lk-SCTP for linux (sourceforge I think)
and I am unsure how far
SUN (Kacheong?) and IBM/AIX  are in their socket API ..

HP has a SCTP stack too.. but I am not sure if it
uses the socketapi (Jim Bound might be able to answer this)...

R

Naveen.R.Ranga wrote:
>>>THanks for the reply. Actually I have this
>>
>>question.
>>
>>>Do we need to have root access in order to do
>>
>>socket
>>
>>>programming. Since I am trying to run the examples
>>
>>in
>>
>>>the package and also a few files I had written,
>>
>>but
>>
>>>they are not working.

---

From: "Phillip T. Conrad" <[email-masked]>
Date: Tue, 27 May 2003 17:29:30 -0400

Naveen,
   You are addressing your questions to the wrong mailing list.   The 
support list for the www.sctp.de implementation is at 
http://www.sctp.de/mailman/listinfo/discussion  .    This mailing list 
([email-masked]) is for general discussion of transport layer design issues.

So if you want to suggest changes to draft-ietf-tsvwg-sctpsocket-06.txt , 
or want to ask questions about the design issues involved in the draft, you 
may do so here.  But if you want to know how to use the www.sctp.de 
implementation (or any other specific implementation) you should address 
your question to a software support list for that implementation.

Best Regards,
Phill Conrad

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 27 May 2003 16:39:07 -0500

Hi, Nav,

One thing to keep in mind is that the socket API draft (as well as the
RFC in the end) is NOT an IETF mandatory standards. Therefore, each
individual implementation will likely take the liberty to set its own
degree of compliance to the API. You need to read the release note(s) of
the implementation you are investigating very closely to understand what
API calls are and are not supported.

-Qiaobing