Subject: [Tsvwg] Re: PR-SCTP question.

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Wed, 07 May 2003 11:44:27 -0500

Sellar, Ronnie wrote:

>Randall:
>
>One further question.  Does the advanced.peer.ack.point get moved backwards
>if acked data that it relies on is reneged ?  This doesn't seem to be
>mentioned in the draft.
>
Hmm.. I am lost on this one..

I do

---1--------->
---2--------->
---3---------->
and now I decide I am placing 1 and 3 as
no longer abandoned...

Now  I send  fwd-tsn only for 1 (I can't get
by 2..since it is reliable.. or not yet abandonded).

I can't mention 3... until it is at the top..

I guess I am unclear on your quesitons.. can you illustrate with
soemthing like the above>?

>
>One or two typos: in rule A2) there's and 'rxt' that should be an 'rtx', 
>

good catch..

>and
>in section 3.4 there is a "drop" which perhaps should be an "abandon".
>
good catch..

I fixed both of these in the XML.

Thanks
R

>
>Thanks
>
>Ronnie
>
>PS I'm not in the office again till Monday but Gavin Shearer will be
>monitoring the newsgroup. 
>
>---
>Ronnie Sellar			Artesyn Communications Products
>Tel: +44 131 475 7015		Suite 4, 2 Anderson Place
>Fax: +44 131 475 7001		Edinburgh EH6 5NP
>mailto:[email-masked]	http://www.artesyncp.com
>
>  
>
>>-----Original Message-----
>>From: Randall Stewart (cisco) [mailto:[email-masked]]
>>Sent: 06 May 2003 21:12
>>To: Qiaobing Xie
>>Cc: [email-masked]; Ronnie; [email-masked]'; Michael
>>Tüxen; [email-masked]; Sctp-Impl (E-mail); Phillip T. Conrad; 
>>Michael A.
>>Ramalho
>>Subject: Re: PR-SCTP question.
>>
>>
>>Dear all:
>>
>>I have made what I think are the appropriate changes and I would
>>like you all to take a look. I have put up on
>>
>>http://www.sctp.org
>>
>>under the RFC page tab
>>
>>A web link that will take you to a very nice diff of the 
>>02/03 version.
>>
>>Please take a few moments to look at the diff's and suggest 
>>any changes
>>
>>I would like to get this sumbitted by Friday.
>>
>>R
>>
>>
>>
>>
>>Qiaobing Xie wrote:
>>
>>    
>>
>>>"Randall Stewart (cisco)" wrote:
>>> 
>>>
>>>      
>>>
>>>>Ronnie/Brian:
>>>>
>>>>I think this is the correct solution...
>>>>
>>>>It then requires:
>>>>
>>>>1) A note on the receiver side .. aka handle like data .. 
>>>>        
>>>>
>>you must start the
>>    
>>
>>>>   sack timer etc
>>>>
>>>>and
>>>>
>>>>2) A note on the sender side.. aka you don't stop the 
>>>>        
>>>>
>>t3-timer if there
>>    
>>
>>>>    is no outstanding data.. and when the t3-timer goes 
>>>>        
>>>>
>>off you should
>>    
>>
>>>>    send a fwd-tsn as well as any retransmmitted data..
>>>>
>>>>I will see if I can't cut and past from this email and do a bit
>>>>of massaging to get the proper notes in the document..
>>>>
>>>>I too view the FWD-TSN as nothing but a compressed "heres the data
>>>>I am skipping and not sending"...
>>>>   
>>>>
>>>>        
>>>>
>>>This is indeed a good way to look at it. And I think the solution
>>>summarized by Brian and Randy is the right approach.
>>>
>>>-Qiaobing
>>>
>>>
>>> 
>>>
>>>      
>>>
>>>>R
>>>>
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>> 
>>>
>>>      
>>>
>>-- 
>>Randall R. Stewart
>>ITD
>>Cisco Systems Inc.
>>[email-masked] 815-342-5222(cell) or 815-477-2127(office)
>>
>>    
>>
>
>
>  
>

-- 
Randall R. Stewart
ITD
Cisco Systems Inc.
[email-masked] 815-342-5222(cell) or 815-477-2127(office)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Sellar, Ronnie" <[email-masked]>
Date: Wed, 7 May 2003 16:35:48 +0100

Randall:

One or two typos: in rule A2) there's and 'rxt' that should be an 'rtx', and
in section 3.4 there is a "drop" which perhaps should be an "abandon".

Thanks

Ronnie

---