Subject: RE: [Tsvwg] Re: WGLC on draft-ietf-tsvwg-prsctp-00

From: "Sourabh Ladha (EED)" <[email-masked]>
Date: Thu, 26 Jun 2003 18:45:08 +0200

[snip]

>>Well yes maybe a corner case for example consider  a sender had retransmitted a chunk (the >original transmit being lost). And then abandoned it immediately. Lets assume that the 
>>retransmitted chunk reached after the FW-TSN (which can very well be considering 
>>multihomed endpoints and retransmission to the alternate). Then the reciever will generate >>a "fake" dup-tsn report. And blanton-allman's draft will be happy with the dup-tsn report 
>>and declare that retransmission spurious. Again I may agree that this is a corner case.
>

>So now you are doing 1 retransmission and a abandon chunk. Again.. the 
>sender still has the
>information and can KNOW that it abandoned the chunk and you are still 
>in a corner
>case... since  you do

> ----TSN(111)---->XlostX
> <4 strikes or T-O aka at LEAST 1/2 RTT + some amount>
> ----TSN(111)----->Retran--->
> "mark for abandon 111"
> <T-O aka at LEAST 1 RTO even greater than a RTT>
>  ------FWD-TSN(111)--------->

> Now in the above, where is the duplicate... the only way this would
> happen is if the retransmission gets held a full RTO the FWD-TSN arrives
> and then the retran arrives... this is IMO an even further strech than your
> first example..

maybe I am missing something.

My reading of the draft says that in F3> "If" any delay is applied to sending of FW-TSN chunk, it SHOULD NOT exceed 200 ms and MUST not exceed 500ms. I dont understand how this "at LEAST 1 RTO wait" in sending the FWD TSN comes. 

Anyway, one of the reasons of pointing this out was to to cause a thought process for blanton&allman's draft or any other work that "may" get influenced by PR-SCTP. If not, well and good.

>>
>>This comment had nothing to do with previous discussions on PR-SCTP. My comments about 
>>being aggressive were only linked to point (i) which I think you have now clarified. 

>I was wondering if you were not back addressing (i) so this
>comment is a non-issue with the F5) clearification...

Again, the F5 clarification clears this case.

-Sourabh

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Thu, 26 Jun 2003 11:54:51 -0500

Sourabh Ladha (EED) wrote:

>Anyway, one of the reasons of pointing this out was to to cause a thought process for blanton&allman's draft or any other work that "may" get influenced by PR-SCTP. If not, well and goo
>

You can't send the FWD-TSN until the left edge of the number
of TSN's is concurrent with your "abandoned chunk"

So

Consider

-----TSN101---->
-----TSN102----> XlostX
-----TSN103---->
..

at some point, 102 is abandoned.

the FWD-TSN(102)----->

can NOT be sent until:

1) TSN101 is acknowledged (aka the cumack is to the immediate left
     of the chunk to be forwarded... the left edge).

2) You would normally make a retransmission decision.

Just because you abandon it does not mean you tell the peer.. you have
to follow all or the normal RFC2960 procedures and ONLY when you
have marked it to abandon and you would have retransmitted and the
left edge is aligned will you send the FWD-TSN... you may decide
to delay a while... aka the 200ms but you send only at the normal
retrans opp..

R