Subject: RE: [Tsvwg] Re: WGLC on draft-ietf-tsvwg-prsctp-00

From: "Sourabh Ladha (EED)" <[email-masked]>
Date: Thu, 26 Jun 2003 19:04:22 +0200

You can't send the FWD-TSN until the left edge of the number
of TSN's is concurrent with your "abandoned chunk"

>Just because you abandon it does not mean you tell the peer.. you have
>to follow all or the normal RFC2960 procedures and ONLY when you
>have marked it to abandon and you would have retransmitted and the
>left edge is aligned will you send the FWD-TSN... you may decide
>to delay a while... aka the 200ms but you send only at the normal
>retrans opp..

So consider this:

everything before has been ACKed
-----TSN101----> XlostX
-----TSN102----> 
-----TSN103---->
-----TSN104---->
-----TSN105----> 

----TSN101-----> retransmitted
---abandon 101--
Now all your three points for sending a FW-TSN (as mentioned by you above) hold. So,
-----FW TSN----

Where is the "at least 1RTO"?? What if the FW TSN now reaches before TSN 101 going on a possible alternate path? 

-S

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Thu, 26 Jun 2003 12:40:56 -0500

>Now all your three points for sending a FW-TSN (as mentioned by you above) hold. So,
<<<<<here is your error... no stimulus

>-----FW TSN----
So you can't send the FWD-TSN here.. unless a T3 occured

>Where is the "at least 1RTO"?? What if the FW TSN now reaches before TSN 101 going on a possible alternate path? 
You have not reached a point to retransmit it yet...

You must hit a RTO or 4 strikes the key is in A4 and A5... you must
have a stimuleous to send the FWD-TSN i.e. a T3-Timeout (A5) or
a SACK (A4)..

You retransmitted 101 as shown for one of two reasons (before
it was abandoned)...

If you retransmitted TSN101 due to T3.. you are collapsed to 1 MTU and
have burnt that in sending TSN101. If the SACK of 105 is the 4th strike
for fast retransmit... you have sent 101 and have done a CWND reduction
and must await the T3 for 101 or a SACK for 101... so you have
no chance to send the FWD-TSN until a SACK or T3 occurs...

I see at a minimum a RTO or if 101 is sack'd no FWD-TSN is needed...

R