Subject: RE: [Tsvwg] Re: WGLC on draft-ietf-tsvwg-prsctp-00

From: "Sourabh Ladha (EED)" <[email-masked]>
Date: Thu, 26 Jun 2003 19:52:26 +0200

>You have not reached a point to retransmit it yet...

>You must hit a RTO or 4 strikes the key is in A4 and A5... you must
>have a stimuleous to send the FWD-TSN i.e. a T3-Timeout (A5) or
>a SACK (A4)..

>You retransmitted 101 as shown for one of two reasons (before
>it was abandoned)...

>If you retransmitted TSN101 due to T3.. you are collapsed to 1 MTU and
>have burnt that in sending TSN101. If the SACK of 105 is the 4th strike
>for fast retransmit... you have sent 101 and have done a CWND reduction
>and must await the T3 for 101 or a SACK for 101... so you have
>no chance to send the FWD-TSN until a SACK or T3 occurs...

Well, You could add another TSN106 to the picture if thats the case..and let me explain the stimulus again:

everything before has been ACKed
-----TSN101----> XlostX
-----TSN102----> 
-----TSN103---->
-----TSN104---->
-----TSN105----> 
-----TSN106---->
on the 4th missing report
>----TSN101-----> retransmitted
---abandon 101--
recieve another dupsack (coming due to TSN106)
Now all your three points for sending a FW-TSN (as mentioned by you above) hold and the stimulus. So,
----FWTSN-------

What about now?

-Sourabh

(last try ;) ..If it doesnt work..I'll see if I can spend some time making a scenario and get back then)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Thu, 26 Jun 2003 13:19:43 -0500

>Now all your three points for sending a FW-TSN (as mentioned by you above) hold and the stimulus. So,

Yes... now you finally have a case that you would send the fwd-tsn.. but 
so what... it
now still takes over 1/2 RTT for your FWD-TSN to arrive plus whatever 
difference
there is between sending 105 and 106... you have further complicated your
corner case in that the "abandon" time MUST be before the SACK for
106 arrives..  that is still a corner case.. routers generally
don't hold packets to dump them on innocent transport protocols later 
:-D they
forward or drop the packets...

You are still talking about occurances that are rare.. aka a routing 
reconvergance that
lets the TSN101 get held somewhere and then later put to the transport...

I don't see building a strange corner case is justification for 
changes... nor what
the changes would be..

I have of late thought that the sending time and RTT might be used in
conjunction with the "4 strikes" in making retransmission decisions.. this
could be a case where that would be worth doing.. if it were more than
an isolated corner case...

If we were really worried about this case (I look for others
to chime in on this) we could add something that said you MUST
wait until you would normally retransmit the chunk before sending
the FWD-TSN.. but I don't know if that is needed... not for this case
at least... it may well be how folks  implement PR-SCTP... but I don't 
see it
has a requirment to implement it that way...

R