Subject: [Tsvwg] need help in sctp

From: sridhar duggireddy <[email-masked]>
Date: Wed, 25 Feb 2004 18:51:56 -0500 (EST)

Hi,

   I am doing project on sctp protocol. I have to measure the throughput
performance of sctp. I am using the following procedure to measure the
bandwidth.

set bw1 0.0
set interval 0.025
proc record {} {
        global ns interval qmon sctp_tf bw1 sctp0

        set now [$ns now]

        set bw [$qmon set bdepartures_]

	# Bandwidth in Mbps
        set bw2 [expr ($bw-$bw1)*8/1000000/$interval]

	puts $sctp_tf "$bw2"

        set bw1 [expr $bw]

        $ns at $now "$sctp0 print cwnd_"

        $ns at [expr $now+$interval] "record"

}

I want to measure the bandwidth for every 0.025 seconds and take the
average of all bandwidths after the simulation time. When I am running the
above procedure I am getting all the bandwidth values as zero.

I think there is problem in setting the bandwidth variable (bw1). can
anyone explain how to solve this?

Thanks,
Sridhar.

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 26 Feb 2004 11:18:15 +0100

Please send ns-2 related questions to [email-masked]

Best regards
Michael