Subject: [Tsvwg] How to get configuration parameters in sctp

From: sridhar duggireddy <[email-masked]>
Date: Fri, 6 Feb 2004 16:17:57 -0500 (EST)

Hi,

 We are doing an experiment in which we want to compare various
versions of protocols like tcp Reno, Vegas, SCTP, Westwood etc. For this I
need to get the configuration parameters like ack_(highest acknowlegement
received), ssthresh_, cwnd_, rtt_, t_seq_no, dupacks_ for sctp. How to get
these parameters for sctp protocol? Below is the code for getting the
parameters in tcp versions...Here tcpSrc is the parameter for creating
connection like
set regtcp [$ns create-connection TCP/Vegas $n1 TCPSink $n2 1]

and then calling timeackReport $regtcp 0.025 Vegas

proc timeackReport {tcpSrc interval label} {
  global ns frep fre qmon flow tseq oldbytesD
 set now [$ns now]
  set time [expr int (([$ns now]+$interval)/10)]
  $ns at [expr [$ns now]+$interval] "timeackReport $tcpSrc $interval
$label"
  puts $label/time=[$ns now]/ack=[$tcpSrc set ack_]/ssthresh=[$tcpSrc set
ssthresh_]/CongW=[$tcpSrc set cwnd_]/RTT=[$tcpSrc set rtt_]/seq=[$t$

  puts $frep "time=[$ns now]/ack=[$tcpSrc set ack_]/ssthresh=[$tcpSrc set
ssthresh_]/CongW=[$tcpSrc set cwnd_]/RTT=[$tcpSrc set rtt_]/seq=[$t$

 puts $frep "at $now, bdepartures_=[$qmon set bdepartures_]"
 puts $frep "at $now, barrivals=[$qmon set barrivals_]"
 puts $frep "at $now, bdropss=[$qmon set bdrops_]"
# puts $frep "at $now, loss=[$n2 set nlost_]"

if {$now != 0} {
set tseq [$tcpSrc set t_seqno_]
set bytesD [ns-int64todbl $tseq]
#set tag [$ns now]

#puts $label/$bytesD       /[$ns now]/
puts $fre "[$ns now] [$tcpSrc set ack_] [$tcpSrc set ssthresh_] [$tcpSrc
set cwnd_] [$tcpSrc set rtt_] [$tcpSrc set t_seqno_] [$qmon set pdep$
set oldbytesD [expr $bytesD]

Thanks,
Sridhar.

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Randall R. Stewart (home)" <[email-masked]>
Date: Mon, 09 Feb 2004 18:48:35 -0600

sridhar duggireddy wrote:

>these parameters for sctp protocol?
>
Sridhar:

I don't know if it will get all your values.. but the socket api
I know has some of them.. take a look at

draft-ietf-tsvwg-sctpsocket-07.txt

And see if you can get what you want from the socket-api.
If so you can find these in KAME-SCTP (for BSD), LK-SCTP (for linux)
and I think Solaris and the U-of-Essen also support these fields..

Hope that helps

R

> Below is the code for getting the

-- 
Randall R. Stewart
815-477-2127 (office)
815-342-5222 (cell phone)