Subject: [Fwd: Re: [Tsvwg] SCTP - COOKIE ECHO handling when association doesnot exist's]

From: bhanu <[email-masked]>
Date: Sat, 04 Sep 2004 16:17:47 +0530

-------- Original Message --------
Subject: Re: [Tsvwg] SCTP - COOKIE ECHO handling when association 
doesnot exist's
Date: Sat, 04 Sep 2004 15:49:56 +0530
From: bhanu <[email-masked]>
To: [email-masked]
References: <[email-masked]> 
<[email-masked]> 
<[email-masked]> 
<[email-masked]> 
<[email-masked]> 
<[email-masked]> 
<[email-masked]>

Brian,

Consider the following scenario:

1. The End point "A" sent INIT to End point "B"
2. The End point "B" sent INIT to End point "A" (Both sides initiating 
association)
3. INIT Ack sent from End point "A" to End point "B"
4. Cookie Echo sent from End point "B" to End point "A".
5. Meanwhile End point "A" crashes (no Cookie Ack sent) and starts 
sending INIT again.
6. The End point "B" will time out and the same Cookie Echo is sent 
again from End point "B" to End point "A".

So now what should be the action from End point "B"..?
(Note : Now the situation at "B" is that it has TCB, as it has started 
INIT and it has recieved COOKIE ECHO)

Regards
Bhanu.

Brian F. G. Bidulock wrote:

>bhanu,
>
>If it does not fall into any of the categories of 5.2.4, then I
>believe it is a new asssociation forming.  Is it not?
>
>--brian
>
>On Fri, 03 Sep 2004, bhanu wrote:
>
>  
>
>>   Please find the corrected question as follows:
>>   What is the action needs to be done for this Cookie Echo?
>>   bhanu wrote:
>>
>>   Brian,
>>          I  want  to  know the action needs to be done for the following
>>   case.
>>   1. INIT from End point "A" to End point "B"
>>   2. INIT from End point "B" to End point "A"  (INIT Collision).
>>   3. INIT Ack from End point "A" to End point "B"
>>   4. Cookie Echo from End point "B" to End point "A".
>>   5. Cookie Ack from End point "A" to End point "B"
>>   6. Heartbeat from End point "A" to End point "B"
>>   7. DATA from End point "A" to End point "B".
>>   8. Heartbeat Ack from End point "B" to End point "A"
>>   Association is UP.
>>   1. Abort from End point "B" to End point "A"
>>   2. INIT from End point "A" to End point "B"
>>   3.  Cookie Echo from End point "B" to End point "A" (similar to Cookie
>>   Echo in the previous association.)
>>   Is  it  to be considered as OOTB? If not, it does not fall into any of
>>   the  actions  mentioned  in  5.2.4  of  RFC  2960  to  enter  into the
>>   established state. What is the action needs to be done for this Cookie
>>   Ack?
>>   thanks,
>>   bhanu
>>   Brian F. G. Bidulock wrote:
>>
>>bhanu,
>>
>>I believe the SCTP IG has a section dicussing what to do when the
>>vtag does not match (but other things do), particularly with regard
>>to COOKIE-ECHO and restart behavior.  Have you looked at the SCTP IG?
>>
>>--brian
>>
>>    
>>
>
>  
>

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 4 Sep 2004 11:30:11 -0600

bhanu,

Again, the association should just form if the recovered endpoint is
still capable of processing the contents of the cookie.  If it cannot,
one of the proscribed actions in 5.2.4 should be taken (usually an
ABORT sent).

--brian

On Sat, 04 Sep 2004, bhanu wrote:

>    From: bhanu [1]<[email-masked]>
>    To: [2][email-masked]
>    References:               [3]<[email-masked]>
>    [4]<[email-masked]>
>    [5]<[email-masked]>
>    [6]<[email-masked]>
>    [7]<[email-masked]>
>    [8]<[email-masked]>
>    [9]<[email-masked]>
> 
>    Brian,
> References
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. mailto:[email-masked]
>    4. mailto:[email-masked]
>    5. mailto:[email-masked]
>    6. mailto:[email-masked]
>    7. mailto:[email-masked]
>    8. mailto:[email-masked]
>    9. mailto:[email-masked]

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Randall Stewart <[email-masked]>
Date: Thu, 16 Sep 2004 05:59:45 -0400

> 2. The End point "B" sent INIT to End point "A" (Both sides initiating 

So here both endpoints are in COOKIE-WAIT
> 4. Cookie Echo sent from End point "B" to End point "A".
ok...
> 5. Meanwhile End point "A" crashes (no Cookie Ack sent) and starts 
So the machine crashes and goes through a complete restart...

> again from End point "B" to End point "A".

ok..
> INIT and it has recieved COOKIE ECHO)

Well.. this is similar to page 110 in the SCTP I-G book..(only
the crashing A is Z in the illustration)

basically endpoint A will discard the cookie always, since the
tags don't match..

B however should respond with an INIT-ACK (even in the COOKIE-ECHOED
state) and a new COOKIE. Its internal tags (tie-tag etc) will be setup
correctly... Thus it will adopt the cookie when A echoes it and
the association will come up..

R