Subject: [Tsvwg] chunk bundling

From: Brad Penoff <[email-masked]>
Date: Tue, 19 Oct 2004 16:45:51 -0700 (PDT)

Greetings,

We have been reading about the ability to perform chunk bundling within 
SCTP, specifically the coalescing of multiple DATA chunks into a single 
SCTP packet.  It is said that this is an option by the application 
programmer; is the only control simply the ability to turn off/on Nagle's 
algorithm (SCTP_NODELAY), or is there a finer degree of control (i.e. can 
we pack a packet with specific DATA chunks) ?  If there are other ways, 
what are they? If SCTP_NODELAY is the only option, is this saying that 
chunk bundling is applicable to an entire association rather than per 
stream?

Thanks,
brad

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 20 Oct 2004 12:36:41 -0500

Brad,

To put it in a simple way, SCTP DATA chunk bundling is an opportunistic procedure - where 
the SCTP sender (not the application above) always tries to bundle as many ready-to-go DATA 
chunks as the current congestion window allows. There are only very few rules, such as that 
chunks marked for retrans will go first, etc. Turning SCTP_NODELAY off/on by the app simply 
increases/decreases the __opportunity__ for the SCTP sender to bundle, and that's all.

The idea for this is to maximize the bandwidth efficiency. I am afraid if we create finer 
controls to this bundling procedure (such as dis-allowing bundling across streams), we will 
be less successful in maximizing the bandwidth efficiency, which will mean poorer achievable 
throughput.

regards,
-Qiaobing

Brad Penoff wrote:

> programmer; is the only control simply the ability to turn off/on 
> Nagle's algorithm (SCTP_NODELAY), or is there a finer degree of control 
> (i.e. can we pack a packet with specific DATA chunks) ?  If there are 
> other ways, what are they? If SCTP_NODELAY is the only option, is this 
> saying that chunk bundling is applicable to an entire association rather 
> than per stream?
> 
> Thanks,
> brad
>