Subject: RE: [Tsvwg] Comments about draft-ietf-tsvwg-sctp-auth-00.txt

From: [email-masked]
Date: Mon, 19 Sep 2005 14:57:35 +0300

>> 	- Section 7, second example: Actually, I don't think 
>that such a 
>> message exchange is legal, as when the client sends the COOKIE-ECHO; 
>> AUTH; DATA it is still in the COOKIE-ECHOED state and not in the 
>> ESTABLISHED one as stated in section 6.2 above.
>After the COOKIE-ECHO has been processed the left side is in 
>ESTABLISHED I think. This is just the normal bundling of DATA 
>with the COOKIE-ECHO.

	Well... When you send the COOKIE-ECHO chunk you enter the COOKIE-ECHOED state, and still need the COOKIE ACK to enter the ESTABLISHED one. So, the left side is sending an AUTH chunk while not yet in the ESTABLISHED state, which I think is not legal as per 6.2. :-/=

	BR Iván Arias Rodríguez

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 19 Sep 2005 17:56:12 +0200

Hi Ivan,

I see, you are right. The example is not allowed by the first sentence
in 6.2.

    Chunks can only be authenticated when the SCTP association is in the
    ESTABLISHED state.

That restriction will be removed in the next version. The example is 
then
allowed.

It's time to submit the new version (which has all your comments in...)

Best regards
Michael

On Sep 19, 2005, at 13:57 Uhr, <[email-masked]> wrote:

> 	Well... When you send the COOKIE-ECHO chunk you enter the 
> COOKIE-ECHOED state, and still need the COOKIE ACK to enter the 
> ESTABLISHED one. So, the left side is sending an AUTH chunk while not 
> yet in the ESTABLISHED state, which I think is not legal as per 6.2. 
> :-/=
>
> 	BR Iván Arias Rodríguez
>