Subject: AW: [Tsvwg] ICMP issue with SCTP IG

From: "Schruefer, Wolfgang" <[email-masked]>
Date: Wed, 14 Sep 2005 15:35:26 +0200

Hi,

like in the whole ICMP section I would avoid the uppercase >MUST<'s (as
the whole ICMP handling is only 'should be followed'), e.g that way:

"
ICMP8) If the ICMP code is an "Unrecognized next header type
        encountered" or a "Protocol Unreachable" and the
        association state is COOKIE-WAIT, the packet must
        be examined to determine if it contains an INIT. If
        it does not, then the packet is silently discarded. If
        it does hold an INIT, then if there is enough information
        to examine the initiation tag, compare it with the
        association tag. If the tags match then the ICMP message
        it is treated it as an ABORT. If there is NOT enough
        information in the ICMP message to examine the initiation
        tag or the tags do NOT match, then the packet
        is silently discarded.
"

Best Regards
Wolfgang

> Randall Stewart wrote:
> 
> "
> ICMP8) If the ICMP code is an "Unrecognized next header type
>         encountered" or a "Protocol Unreachable" and the
>         association state is COOKIE-WAIT, the packet must
>         be examined to determine if it contains an INIT. If
>         it does not, then the packet is silently discarded. If
>         it does hold an INIT, then if there is enough information
>         to examine the initiation tag, compare it with the
>         association tag. If the tags match then the ICMP message
>         MUST be treated as an ABORT. If there is NOT enough
>         information in the ICMP message to examine the initiation
>         tag or the tags do NOT match, then the packet
>         MUST be silently discarded.
> "
> 
> That will mean another spin of the I-G.. I guess I was to 
> quick in trying to get all the corrections in :->
> 
> Comments on this insert?
> 
> 
> R
> 
> 
> --
> Randall Stewart
> 803-345-0369 <or> 815-342-5222(cell)
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Wed, 14 Sep 2005 09:42:02 -0400

>         tag or the tags do NOT match, then the packet

Ok..

this seem reasonable.. since it is an appendix and no other
ICMPx) has a MUST ... I will make them all "must" instead
of MUST..

R