Subject: [Tsvwg] Re: SCTP and multicast (fwd)

From: Randall Stewart <[email-masked]>
Date: Thu, 15 Sep 2005 13:53:27 -0400

Liangping:

As 2960 currently reads you MUST discard non-unicast packets.
This means Multi-cast and Broad-cast .. it also means
Any-Cast too.

Now the I-G softens this to SHOULD discard.. and the
reason it does this is that a combination of ADD-IP and
Anycast would work very nicely together...

But, that all being said, how would you expect Multi-cast or
Broadcast to work with SCTP... after all SCTP creates state
in each of two communicating endpoints. If you sent something
out M/B-cast you get multiple endpoints... responding..
very confusing to an SCTP stack... :-D

I don't actually know how one would make such a thing work.. it
might be possible but you would need to further define what
it was for...

R

Liangping Ma wrote:
> Hello Randall,
> 
> I could not send my question to the [email-masked] list so I send it 
> directly to you and other people that participate a lot in the 
> discussions. Maybe you guys can help me out.
> 
> I have checked RFC 2960 and RFC 3758, but did not find the description 
> about how to support multicast and broadcast. Is it doable? Would you 
> give some references if there are any out there?
> 
> Thanks a lot!
> 
> - Liangping
> 
> P.S. Please feel free to forward this email to the tsvwg mailing list.
> 
> ---------- Forwarded message ----------
> Date: Wed, 14 Sep 2005 11:52:00 -0400 (EDT)
> From: Liangping Ma <[email-masked]>
> To: [email-masked]
> Subject: SCTP and multicast
> 
> Hello everyone,
> 
> Does anyone know whether SCTP can be used for multicast? If yes, I'd 
> appreciate it if you could point out some reference.
> 
> Thanks!
> 
> - Liangping
> 
> 
> 

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 15 Sep 2005 12:00:39 -0600

Randall,

> very confusing to an SCTP stack... :-D

Not necessarily, perhaps only in the B case and not the M case.
Multicast membership could be established to only contain two
peer's multihomed addresses.

> might be possible but you would need to further define what

The best purpose for multi-/broadcast that I could think of was
for sending INIT messages to rapidly establish an association in
a redundant manner to all multihomed addresses simultaneously.
But it is probably too big of a security threat to use on anything
but captive networks.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Liangping Ma <[email-masked]>
Date: Thu, 15 Sep 2005 13:00:02 -0400 (EDT)

Hello Randall,

I have checked RFC 2960 and RFC 3758, but did not find the description 
about how to support multicast and broadcast. Is it doable? Would you give 
some references if there are any out there?

Thanks a lot!

- Liangping

---------- Forwarded message ----------
Date: Wed, 14 Sep 2005 11:52:00 -0400 (EDT)
From: Liangping Ma <[email-masked]>
To: [email-masked]
Subject: SCTP and multicast

Hello everyone,

Does anyone know whether SCTP can be used for multicast? If yes, I'd appreciate 
it if you could point out some reference.

Thanks!

- Liangping

---

From: Liangping Ma <[email-masked]>
Date: Thu, 15 Sep 2005 15:19:01 -0400 (EDT)

Hello Brian and Randall,

First thanks a lot for your prompt responses. I will put my comments 
inline.

> peer's multihomed addresses.

Multicast is usually done in the network layer. Without a router involved, 
the traffic to different destinations will be stand alone. That is, for each 
destination, there will be a flow, and these flows are independently 
handled by the router.

> But it is probably too big of a security threat to use on anything

SCTP has been extended to have the partial reliability capability. That is 
good for applications such as media streaming. But a lot of times, it is 
desirable to have some kind of multicast mechanisms to efficiently support 
media streaming. For example, stream a conference to hundereds of clients. 
In this case, it is not a good idea to establish a separate connection 
between the server and each client.

So my question is how to take full advantage of the partial reliability 
extension of SCTP.

There is a paper by Yong about SCTP multicast: M-SCTP: Transport Layer 
Multicasting Protocol. In that paper, multicast is done by recursive 
unicast. I do not think that is an efficient way (maybe I am wrong).

Thanks.

- Liangping

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 15 Sep 2005 19:18:22 +0200

Hi Liangping,

reliable transport and (multi|broadcast)cast is pretty difficult.

I'm not sure, but there is an IRFT WG on reliable multicast, or
is it an IETF WG. The problems are not related to SCTP in
particular, but how to do CC and reliability using 
(multi|broadcast)cast.

Best regards
Michael