Subject: RE: [NSIS] Re: [Tsvwg] Re: additions on draft-floyd-ecn-alternate s-02.txt

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 23 Nov 2005 10:34:23 +0100

Hi Bob,
 
|Why don't the changes to RSVP and NSIS (that I 
|repeat below) resolve the conflict between 
|end-to-end and edge-to-edge semantics? The 
|conflict only occurs for flows within a 
|signalled reservation, so the conflict can be 
|resolved in the signalling. If the conflict 
|is resolved, this proposal should satisfy 
|Sally's requirements for specifying alternate 
|semantics for ECN in an edge-edge scenario.

I read one of your drafts. If I understood things 
right, you virtually limit the resources available 
to packets of a certain DSCP. Once the limit 
is approached on any link operated according to 
your scheme, this is indicated by using ECN. 
Finally, a router interprets and re-writes the 
ECN field.

My personal view is:

- The way you apply ECN within the backbone seems 
  to be conforming to the aims of ECN. There in 
  fact is a congestion of the specific resource 
  identified by a packets DSCP.

- I personally may prefer the ECN field remaining 
  unchanged, once congestion is indicated. Wouldn't 
  this make your proposed architecture ECN conformant? 
  Further, capable end-systems could renegotiate 
  Codecs.

As an additional result, a few more sessions could 
be accepted. 

Regards,

Rüdiger

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 23 Nov 2005 12:01:18 +0100

Hi Ruediger

The same protocol semantics (in terms of (pre-)congestion notification
 and severe congestion [pre-emption]) are supported by using
DSCP re-marking within the edge to edge domain.

In this way the end-to-end ECN filed is not changed within
the edge to edge domain and capable end-systems
are able to renegotiate Codecs.

Best Regards,
Georgios

----- Original Message ----- 
From: "Geib, Ruediger" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>
Sent: Wednesday, November 23, 2005 10:34 AM
Subject: RE: [NSIS] Re: [Tsvwg] Re: additions on 
draft-floyd-ecn-alternates-02.txt

> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
>