Subject: [Tsvwg] Comments about draft-ietf-tsvwg-sctp-auth-01.txt

From: [email-masked]
Date: Wed, 16 Nov 2005 22:05:07 +0200

Hi!

	I have some few comments about the last version of the Authenticated Chunks for SCTP draft:

	- Page 5: It says that "The CHUNKS parameter MUST be included once...", hmmm, unless it is empty, in which case it is not needed.

	- Page 6: In the Parameter Length, it says "This value is the length of the number of HMAC identifiers times 2 plus 4." My English is far from perfect, but I guess that something like "This value is the length of the number of HMAC identifiers multiplied by 2 plus 4."

	- Page 9, first paragraph of section 6.1: It still says there that the RANDOM parameter contains a 32-byte random number.

	- Page 12, section 8: I guess IANA has also something to say about the Error Cause 0x0105 for "Unsupported HMAC Identifier" ;-)= And the last paragraph speaks about 3 values, I guess it should say 5.

	- Page 13, section 11: The Reference for [7] (SHA-1) is still missing :-/=

	That's all!

	Thanks!

	BR Iván Arias Rodríguez

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 17 Nov 2005 17:24:51 +0100

Hi,

see my comments in-line.

Best regards
Michael

On Nov 16, 2005, at 21:05 Uhr, [email-masked] wrote:

> 	- Page 5: It says that "The CHUNKS parameter MUST be included 
> once...", hmmm, unless it is empty, in which case it is not needed.
The text says:

    The CHUNKS parameter MUST be included once in the INIT or INIT-ACK
    chunk if the sender wants to receive authenticated chunks

Giving an empty parameter means that you do not request any chunk to be
authenticated. So you do not have to include it. Isn't the wording OK?
>
> 	- Page 6: In the Parameter Length, it says "This value is the length 
> of the number of HMAC identifiers times 2 plus 4." My English is far 
> from perfect, but I guess that something like "This value is the 
> length of the number of HMAC identifiers multiplied by 2 plus 4."
Fixed.
>
> 	- Page 9, first paragraph of section 6.1: It still says there that 
> the RANDOM parameter contains a 32-byte random number.
The text is
      The RANDOM parameter SHOULD contain a 32 byte random number.
What is wrong with it?
>
> 	- Page 12, section 8: I guess IANA has also something to say about 
> the Error Cause 0x0105 for "Unsupported HMAC Identifier" ;-)= And the 
> last paragraph speaks about 3 values, I guess it should say 5.
You are correct regarding the error cause. But the last paragraph says:

    HMAC Identifiers have to be maintained by IANA.  Three initial values
    should be assigned by IANA as described above.

These three values are from the table:

               +-----------------+--------------------------+
               | HMAC Identifier | Message Digest Algorithm |
               +-----------------+--------------------------+
               | 0               | Reserved                 |
               | 1               | SHA-1 defined in [7]     |
               | 2               | MD-5 defined in [1]      |
               +-----------------+--------------------------+

They are three, not five.
> 	- Page 13, section 11: The Reference for [7] (SHA-1) is still missing 
Well, it is [6]... Fixed it. xml2rfc can not handle references in 
tables...