Subject: RE: [Tsvwg] Re: [NSIS] interoperability problems between end-to-endECNandedge-to-edge ECN

From: [email-masked]
Date: Fri, 18 Nov 2005 10:01:18 -0000

I don't think I'm any nearer understanding whether there is an example of why end-to-end ECN is really needed inside a reservation (as opposed to an idealistic requirement). 
Rather than spamming tsvwg & nsis I suggest we discuss this further off-list, and then report back with our conclusion. Is this ok? I think the cc list is those interested, please say if you want to be added [or removed]. 

Best wishes
Philip Eardley/ 

-----Original Message-----
From: Georgios Karagiannis [mailto:[email-masked]] 
Sent: 17 November 2005 13:06
To: [email-masked]; Burness,AL,Louise,CXR9 R
Cc: Eardley,PL,Philip,CXR9 R; [email-masked]; [email-masked]
Subject: Re: [Tsvwg] Re: [NSIS] interoperability problems between end-to-endECNandedge-to-edge ECN

Hi Louise

Are you actually indirectly saying that when RSVP is used as an
end-to-end QoS signaling protocol for a flow then DCCP must not be used
as transport layer protocol for that flow?

The previous example shows that there are cases where it is usefull to
use both DCCP and RSVP for the same flow!

Best regards,
Georgios

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Thursday, November 17, 2005 11:35 AM
Subject: Re: [Tsvwg] Re: [NSIS] interoperability problems between 
end-to-endECNandedge-to-edge ECN

> louise.burness,
>
> On Thu, 17 Nov 2005, [email-masked] wrote:
>
>> If your probability of survival increases with bandwidth, you would
>> reserve more
>
> Maybe not at the expense of someone else's survival.
>
> Also, I might want to reserve more, but my commanders may have
> determined for me that the reservation policy is for the
> greater good.
>
> Why presume that all users are like another: that none can
> have any specialized needs or requirements worthy of being
> satisfied?  Why must a user be mistaken in their motive just
> because they are different?
>
> On the contrary, I think there can exist users that would
> benefit from a policy that guarantees a minimum bandwidth
> and provides best effort above that minimum.
>
> --brian
>
> -- 
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                        ¦ Therefore  all  progress  depends on the ¦
>                        ¦ unreasonable man. -- George Bernard Shaw ¦
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 18 Nov 2005 15:17:20 +0100

Hi Phil

Here is some background information regarding the streaming application
example!

A streaming video application that have "connstant" quality generates
bits according to the dynamic in the images: more dynamics (movements of
objects) more information.

The network may very well be dimensioned for an statistical aggregate
rather an absolute peak. Statistical dimensioning is very important in all
expensive networks and the variable codec can very well congest
the network with traffic during peak conditions.

However, to be able to ensure a minimum quality level for the end-user,
reservation of this may very well be done such that some end-user may be
blocked due to limited network capacity.

However, we may want to ensure that the codec adapts to the available
bitrate instead of experiencing a lot of packet losses.

The network scenario is therefore as following:
* Minimum reserved capacity to ensure a sufficient end-user experience.
* Allow a common network resource shared among the  end-users in the
network
* Using ECN as a feedback to the speech codec when the network
starting to be fully loaded.
* Block new end-user when the minum bandwidth can not be fulfilled.

Hopefully, the above information helps!

Best regards,
Georgios

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, November 18, 2005 11:01 AM
Subject: RE: [Tsvwg] Re: [NSIS] interoperability problems between 
end-to-endECNandedge-to-edge ECN

>I don't think I'm any nearer understanding whether there is an example of 
>why end-to-end ECN is really needed inside a reservation (as opposed to an 
>idealistic requirement).
> Rather than spamming tsvwg & nsis I suggest we discuss this further 
> off-list, and then report back with our conclusion. Is this ok? I think 
> the cc list is those interested, please say if you want to be added [or 
> removed].
>
> Best wishes
> Philip Eardley/
>

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Fri, 18 Nov 2005 09:40:59 -0500

Phil:
If this discussion is off TSVWG or NSIS list, please add me to the cc list.
Thanks!
-- Kwok --

At 05:01 AM 11/18/2005, [email-masked] wrote:
>I don't think I'm any nearer understanding 
>whether there is an example of why end-to-end 
>ECN is really needed inside a reservation (as 
>opposed to an idealistic requirement).
>Rather than spamming tsvwg & nsis I suggest we 
>discuss this further off-list, and then report 
>back with our conclusion. Is this ok? I think 
>the cc list is those interested, please say if 
>you want to be added [or removed].
>
>Best wishes
>Philip Eardley/
>
>Subject: Re: [Tsvwg] Re: [NSIS] interoperability 
>problems between end-to-endECNandedge-to-edge ECN
>
>Hi Louise
>