Subject: RE: [Tsvwg] Fecframe BOF next week

From: "Mark Watson" <[email-masked]>
Date: Thu, 3 Nov 2005 13:10:47 -0500

Joe,

Yes - thank you for the clarification. I mean FEC protection of
unreliable transport flows over IP (v4 or v6).

Also, btw, there is a mailing list for this BOF: [email-masked],
https://www1.ietf.org/mailman/listinfo/fecframe which I should also have
advertised in the mail below.

Regards,

Mark

-----Original Message-----
From: Joe Touch [mailto:[email-masked]] 
Sent: Thursday, November 03, 2005 9:57 AM
To: Mark Watson
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Tsvwg] Fecframe BOF next week

Mark Watson wrote:
> All,
> 
> There will be a BOF session on Wednesday afternoon next week on the
> topic of FEC over transport protocols. The objective is to consider
> starting work on a framework for generalized FEC protection of IP
flows
> over unreliable transport (possibly based on the framework presented
in
> draft-watson-tsgwg-fec-sf-00 which I presented at TSVWG and AVT at
IETF63.)

This is a little confusing; in the IETF, transport happens over IP, not
the other way around. And the term flows applies to IPv6, but not as
well to IPv4.

Do you mean FEC of unreliable transport flows over IP? (that seems what
the BOF is talking about)?

> The BOF description and agenda are available at:
> http://www3.ietf.org/proceedings/05nov/agenda/fecframe.txt
> 
>  
> 
> As many of you will be aware, there is increasing interest in applying
> FEC to media streams in a variety of environments, but a notable lack
of
> IETF protocols to support that in a way which is independent of the
> actual FEC code used. This would would aim to address that in a way
> which is as far of possible generic with respect to transport and
> application protocols as well.
> 
>  
> 
> Regards,
> 
>  
> 
> Mark Watson
> 
> 
>
------------------------------------------------------------------------
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Caitlin Bestler" <[email-masked]>
Date: Thu, 3 Nov 2005 10:34:45 -0800 (PST)

> advertised in the mail below.

Actually I think that Error Correction vs. Error Detection
and Reliable vs. Unreliable are distinct issues.

With Error Deteciton alone a packet either is valid or it
is not. With error correction, a packet can be valid *after*
correction or it can still be invalid.

Reliable vs. Unreliable deals with how the transport
responds to missing packets (potentially because they
were deemed invalid).

I will agree, however, that the *applicability* of
Error Correction heavily favors unreliable or partially
reliable transports.