Subject: Re: [Tsvwg] ECN-MPLS Draft for discussion in TSVWG

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 3 Jul 2006 09:49:34 +0200

Dear Bruce,

I appreciate your teams draft. As far as I can judge
the proposed consumption of MPLS EXP codepoints in 
conjunction with a carefully adapted ECN/PCN 
functionality is a fair compromise.

I'm having a minor comment: Paragraph 4.4 describes 
how to react if a DiffServ boundary is crossed. The 
paragraph only describes what to do if the next 
domain support ECN/PCN. Text about the behaviour 
of a domain not supporting ECN/PCN should be added.

In principle, the document describes what to do 
already. Packets marked as "Congestion Experienced" 
must be dropped. This may be done by the egress or 
ingress router. The choice may be limited to the 
egress router in the case of an inter carrier IP 
interface. On MPLS level, packets with an "unknown" 
EXP codepoint (i.e. congestion experienced) may be 
dropped by an ingress router as well.

Regards,

Ruediger

Rüdiger Geib

T-Systems Enterprise Services GmbH
Senior Expert
Systems Integration 
Technologiezentrum
Engineering Networks, Products & Services
Packet based Carrier Transport Networks
Deutsche-Telekom-Allee 7, D-64295 Darmstadt
Fon: +49 6151 937-2138
http://www.t-systems.com

---

From: Bruce Davie <[email-masked]>
Date: Fri, 7 Jul 2006 09:34:32 -0400

Thanks for the feedback. We'll address the comment below (which I  
agree with) in the next revision.

Regards,

Bruce