Subject: [Tsvwg] INIT Collission

From: Bhanu Prakash <[email-masked]>
Date: Tue, 25 Jul 2006 15:08:20 +0530

Please consider the case mentioned below.

| end point A |      ---------INIT (Init tag 'x')--------->    |endpoint 
B| 

| endpoint A |       <--------INIT (Init tag 0) --------   |end pointB|

| endpoint A |       ------ABORT (T Bit set to 0)--->      |endpoint B| 

| end point A |      ---------INIT (Init tag 'x')--------->    |endpoint 
B| 

As per this sequence, on receiving INIT with InitTag set to zero, end 
point A sends Abort with "T" bit set to zero and again tries to initiate 
the association by sending INIT (but with same InitTag). Is it correct 
to reuse the InitTag?

thanks,
Bhanu

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 25 Jul 2006 13:09:04 +0200

Hi Bhanu,

yes, the left side can resend the INIT with the old init-tag 'x'.

Best regards
Michael

On Jul 25, 2006, at 11:38 AM, Bhanu Prakash wrote:

> | end point A |      ---------INIT (Init tag 'x')--------->    | 
> endpoint B|
>
> | end point A |      ---------INIT (Init tag 'x')--------->    | 
> endpoint B|
>
> As per this sequence, on receiving INIT with InitTag set to zero,  
> end point A sends Abort with "T" bit set to zero and again tries to  
> initiate the association by sending INIT (but with same InitTag).  
> Is it correct to reuse the InitTag?
>
> thanks,
> Bhanu

---

From: Joe Touch <[email-masked]>
Date: Tue, 25 Jul 2006 11:24:56 -0700

It would be useful to label the subject line of these posts with "SCTP".
It might even be useful to post these to an SCTP mailing list (is there
one? can there be?)

Joe

---

From: Randall Stewart <[email-masked]>
Date: Tue, 25 Jul 2006 16:57:56 -0400

Joe:

there are actually two lists for SCTP..

1) Protocol issues come here [email-masked].. just like
    RSVP issues and other such things.

2) Implementation questions go to [email-masked] --- this
    list is for implementation questions on SCTP.. which I think
    this question, which Michael answered.. should probably be directed
    there...

R

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

---

From: Joe Touch <[email-masked]>
Date: Tue, 25 Jul 2006 14:04:21 -0700

>    this question, which Michael answered.. should probably be directed

Thanks - that's what I was looking for...

Joe

---

From: Lars Eggert <[email-masked]>
Date: Wed, 26 Jul 2006 14:09:14 +0200

Hi,

>    this question, which Michael answered.. should probably be directed

I wasn't aware that that exists - would you add it to the IETF's list  
of non-WG email lists at https://datatracker.ietf.org/public/ 
nwg_list.cgi?

Lars
-- 
Lars Eggert                                     NEC Network Laboratories

---

From: Bhanu Prakash <[email-masked]>
Date: Thu, 27 Jul 2006 16:37:16 +0530

Hai,

How do we register ourself with [email-masked]..?

Thanks
Bhanu.