Subject: [Tsvwg] add ip draft update??

From: Randall Stewart <[email-masked]>
Date: Mon, 17 Jul 2006 10:41:16 -0400

All:

For those of you at the TSVwg you know we discussed:

http://www.ietf.org/internet-drafts/draft-marushin-sctp-asconfext-01.txt

The outcome of the discussion is that we would put this
issue to the list.

Basically the above document highlights that you cannot
send more than one asconf. In certian circumstances
this can lead to association failure.

After some discussion we came to one lack in the current
add-ip and one point about the document.

a) The current document specifies that you give an error
    when deleting the "last" IP address. But it really
    needs to say, the "last" IP address of its type when
    your peer has no other way to communicate with you i.e.
    if you have V6+V4 and your peer only has V6. Deleting
    your last V6 address would break the association and
    should NOT be done :-0

b) The document allows only one ASCONF outstanding at
    a time in an effort to provide a limit on how
    much data gets put into the network. In placing that
    one packet limit we were a bit strict in saying only
    one-chunk could be outstanding. If you had multiple
    ASCONF's bundled together, as long as you sent only
    one per RTO, this would not be a bad thing..

Based on the above, the question to the list is:

1) Should we combine in the concepts of the
    above draft, but with a limit of only one packet
    per RTO (not the current drafts send an ASCONF
    whenever you want.. only bundled).

or

2) Have the draft listed above become a seperate
    document which would probably then need a "feature
    negotiation" added to it.

The authors present discussed this and think due to
<b> we probably should just do <1>... but what is
your opinion???

Is there any objections to this idea?

If we hear no strong objections we will go ahead
and tweak in the wording of the document to include
the thoughts from draft-marushin-sctp-asconfext

Thoughts/objections/issues on this subject would be appreciated :-D

R
-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Jul 2006 09:49:46 -0600

Randall,

Randall Stewart wrote:                        (Mon, 17 Jul 2006 10:41:16)
> <b> we probably should just do <1>... but what is

Go for <1>.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/