Subject: [Tsvwg] Fwd: [tsv-area] Re: WGLC for draft-ietf-tsvwg-sctp-auth-03

From: Lars Eggert <[email-masked]>
Date: Wed, 9 Aug 2006 17:02:56 +0200

Begin forwarded message:

> From: "Shearer, Gavin" <[email-masked]>
> Date: August 9, 2006 4:25:59 PM GMT+02:00
> To: "[email-masked]'" <[email-masked]>
> Subject: [tsv-area] Re: WGLC for draft-ietf-tsvwg-sctp-auth-03
>
> As discussed at the recent SCTP Interop event, there is an issue  
> with the
> suggested handling of authenticated COOKIE-ECHO chunks.
>
> The draft currently says:
>
>    If the receiver of the packet does not have a TCB when it needs to
>    process the AUTH chunk, it MUST ignore the AUTH chunk.  This  
> applies
>    to a packet containing an AUTH chunk as a first chunk and an  
> COOKIE-
>    ECHO chunk as the second chunk received in the CLOSED state.  If  
> the
>    receiver has a TCB, it MUST process the AUTH chunk as described
>    above.
>
> This means that as the COOKIE-ECHO is received in the CLOSED state,  
> the
> preceding AUTH chunk will be ignored, and so the COOKIE-ECHO will  
> be handled
> unauthenticated.
>
> I suggest it should say: The COOKIE-ECHO MUST be authenticated by  
> processing
> the COOKIE-ECHO to create a TCB, and then use the secret and random  
> numbers
> from the TCB information and the previous AUTH chunk to  
> authenticate the
> packet. If authentication fails then the TCB just created MUST be  
> destroyed
> and the packet discarded.
>
> Thanks, Gavin
>

Lars
-- 
Lars Eggert                                     NEC Network Laboratories

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 11 Aug 2006 19:55:00 +0200

Hi Gavin,

I agree with your suggested text. I'll update the ID.

Best regards
Michael

On Aug 9, 2006, at 5:02 PM, Lars Eggert wrote:

>>    ECHO chunk as the second chunk received in the CLOSED state.   
>> If the
>> This means that as the COOKIE-ECHO is received in the CLOSED  
>> state, the
>> the COOKIE-ECHO to create a TCB, and then use the secret and  
>> random numbers