Subject: [Tsvwg] comments on Resource Unavailability PDB

From: <[email-masked]>
Date: Thu, 9 Nov 2006 02:43:44 -0000

hi,
here are a few comments on "Resource Unavailability PDB", mainly summarising a chat i had with georgios (georgios, please correct what i got wrong!) draft-karagiannis-ru-pdb-03

there are a lot of things in this draft relevant to the PCN work, so would be good input to the PCN WG [if formed], ie it basically uses PCN.

1. the router marking behaviour (ie whether a particular router within your domain marks packets) is similar. ie forms input to discussions about what the should be. 
2. the edge behaviour (ie what the gateways of teh PCN-region measure) is very similar to the edge behaviour of draft-briscoe-tsvwg-cl-architecture-04. there's a difference in that you dont get the ingress to measure the rate being sent into the PCN-region towards a particular egress; rather the egress already knows this (part of set-up signalling i think). the point is that you dont need anythin extra or different in terms of PCN standards work on edge behaviour. 
3. it could be re-written to form another deployment model for PCN. however, in terms of the goals/assumptions that your deployemtn scenario places on the PCN standards work, it seems these are nearly all in draft-babiarz-pcn-sip-cap-00.txt. the extra thing(s) are probably easiest to add to that, rather than having a new deployment model.

On a separate point, I didn’t understand the references to SLS in the draft. You seemed to me to imply that the SLS is related to a router’s “configured threshold” (ie marks if traffic on router interface is above this level)
It isn’t obvious to me how bandwidth of the SLS is related to the configured thresholds of the routers. In various places the draft seemed to me to imply they were related, eg seemed to say changing the SLS bandwidth would lead to changing the configured bandwidth – which doesn’t seem realistic to me.

thanks
phil

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 09 Nov 2006 23:39:20 +0000

Hi Phil

Thank you for your comments!

Regarding your comments related to the fat that this draft can be
considered as a PCN item, yes I agree that this is the case!

The requirements that we want to get fulfilled are:
* it has to be applied in a controlled/trusted PCN region, with edges
being hosts and media gateways.
* it has to support in addition to real time applications also rate
adaptive real time applications
* it should be able to interwork with applicatuion based signaling. Thus
it should be able to be used in combination with application signaling,
where SIP is just an example.

Based on the above, I think that it can be considered as an application
based deployment model.

Regarding your comment on SLS bandwdith, I agree that we need to
introduce more clarifications.

Best Regards,
Georgios