Subject: [Tsvwg] Can I initiate multiple SCTP associations....

From: "Ashwin" <[email-masked]>
Date: Fri, 27 Apr 2007 11:57:45 +0530

Hello

I have a query related to SCTP.
I just want to know if I can have more than one SCTP association originating from the same IP and Port.(Client)
In RFC 2960, it said that there will be a single association between two SCTP endpoint. And an SCTP end point is a unique PORT.
I just want a confirmation on this.

Thanks & Regards
Ashwin S
Software Engineer
TeleDNA Communication Pvt. Ltd. 
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTE: The content of this email transmission is confidential and property of TeleDNA. The information in this mail is privileged and intended only for the use of the entity(s) or the individual (s) to which it is addressed. If the reader is not an intended recipient, you are hereby notified that any unauthorized disclosure, copying, distribution of this electronically transmitted information is strictly prohibited. If you are in receipt of this electronic communication in error, please immediately notify the sender and delete the information.

---

From: Ashwani Kathuria <[email-masked]>
Date: Fri, 27 Apr 2007 18:18:16 +0530

Hello Ashwin

To form an SCTP Association the following tuple should be unique for that 
association:
{ client IP, client port, server IP, server port }

So if at the client side 2 sockets are bound to same IP address and port, 
then the server sockets they are connecting to, should either differ in IP 
address or port to make the above mentioned tuple unique.

Thanks & Regards -
Ashwani Kathuria
 
A R I C E N T
 
The Presidency Tower ?A, 351/2, Sector 14
M.G. Road Gurgaon 122001, Haryana, India.
 
Main     +91 124.417.6333         Extn : 5218
Fax      +91 124.417.6225
Mobile   +91 991.142.4546
www.aricent.com

"Ashwin" <[email-masked]> 
04/27/2007 11:57 AM

To
<[email-masked]>
cc
[email-masked]
Subject
[Tsvwg] Can I initiate multiple SCTP associations....

Hello
 
I have a query related to SCTP.
I just want to know if I can have more than one SCTP association 
originating from the same IP and Port.(Client)
In RFC 2960, it said that there will be a single association between two 
SCTP endpoint. And an SCTP end point is a unique PORT.
I just want a confirmation on this.

Thanks & Regards
Ashwin S
Software Engineer
TeleDNA Communication Pvt. Ltd. 
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
CONFIDENTIALITY NOTE: The content of this email transmission is 
confidential and property of TeleDNA. The information in this mail is 
privileged and intended only for the use of the entity(s) or the 
individual (s) to which it is addressed. If the reader is not an intended 
recipient, you are hereby notified that any unauthorized disclosure, 
copying, distribution of this electronically transmitted information is 
strictly prohibited. If you are in receipt of this electronic 
communication in error, please immediately notify the sender and delete 
the information.

***********************  Aricent-Unclassified   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."