Subject: [Tsvwg] Can i initiate multiple SCTP Associations??

From: "shilpa" <[email-masked]>
Date: Mon, 14 May 2007 12:42:43 +0530

Hello,

I have two queries related to SCTP.

1) Does SCTP support two associations with different Servers?

Client IP is 192.168.1.44 and port is 12345

Server-1 IP is 192.168.1.54 and port is 14001

Server-2 IP is 192.168.1.16 and port is 14001 

Can the same Client initiate two SCTP associations with Server-1 and Server-2? Does SCTP support this?? 

If Yes then How do i handle it?? Should i maintain two "SCTP_Association_Status" Structures?

2) Can i get more information on Multi-homing feature and requirements for its implementation??

Regards,
Shilpa Kumari P.V
TeleDNA Communications Pvt Ltd
Bangalore
 
CONFIDENTIALITY NOTE: The content of this email transmission is confidential and property of TeleDNA. The information in this mail is privileged and intended only for the use of the entity(s) or the individual (s) to which it is addressed. If the reader is not an intended recipient, you are hereby notified that any unauthorized disclosure, copying, distribution of this electronically transmitted information is strictly prohibited. If you are in receipt of this electronic communication in error, please immediately notify the sender and delete the information.

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 21 May 2007 11:07:00 +0200

Hi Shilpa,

comments in-line.

Best regards
Michael

> Server-2 IP is 192.168.1.16 and port is 14001
I assume that 192.168.1.54 and 192.168.1.16 are two different  
machines...
> and Server-2? Does SCTP support this??
Sure.
> "SCTP_Association_Status" Structures?
That depends on your interface... I doubt that you want to hear how  
to do it
using the sockets interface... If I'm wrong, please let me know, and  
I'll tell you.
> requirements for its implementation??
Not sure what you want to know. On what OS do you want to implement  
SCTP?
> CONFIDENTIALITY NOTE: The content of this email transmission is  
> confidential and property of TeleDNA. The information in this mail  
> is privileged and intended only for the use of the entity(s) or the  
> individual (s) to which it is addressed. If the reader is not an  
> intended recipient, you are hereby notified that any unauthorized  
> disclosure, copying, distribution of this electronically  
> transmitted information is strictly prohibited. If you are in  
> receipt of this electronic communication in error, please  
> immediately notify the sender and delete the information.
>