Subject: Resolution of IANA Section issue Re: [Tsvwg] WG last call of draft-ietf-tsvwg-emergency-rsvp-02

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Wed, 23 May 2007 10:20:14 +0200

Lou and all,

Below is a proposed plan from Ken and I (developed with James's  
help), to resolve the issue raised by Lou on the IANA section. Let us  
know if you have concerns.

On 16 Apr 2007, at 16:34, ken carlberg wrote:

>>
>
>>>> As [SIP-PRIORITY] has been issued and IANA has completed their
>>>> assignments, the document should be consistent with the actual IANA
>>>> registry.  Also, I think you should explicitly request that IANA
>>>> number the namespace so there is no ambiguity or possible numbering
>>>> issues if the namespace were to be reordered.
>>>
>>> ok, we'll update the sentence to indicate that IANA has already set
>>> up the registry.
>>
>> This was a trick question/comment!  Unless I missed it, the IANA  
>> registry doesn't match what was requested in [SIP-PRIORITY].
>
> that will teach me to assume things have been done :-).  I can only  
> imagine that the registry hasn't been set up yet because there have  
> been no requests for new NameSpaces.  However, one would think that  
> the registry would exist to reflect existing values defined in  
> RFC-4412.  Perhaps James (as the co-author of this draft and  
> rfc-4412) needs to chase this down.  One way or another, the  
> registry based on rfc-4412 needs to exist.
>

Despite the fact that  http://www.iana.org/numbers.html does not list  
the registry for the Resource-Priority, that registry has indeed been  
created by IANA as requested by RFC4412 and is listed under
http://www.iana.org/assignments/sip-parameters.

Based on this, the text of the IANA section in emergency-rsvp will be  
amended to:
	* explain that a new column should be added to the registry to  
allocate a numerical value to each namespace (to be used by emergency  
and/or QSPEC and/or other future spec needing to refer to namespace  
via numerical values)
	* indicate this new column should apply to existing namespaces AS  
WELL AS new namespaces whenever they get added to the registry (eg as  
may happen via draft-polk-sip-rph-new-namespaces)
	* add a note at the top of the new column in the registry clarifying  
that this column was added by [emergency-rsvp] and not RFC4412 like  
the rest of the registry.

Cheers

Francois

---

From: Lou Berger <[email-masked]>
Date: Wed, 23 May 2007 08:24:56 -0400

Francois,
         Sounds like a good & reasonable plan to me.

Much thanks,
Lou

At 04:20 AM 5/23/2007, Francois Le Faucheur IMAP wrote:

>Lou and all,
>
>Below is a proposed plan from Ken and I 
>(developed with James's help), to resolve the 
>issue raised by Lou on the IANA section. Let us know if you have concerns.
>
>>>>This was a trick question/comment!  Unless I 
>>>>missed it, the IANA registry doesn't match 
>>>>what was requested in [SIP-PRIORITY].
>>>
>>>that will teach me to assume things have been 
>>>done :-).  I can only imagine that the 
>>>registry hasn't been set up yet because there 
>>>have been no requests for new 
>>>NameSpaces.  However, one would think that the 
>>>registry would exist to reflect existing 
>>>values defined in RFC-4412.  Perhaps James (as 
>>>the co-author of this draft and rfc-4412) 
>>>needs to chase this down.  One way or another, 
>>>the registry based on rfc-4412 needs to exist.
>>
>>Despite the fact 
>>that 
>><http://www.iana.org/numbers.html>http://www.iana.org/numbers.html 
>>does not list the registry for the 
>>Resource-Priority, that registry has indeed 
>>been created by IANA as requested by RFC4412 and is listed under
>><http://www.iana.org/assignments/sip-parameters>http://www.iana.org/assignments/sip-parameters.
>>
>>Based on this, the text of the IANA section in 
>>eme`? Èÿ®ÿÿÿÿlZb rgency-rsvp will be amended to:
>>* explain that a new column should be added to 
>>the registry to allocate a numerical value to 
>>each namespace (to be used by emergency and/or 
>>QSPEC and/or other future spec needing to refer 
>>to namespace via numerical values)
>>* indicate this new column should apply to 
>>existing namespaces AS WELL AS new namespaces 
>>whenever they get added to the registry (eg as 
>>* add a note at the top of the new column in 
>>the registry clarifying that this column was 
>>added by [emergency-rsvp] and not RFC4412 like the rest of the registry.
>>
>>Cheers
>>
>>Francois