Subject: [Tsvwg] INIT_ACK with a_rwnd=0

From: "Andrey Konstantinov" <[email-masked]>
Date: Wed, 19 Sep 2007 14:18:07 +0400

Hi,

RFC 2960 does not decribe reaction for INIT or INIT_ACK chunk with a_rwnd
which is equal to 0.
a_rwnd can be increased during association life after.

Could you describe correct reaction for these chunks with such paramenter?

I suppose it is not critical and SCTP may accept such chunks and move to
zero window probe state after the association establishment phase...

Best regards,
Andrey Konstantinov

---

From: Ash Kat <[email-masked]>
Date: Wed, 19 Sep 2007 03:53:41 -0700 (PDT)

Hello Andrey Konstantinov:

According to section 6 of RFC  2960, the a_rwnd must not be less than 1500.

---------------------------
  "A SCTP receiver MUST be able to receive a minimum of 1500 bytes in
   one SCTP packet.  This means that a SCTP endpoint MUST NOT indicate
   less than 1500 bytes in its Initial a_rwnd sent in the INIT or INIT
   ACK."
---------------------------

Regards,
Ashwani Kathuria

Andrey Konstantinov <[email-masked]> wrote: Hi,
  
 RFC 2960 does not decribe reaction for INIT or INIT_ACK chunk with a_rwnd which is equal to 0.
 a_rwnd can be increased during association life after.

 I suppose it is not critical and SCTP may accept such chunks and move to zero window probe state after the association establishment phase...
  
 Best regards,
 Andrey Konstantinov

---------------------------------
Shape Yahoo! in your own image.  Join our Network Research Panel today!

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 19 Sep 2007 16:16:22 +0200

Hi Andrey,

what about sending back an ABORT with an optional
error cause "Invalid Mandatory Parameter"...

Best regards
Michael

On Sep 19, 2007, at 12:18 PM, Andrey Konstantinov wrote:

> I suppose it is not critical and SCTP may accept such chunks and  
> move to zero window probe state after the association establishment  
> phase...
>
> Best regards,
> Andrey Konstantinov