Subject: [Tsvwg] consensus call: draft-larsen-tsvwg-port-randomization to WG item

From: Lars Eggert <[email-masked]>
Date: Wed, 12 Sep 2007 18:38:38 +0300

Hi,

regarding http://tools.ietf.org/html/draft-larsen-tsvwg-port- 
randomization, there was quite a bit of discussion around this draft  
during the summer. My personal take is that I saw more positive than  
negative comments, but I'd like to confirm this.

I'd hence like to start a consensus call on whether we want to take  
this document to be the basis for a standards-track work item in  
TSVWG that will recommend a randomization scheme for operating  
systems allocation of source ports. Because this scheme will cover  
all our transport protocols, I'm CC'ing the DCCP and TCPM working  
groups. This consensus call will run for two weeks, until September 28.

Please comment on the [email-masked] list (reply-to set accordingly),  
even if you have already commented be on this draft in the past.

To make it easy for your chairs, please start your email by choosing  
ONE of the options below, followed by any detailed comments you'd  
like to make:

   (1) TSVWG should take on this work item, with this document as the  
basis
   (2) TSVWG should take on this work item, but NOT with this  
document as the basis
   (3) TSVWG should NOT take on this work item
   (4) don't care

Thanks,
Lars

---

From: "tom.petch" <[email-masked]>
Date: Fri, 14 Sep 2007 09:45:00 +0200

1)

Tom Petch

----- Original Message -----
From: "Lars Eggert" <[email-masked]>
To: "tsvwg WG" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
"DCCP mailing list" <[email-masked]>
Sent: Wednesday, September 12, 2007 5:38 PM
Subject: [tcpm] consensus call: draft-larsen-tsvwg-port-randomization to WGitem

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tcpm
>

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 18 Sep 2007 14:37:24 -0700

I support this document becoming a TSVWG working group item.  

During its transition to such, I would like the authors to more clearly extend
the document's applicability to non-TCP protocols with port numbers.
Specifically, the document should include "UDP", "DCCP", and "SCTP" (as well
as TCP) in its introduction (and perhaps also in its abstract) so that anyone
developing or writing host requirements for those protocols will have a better
chance of finding this specification when working on those protocols.

-d

> -----Original Message-----
> From: Lars Eggert [mailto:[email-masked]] 
> Sent: Wednesday, September 12, 2007 8:39 AM
> To: tsvwg WG
> Cc: [email-masked]; 
> [email-masked]; DCCP 
> mailing list
> Subject: [tcpm] consensus call: 
> draft-larsen-tsvwg-port-randomization to WGitem
> 
> Hi,
>

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Sep 2007 15:48:46 +0300

I've seen two (positive) comments so far. Please comment.

On 2007-9-12, at 18:38, ext Lars Eggert wrote:
> randomization, there was quite a bit of discussion around this  
> draft during the summer. My personal take is that I saw more  
> positive than negative comments, but I'd like to confirm this.
>
> Please comment on the [email-masked] list (reply-to set  
> accordingly), even if you have already commented be on this draft  
> in the past.
>
> To make it easy for your chairs, please start your email by  
> choosing ONE of the options below, followed by any detailed  
> comments you'd like to make:
>
>   (1) TSVWG should take on this work item, with this document as  
> the basis

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Thu, 20 Sep 2007 16:06:37 +0300

> I've seen two (positive) comments so far. Please comment.

Good to me. It is relevant to issues identified here:

http://tools.ietf.org/html/draft-ietf-v6ops-teredo-security-concerns-00

and here:

http://www1.ietf.org/mail-archive/web/sipping/current/msg14527.html

-- 
Rémi Denis-Courmont

---

From: Carlos Pignataro <[email-masked]>
Date: Thu, 20 Sep 2007 10:24:35 -0400

Option (1)

I also support this document becoming a tsvwg document, and agree with
explicitly expanding the scope/applicability to other transport protocols.

Thanks,

--Carlos.

On 9/18/2007 5:37 PM, Dan Wing said the following:
>> accordingly),  

-- 
--Carlos Pignataro.
Escalation RTP - cisco Systems

---

From: Pekka Savola <[email-masked]>
Date: Fri, 21 Sep 2007 10:10:47 +0300 (EEST)

Cc:ing chairs because I'm not subscribed, if the message doesn't 
appear on the list feel free to forward it or whatever.

On Thu, 20 Sep 2007, Lars Eggert wrote:
>> the options below, followed by any detailed comments you'd like to make:
>>
>>   (1) TSVWG should take on this work item, with this document as the basis
>>   (2) TSVWG should take on this work item, but NOT with this document as
>>   the basis

This seems like a reasonable piece of work and the document seems like 
a reasonable starting point.  I support (1).

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 21 Sep 2007 08:48:06 +0100

I have read this, and believe that it would be possible to implement 
such a scheme in TCP and DCCP. It seems it could also be useful.

I commented on earlier drafts. This seems in a readable state, although 
I have NOT thought whether the specific randomisation algorithms are a 
good choice.

This makes it (1) - but with a need to look closely at the design
decisions.

Gorry

Lars Eggert wrote:
> Hi,
> 
> regarding 
> http://tools.ietf.org/html/draft-larsen-tsvwg-port-randomization