Subject: [Tsvwg] (Plain text) Problem with using Tie-Tags in Table 2 of RFC4960‏

From: BlackHorse <[email-masked]>
Date: Wed, 29 Oct 2008 16:45:56 +0800

Dear Sirs,
I have a problem with using Tie-Tags for Handling of a COOKIE ECHO when a TCB Exists in  RFC4960.

If There is display problem with this e-mail,please see the attach file with plain text.

The Table 2 in page 68 of RFC 4960 is showed as follow.

+------------+------------+---------------+--------------+-------------+
|  Local Tag | Peer's Tag | Local-Tie-Tag |Peer's-Tie-Tag|   Action/   |
|            |            |               |              | Description |
+------------+------------+---------------+--------------+-------------+
|    X       |     X      |      M        |      M       |     (A)     |
+------------+------------+---------------+--------------+-------------+
|    M       |     X      |      A        |      A       |     (B)     |
+------------+------------+---------------+--------------+-------------+
|    M       |     0      |      A        |      A       |     (B)     |
+------------+------------+---------------+--------------+-------------+
|    X       |     M      |      0        |      0       |     (C)     |
+------------+------------+---------------+--------------+-------------+
|    M       |     M      |      A        |      A       |     (D)     |
+======================================================================+
|       Table 2: Handling of a COOKIE ECHO when a TCB Exists           |
+======================================================================+

   Legend:

      X - Tag does not match the existing TCB.
      M - Tag matches the existing TCB.
      0 - No Tie-Tag in cookie (unknown).
      A - All cases, i.e., M, X, or 0.

   Note: For any case not shown in Table 2, the cookie should be silently discarded.

There is a "0" in second column of the third case. The Table's legend explains the "0". Can we think that the Peer's Tag in cookie is zero(or unknow)?
Can we think that the Local-Tie-Tag or the Peer's-Tie-Tag in cookie is zero(or unkonw)? I'm not sure the question. Please give your answer.

Best regards

Shengcai Zhang

_________________________________________________________________
谈话枯燥无味？让MSN魔法书来点缀您的MSN！
http://im.live.cn/emoticons/?ID=6

---

From: Randy Stewart <[email-masked]>
Date: Wed, 29 Oct 2008 08:24:11 -0400

Shengcai:

The 0 indicates that you (in your TCB) do not know
the peers tag. Most likely you have sent an INIT
and are still waiting for the response.

R
On Oct 29, 2008, at 4:45 AM, BlackHorse wrote:

> |            |            |               |              |  
> Description |
> |    X       |     X      |      M        |      M       |      
> (A)     |
> |    M       |     X      |      A        |      A       |      
> (B)     |
> |    M       |     0      |      A        |      A       |      
> (B)     |
> |    X       |     M      |      0        |      0       |      
> (C)     |
> |    M       |     M      |      A        |      A       |      
> (D)     |
> + 
> = 
> =====================================================================+
> + 
> = 
> =====================================================================+
>
>   Legend:
>
> There is a "0" in second column of the third case. The Table's  
> legend explains the "0". Can we think that the Peer's Tag in cookie  
> is zero(or unknow)?
> Can we think that the Local-Tie-Tag or the Peer's-Tie-Tag in cookie  
> is zero(or unkonw)? I'm not sure the question. Please give your  
> answer.
>
> Best regards
>
> Shengcai Zhang
>
>
> http://im.live.cn/emoticons/?ID=6<Problem with using Tie-Tags in  
> Table 2 of RFC4960‏.txt>

-----
Randall Stewart
[email-masked]