Subject: Re: [Tsvwg] Ran's comment from Dublin meeting regarding RSVP groupkeying

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Mon, 17 Nov 2008 14:24:07 -0600

Hello Ran,

The latest version of the I-D on "Applicability of Keying methods to  
RSVP Security" addressed your comments from Dublin
(in particular by explicitly discussing use of IPsec AH)

See http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-rsvp-security-groupkeying-02.txt

Please let us know if this did not fully address your comments or if  
you have additional comments/suggestions.

Thanks for your views

Francois

On 15 Oct 2008, at 10:14, Magnus Westerlund wrote:

> Hi,
>
> Ran has kindly provided with some clarification on the comment he
> provided at the microphone in Dublin for the WG and authors to  
> consider:
>
> It concerns the presentation:
> http://www.ietf.org/proceedings/08jul/slides/tsvwg-2/tsvwg-2.htm
>
>> Regarding Slides 4 and 5 of the presentation, AH protects
>> the essential outer IP header fields and also outer
>> security-critical IP options (for both IPv4 and for IPv6)
>> and also protects whatever payload follows.
>>
>> Slide 4 is quite correct that no form of ESP is capable
>> of protecting the outer IP header fields or IP-layer options.
>> This is a critical, and not widely understood, difference
>> between ESP-Null encryption and AH.
>>
>> So for the particular concern described in these slides,
>> AH is an already standard, already deployable, well-known
>> solution.   We at NRL demonstrated AH for protecting
>> IPv4 and IPv6, including IPv6 ND traffic and IP options,
>> to DARPA (Mike StJohns) in August 1995.  Multiple free
>> implementations exist.
>>
>> So one could use AH with some group keying mechanism
>> to address the issue on these 2 slides.  This could be
>> done with or without the RSVP Integrity option and
>> could be done with or without ESP encryption, as desired.
>
>
> Best Regards
>
> Magnus Westerlund
>
> IETF Transport Area Director & TSVWG Chair
> ----------------------------------------------------------------------
> Multimedia Technologies, Ericsson Research EAB/TVM
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Färögatan 6                | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> ----------------------------------------------------------------------

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Nov 2008 22:19:30 -0000

Hi Francois,

On your slides today I saw...

- Incorporate feedback from MPLS WG, CCAMP WG
   - Mail sent Nov 7 requesting feedback

Of course, this sent me to the mail archives because I didn't recall seeing 
anything.
I found the email in the MPLS archive but nothing in CCAMP.

I will send mail to the list to request them to review and feed back, but 
please give them them the a few extra days to generate comments.

Thanks,
Adrian

---

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Mon, 17 Nov 2008 16:40:14 -0600

Hi Adrian,

Thanks for sending the request for feedback to CCAMP on our behalf.
We will definitely allow for plenty of time.

Francois

On 17 Nov 2008, at 16:19, Adrian Farrel wrote:

> Of course, this sent me to the mail archives because I didn't recall  
> seeing anything.
> I will send mail to the list to request them to review and feed  
> back, but please give them them the a few extra days to generate  
> comments.
>
> Thanks,
> Adrian

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 18 Nov 2008 11:02:29 -0500

> you have additional comments/suggestions.

Thank you for your note and for the pointer to the revised draft.

In Section 6.3, the discussion of AH seems artificially abbreviated.

Further, it is not clear to me that one ought to say that AH and
RSVP Integrity Object "provide comparable security" without explaining
what one means in more detail.

I believe those two mechanisms (AH & RSVP Integrity object) actually
protect different sets of fields in an RSVP packet.  It would seem
worthwhile to describe which fields AH protects, and which fields
AH does not protect in Section 6.3.  Similarly it would seem
worthwhile to discuss (someplace else in the same draft) which fields
the RSVP Integrity object protects, and which the RSVP Integrity object
does not protect.

It is possible that the difference in which fields are protected is
not considered significant, but if one believes that, then one ought
to explain the specific differences in which fields are protected and
also then explain also why those differences are believed not to be
significant.

Cheers,

Ran
[email-masked]

---

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Tue, 18 Nov 2008 13:43:49 -0600

Hi Ran,

Good suggestions.
Looking back at it, I also realized an explicit statement in that  
section about which keying method is applicable to AH would not hurt.

Thanks

Francois