Subject: [Tsvwg] SCTP: Reusing association in SHUTDOWN_SENT state

From: kumar gaurav <[email-masked]>
Date: Mon, 13 Apr 2009 14:55:50 +0530 (IST)

Hi,
 
       Section 5.2.2 of rfc 2960 allows the reuse of an association in SHUTDOWN_SENT. i.e. if the other end of the association reconnects(after recovering from crash), association moves from SHUTDOWN_SENT to ESTABLISHED state. An association reaches SHUTDOWN_SENT state when an application either calls close or shutdown(SHUT_WR) on the socket. In both cases the application is not willing to send any further data to the other end of the connection. 
 
I am not able to understand the purpose of reusing an association in SHUTDOWN_SENT state.Is there some special case where transition from SHUTDOWN_SENT to ESTABLISHED is useful from application point of view?
 
Thanks,
Gaurav

      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

---

From: Randy Stewart <[email-masked]>
Date: Mon, 13 Apr 2009 05:34:31 -0400

Gaurav:

You are overlooking the one-to-many socket model.

Its possible on a one-to-many listener to close an association without
doing shutdown() OR close().

For example I can do

sd = socket(..);
listen(sd..);

...

  sendmsg(..., addr1)
  recvmsg(... (from addr)..)
  semdmsg(..., addr1, SCTP_EOF)

..

and still be talking to other endpoints that have connected
to the socket. In such a case the peer at addr1 may do this.

R
On Apr 13, 2009, at 5:25 AM, kumar gaurav wrote:

> Hi,
>
>        Section 5.2.2 of rfc 2960 allows the reuse of an association  
> in SHUTDOWN_SENT. i.e. if the other end of the association  
> reconnects(after recovering from crash), association moves from  
> SHUTDOWN_SENT to ESTABLISHED state. An association reaches  
> SHUTDOWN_SENT state when an application either calls close or  
> shutdown(SHUT_WR) on the socket. In both cases the application is  
> not willing to send any further data to the other end of the  
> connection.
>
> I am not able to understand the purpose of reusing an association in  
> SHUTDOWN_SENT state.Is there some special case where transition from  
> SHUTDOWN_SENT to ESTABLISHED is useful from application point of view?
>
> Thanks,
> Gaurav
>
> Add more friends to your messenger and enjoy! Invite them now.

-----
Randall Stewart
[email-masked]