Subject: Re: [tsvwg] TSVWG Status Report Oct 2009

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 5 Nov 2009 19:55:39 +0100

Hello Gorry, James,

Any comments on why this document is not going for Last Call as  
(apparently) agreed 4 months ago?

Francois

On 26 Oct 2009, at 19:14, Francois Le Faucheur wrote:

> Gorry, James,
>
> Any comments on why this document is not going for Last Call as  
> (apparently) agreed 3.5 months ago?
>
> Thanks
>
> Francois
>
> On 16 Oct 2009, at 15:04, Francois Le Faucheur wrote:
>
>> Gorry, James,
>>
>> Independently of getting the Status Report corrected, my  
>> understanding is that draft-ietf-tsvwg-rsvp-security-groupkeying  
>> has been declared ready to go to WGLC 3 months ago as per the  
>> Stockholm meeting minutes. Could you please:
>> 	(i) either issue the Last Call
>> 	(ii) or let us know if there are outstanding thing sin the way.
>>
>> Thanks
>>
>> Francois
>>
>> On 16 Oct 2009, at 14:43, Michael Behringer (mbehring) wrote:
>>
>>> Gorry,
>>>
>>> Regarding
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-rsvp-security-groupkeying-05 (as INFO)
>>> Milestone: Nov 2009
>>> - Submit 'Applicability of Keying Methods for RSVP Security' to IESG
>>>
>>> ACTION: Reviews Needed to say ready for WGLC
>>> Notes: Francois believes this is ready for WGLC.
>>> Ran Adkinson no longer has any objection to this.
>>> JP will shepherd.
>>>
>>> --------------------------------------------
>>>
>>> I believe this status not to be correct. Please refer to
>>> http://tools.ietf.org/wg/tsvwg/minutes?item=minutes75.html
>>>
>>> "          The WG will now take this to LC. People who have  
>>> commented prior to WGLC
>>>         please quickly re-read and confirm this is ready for  
>>> publication.
>>> "
>>>
>>> My understanding from the last meeting was that:
>>> - the chairs would issue a WGLC (quite explicitly in the notes)
>>> - people who have commented before to quickly confirm that their  
>>> concerns
>>> have been addressed.
>>>
>>> Please also refer to my mail to the list from 8 Sep
>>> http://www.ietf.org/mail-archive/web/tsvwg/current/msg09448.html
>>> Where I asked whether there are any open issues, and I was not  
>>> told about any.
>>>
>>> So in my understanding the document should be in the section
>>> ================ WG Chair ACTION NEEDED ================
>>>
>>> Could you please confirm this or correct my statements above?
>>>
>>> Thanks,
>>> Michael
>>>
>>>
>>> -----Original Message-----
>>> From: [email-masked] on behalf of Gorry Fairhurst
>>> Sent: Thu 08-Oct-09 15:46
>>> To: tsvwg WG
>>> Cc: tsvwg chair
>>> Subject: [tsvwg] TSVWG Status Report Oct 2009
>>>
>>>
>>> I've summarised the list of drafts I know about in TSVWG and their
>>> current state. Please do take time to read this. If there are  
>>> omissions
>>> or corrections, do let me know and I'll fix them.
>>>
>>> - If you are an author please do update your document before the
>>> deadline for the next IETF (not so many weeks from now!!) I see one
>>> document is even expired with pending comments!
>>>
>>> - If you have comments on these drafts, please let us know. If we  
>>> are
>>> going to things completed by the milestones, we'll need people to
>>> comment on the documents and new revisions to be published.
>>>
>>> Best wishes,
>>>
>>> Gorry & James
>>> (as TSVWG Chairs)
>>>
>>> ======== TSVWG STATUS 8th OCT 2009 ========
>>>
>>> ================ IESG Processing ================
>>>
>>> * draft-ietf-tsvwg-rsvp-proxy-approaches-07 (as INFO)
>>>
>>> Notes: None.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-rsvp-proxy-proto-09 (as PS)
>>>
>>> Notes: None.
>>>
>>> ================ WG Chair ACTION NEEDED ================
>>>
>>> * draft-ietf-tsvwg-emergency-rsvp-12 (as PS)
>>>
>>> Status:  In WGLC (Shepherd = Gorry Fairhurst)
>>> ACTION: WG Review reports, and notes of usefulness are needed.
>>> Notes: {WGLCTo end: 17th October 2009}
>>> 8th Oct - currently no nodes of support or comments.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-port-randomization-04 (as BCP)
>>> Milestone: Nov 2009
>>> - Submit 'Port Randomization for Transport Protocols' to the IESG
>>>
>>> Status: This ID is past WGLC. (Shepherd = James Polk)
>>> ACTION: JP to close the LC discussions and provide write-up.
>>> Notes: WGLC concluded April 15th
>>> New revision posted 3rd July - awaiting response by James Polk.=
>>>
>>> ================ With WG ================
>>>
>>> * draft-ietf-tsvwg-admitted-realtime-dscp-05 (as PS)
>>>
>>> Status: This ID is past WGLC. (Shepherd = Magnus Westerlund)
>>> ACTION: Awaiting new revision by authors.
>>> Notes: JP to make final edits (based on Magnus' AD comments)
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-sctp-strrst-00 (as PS)
>>>
>>> ACTION: Awaiting new revision by authors.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-rsvp-security-groupkeying-05 (as INFO)
>>> Milestone: Nov 2009
>>> - Submit 'Applicability of Keying Methods for RSVP Security' to IESG
>>>
>>> ACTION: Reviews Needed to say ready for WGLC
>>> Notes: Francois believes this is ready for WGLC.
>>> Ran Adkinson no longer has any objection to this.
>>> JP will shepherd.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-iana-ports-02 (as BCP)
>>> Milestone:  Dec 2009
>>> -'IANA Procedures for the Transport Protocol Port Number Space'
>>>
>>> ACTION: Awaiting new revision by authors.
>>> Notes:  GF will shepherd.
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-sctpsocket-19 (as INFO)
>>> Milestone: Dec 2009
>>> - 'Sockets API Extensions for SCTP' to IESG
>>>
>>> ACTION: Awaiting new revision by authors.
>>> Notes: Lacks a good IANA section, and  security consideration.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-ecn-tunnel-03 (as PS)
>>> Milestone: Jan 2010
>>> - 'Layered Encapsulation of Congestion Notification'
>>>
>>> ACTION: Awaiting new revision by authors (WG Comments welcome)
>>> Notes: Substantial review of previous version.
>>> GF and David Black to confirm if issues raised were answered.
>>> New material needs review.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-dtls-for-sctp-01 (as PS)
>>> Milestone: Dec 2009
>>> - 'DTLS for SCTP'
>>>
>>> ACTION: Reviewers needed.
>>> Notes: Reviews needed to allow this to progress to LC.
>>> Authors think this is about ready for WGLC.
>>>
>>> --------------------------------------------
>>>
>>> * draft-ietf-tsvwg-byte-pkt-congest (as INFO)
>>> Milestone:  Feb 2010
>>> - Request publication of 'Byte and Packet Congestion Notification'
>>>
>>> ACTION: Awaiting new revision by authors (WG Comments welcome)
>>> Notes: Comments received on rev 00, but no new revision.
>>> Current version has expired Feb 2009.
>>> Chairs need to know if author wishes to continue with a revised ID.
>>>
>>> ================ Individual Drafts ================
>>>
>>> These drafts are ones that are being tracked, if you have a draft  
>>> that
>>> you think is ready for WG comments please email the Chairs.
>>>
>>> --------------------------------------------
>>> * draft-tuexen-sctp-udp-encaps-02
>>>
>>> Notes:
>>>       AD help requested to know what with encapsulation drafts.
>>>
>>> --------------------------------------------
>>>
>>> * draft-fairhurst-6man-tsvwg-udptt-02
>>> - The UDP Tunnel Transport mode
>>> Status: Individual Submission
>>>
>>> Notes:
>>> Presented at IETF-75 (Stockholm) to TSVWG and 6MAN.
>>>
>>> --------------------------------------------
>>>
>>> * draft-tuexen-tsvwg-sctp-sack-immediately-02.txt
>>> Status: Individual Submission
>>>
>>> Notes:
>>> Presented at IETF-75 (Stockholm) to TSVWG
>>>
>>> --------------------------------------------
>>>
>>> * draft-narayanan-tsvwg-rsvp-resource-sharing
>>> Status: Individual Submission
>>>
>>> Notes:
>>> Presented at IETF-75 (Stockholm) to TSVWG
>>>
>>> --------------------------------------------
>>>
>>> * draft-lefaucheur-tsvwg-rsvp-multiple-preemption
>>> Status: Individual Submission
>>>
>>> Notes:
>>> Presented at IETF-75 (Stockholm) to TSVWG
>>>
>>> --------------------------------------------
>>>
>>>
>>> draft-narayanan-tsvwg-rsvp-resource-sharing
>>> Status: Individual Submission
>>>
>>> Notes:
>>> Presented at IETF-75 (Stockholm) to TSVWG
>>>
>>> --------------------------------------------
>>>
>>> * draft-adams-tsvwg-flow-signaling-identification-00
>>> -  Flow State Aware signalling standardisation, and a proposal for
>>> alerting nodes or end-systems on data related to a flow
>>> Status: Individual Submission,  Not discussed by this group.
>>>
>>> Notes: None.
>>>
>>> --------------------------------------------
>>>
>>> * draft-fairhurst-tsvwg-6man-udpzero-00
>>> - IPv6 UDP Checksum Considerations
>>> Status: Individual Submission,  Not discussed by this group.
>>>
>>> Notes:
>>> Linked to work in 6MAN, MBONED and LISP
>>>
>>> --------------------------------------------
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>
>

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 05 Nov 2009 13:39:37 -0600

Francois

This is directly from the meeting minutes:

"The WG will now take this to LC. People who have commented prior to
WGLC please quickly re-read and confirm this is ready for publication."

Which is close - but not exactly how I remember things.  I remember 
asking the room for folks to ping the list and say whether this ID 
ready for WGLC. No one on the list has commented since Stockholm 
about this ID (up or down) -- so we chairs have hesitated issuing the WGLC.

Perhaps I should have pushed the WG more directly to the list. I 
apologize for that.

James

---

From: ken carlberg <[email-masked]>
Date: Thu, 5 Nov 2009 14:50:30 -0500

I reviewed the document back in June, and was satisfied with the  
exchange and changes made to the last draft.  I had actually assumed  
it was ready for WGLC a while back.  So if you are in need of a voice  
to say, "go ahead"....well, go ahead :-)

-ken

---

From: Brian Weis <[email-masked]>
Date: Thu, 5 Nov 2009 12:44:15 -0800

I also reviewed it in June, had questions, and was satisfied with the  
responses (last message sent to the list 6/4/09). I believe it's ready  
for WGLC.

Brian

On Nov 5, 2009, at 11:50 AM, ken carlberg wrote:

> it was ready for WGLC a while back.  So if you are in need of a  
> voice to say, "go ahead"....well, go ahead :-)
>
> -ken
>
>

-- 
Brian Weis
Router/Switch Security Group, ARTG, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 5 Nov 2009 23:14:02 +0100

James,

Considering that:
	* Ken Carlberg already explicitly confirmed on the list that he was  
satisfied with the changes back in June 09
	* Ran Atkinson already explicitly confirmed on the list that his  
comments had been addressed appropriately back in June 09 (http://www.ietf.org/mail-archive/web/tsvwg/current/msg09144.html 
)
	* Brian Weis already explicitly confirmed on the list that the  
proposed changes worked for him back on 5 June 09
	* Bob Briscoe also explicitly confirmed he did a complete review back  
in April and converged with Michael on resolution of the one  
outstanding item,
could we actually do the Last Call?

Thanks

Francois