Subject: Cookie-ECHO bundled with ABORT

From: Aditya Sehgal <[email-masked]>
Date: Thu, 18 Feb 2010 23:29:45 +0530

Hi Experts,
Section 6.10 of SCTP RFC (4960) states

An endpoint MUST process received chunks in their order in the packet.

Further, in Section 9.1, under Abort of an Association it states

An endpoint MUST NOT respond to any received packet
that contains an ABORT chunk

What is the expected behaviour from an implementation if it receives
COOKIE-ECHO bundled with ABORT in that order?

Should it process the ABORT first and therefore ABORT a non-existing
association since COOKIE-ECHO is not processed or processes COOKIE-ECHO
first and then ABORT. If it processes COOKIE-ECHO first and the cookie turns
out stale, it would then be required to send ERROR message with cause Stale
Cookie and thereby violating Section 9.1

Please advise.

Thanks & Regards,
Aditya Sehgal
-- 
There are only 10 type of people in this World...Those who understand binary
and those who dont

---

From: Michael Tüxen <[email-masked]>
Date: Thu, 18 Feb 2010 20:47:31 +0100

On Feb 18, 2010, at 6:59 PM, Aditya Sehgal wrote:

> What is the expected behaviour from an implementation if it receives COOKIE-ECHO bundled with ABORT in that order?
> 
> Should it process the ABORT first and therefore ABORT a non-existing association since COOKIE-ECHO is not processed or processes COOKIE-ECHO first and then ABORT. If it processes COOKIE-ECHO first and the cookie turns out stale, it would then be required to send ERROR message with cause Stale Cookie and thereby violating Section 9.1
You would process the the COOKIE-ECHO, queue the COOKIE-ACK, process the ABORT, delete the association,
discard the queued COOKIE-ACK and are finished with processing. So no packet gets sent.

The above might be optimized in an implementation but the external visible behavior should be the same.

Best regards
Michael
> 
> Please advise.
> 
> Thanks & Regards,
> Aditya Sehgal
> -- 
> There are only 10 type of people in this World...Those who understand binary and those who dont