Subject: [tsvwg] draft-ietf-tsvwg-sctpsocket: shutdown() with SHUT_RD

From: Robin Seggelmann <[email-masked]>
Date: Mon, 1 Feb 2010 16:19:31 +0100

In section 4.1.7 of draft-ietf-tsvwg-sctpsocket is described that shutdown() with the SHUT_RD argument "Disables further receive operations. No SCTP protocol action is taken."

If SHUT_RD disables receiving but nothing is done by SCTP, what happens to messages still send by the peer? If there is no notification on application layer, the peer doesn't know that its messages won't be received anymore. And what about notifications? Is it still possible to read them or will the read call just return an error? Wouldn't that always cause an ABORT because of unread messages left in the receive buffer?

Regards,
Robin

---

From: Michael Tüxen <[email-masked]>
Date: Mon, 1 Feb 2010 17:43:41 +0100

> If SHUT_RD disables receiving but nothing is done by SCTP, what happens to messages still send by the peer? If there is no notification on application layer, the peer doesn't know that its messages…
I think no protocol action is taken when the SHUT_RD is issued. However, if
a message is received after the SHUT_RD was issued, an ABORT should be sent to
the peer. Not sure if this should be stated in the ID.
What do others think?

Best regards
Michael