Subject: Re: WGLC for draft-ietf-tsvwg-dtls-for-sctp-04

From: Alfred Hönes <[email-masked]>
Date: Fri, 12 Mar 2010 01:35:45 +0100 (MEZ)

I support this draft,
with the changes recommended by Michael for 4.7. and 5.

Other changes in the draft since my review of a previous version
seem appropriate from a technical and editorial point of view.

Minor enhancements:

a)
Making the document title ready for searching for the related
acronym might be appreciated by many readers.
So I suggest to change the title to:

           Datagram Transport Layer Security (DTLS) for the
             Stream Control Transmission Protocol (SCTP)

b)
Wouldn't it make sense to place 3.5 at the very beginning of sect. 3
and bump the subsection numbers 3.1 thru 3.4 ?
3.5 is the general statement of base and future directions and that
should perhaps better be spelled out before the technical details.

c)
AFAICS, 3 of the instances of "which" in the text actually should
be "that", and a few commas should be placed after longer conditional
clauses, but that can all be left to the RFC Editor.

Kind regards,
  Alfred.

-- 

+------------------------+--------------------------------------------+
| TR-Sys Alfred Hoenes   |  Alfred Hoenes   Dipl.-Math., Dipl.-Phys.  |
| Gerlinger Strasse 12   |  Phone: (+49)7156/9635-0, Fax: -18         |
| D-71254  Ditzingen     |  E-Mail:  [email-masked]                     |
+------------------------+--------------------------------------------+

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 16 Mar 2010 09:50:16 +0100

Hi Alfred,

thanks a lot for your review. See my comments in-line.

Best regards
Michael

> seem appropriate from a technical and editorial point of view.
... also the reference now needs to be updated to RFC 5705.
>             Stream Control Transmission Protocol (SCTP)
Good point. Scheduled for next rev.
> should perhaps better be spelled out before the technical details.
Makes sense.
> clauses, but that can all be left to the RFC Editor.
You can send me these comments offline and I'll incorporate them.