Subject: Re: Submitted rev of RSVP APP-ID profiles ID

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 10 Nov 2010 10:34:47 +0800

Hi James,

A few more suggestions:

* for the GUID, you may want to use "http://www.ietf.org/rfc/rfcxyz.txt" where xyz will be the RFC number of your document
(instead of rfc4594 and rfc5865) because really it is your document that defines the meaning of what comes afterwards.

* you could probably structure the document a little more succinctly by merging all the sub--sections 3.x and just have a table that lists all possible values and the reference to the RFC where the class is actually are defined (ie rfc4594 and rfc5865)

* regarding the VER field:
I am not clear about the value of mandating the inclusion of VER= and mandating there is no value afterwards. If there is a need for VER later, then whatever document defines its meaning can simply state that the field can be added then. 

* regarding a new P-Type: 
One thing you must make sure is that it is possible to signal both an App class and a regular app identity  (eg "real-time-interactive" & "MyFavoriteAppVendor/MyFAvoriteApp". As long as this is possible I am happy.
Another option that came to my mind is that you keep the existing P-Type but define a new keyword "APP-CLASS=" instead of "APP=". So you now have three choices. EIther one is fine by me (as long as you confirm the requirement above is met).

HTH

Francois

On 29 Oct 2010, at 08:10, James M. Polk wrote:

> TSVWG
> 
> I've submitted a rev of the RSVP APP-ID profiles ID, here
> http://www.ietf.org/internet-drafts/draft-polk-tsvwg-rsvp-app-id-vv-profiles-01.txt
> 
> This rev addresses two of Francois's three concerns below, which I'll answer now (Francois, a thousand pardons!!!):
> 
> - I incorporated his suggestion to change the value of the GUID from something like "RFC4594" to "http://www.ietf.org/rfc/rfc4594.txt" for each profile.
> 
> - I removed the (obvious now) DSCP from each profile name
> 
> - I did not address creating a new attribute for this simple reason, right now, this is only an IANA registry doc, and creating a new attribute would make it more than it is.  I don't have a clear view of what folks think about making this change. I know that right now, this is an individual ID so I can make any changes I want, but I'd like to get the WG to agree to this change -- which I'm not against. What do folks think about making this more than a simple IANA registry doc?
> 
> James
> (without my WG chair hat on, obviously)
> 
> 
>> James, Subha,
>> 
>> The idea of signaling an RSVP policy locator at the granularity of application class make sense to me.
>> 
>> A few comments on the document from a first read:
>>        * for GUID, I suggest you use something like "http://www.ietf.org/rfc/rfc4594.txt" instead of "RFC4594"
>>        * have you considered defining a new attribute (eg APP-SC = Application Service Class) to carry the application service class instead of reusing the existing APP attribute (that is itended to identify applications)?
>>        * I strongly suggest you remove the DS Codepoint from the name of each "profile"
>> (ie s/The Broadcast video (CS5) Profile/The Broadcast video Profile/) because the relationship between the two is only "RECOMMENDED". So what you want to signal is the Service Class, which typically will be mapped into the recommended CS codepoint (but possibly into another).
>> 
>> Cheers
>> 
>> Francois
> 

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 10 Nov 2010 10:38:40 +0800

Hi James,

A few more suggestions:

HTH

Francois

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

Think before you print.