Subject: Re: WGLC Announcement for draft-ietf-tsvwg-iana-ports-08 - 26th November2010

From: Magnus Westerlund <[email-masked]>
Date: Wed, 1 Dec 2010 15:44:07 +0100

Hi,

The author team has now edited this issue into our draft version.
However, after some consideration of IANAs language use we have ended up
using "assign" and assignment instead of allocation. Then we use
"assignment request" or "assignment procedure" depending on context. I
hope that is still satisfactory.

Magnus

t.petch skrev 2010-11-03 16:47:
> ----- Original Message -----
> From: "Magnus Westerlund" <[email-masked]>
> To: "t.petch" <[email-masked]>
> Cc: "tsvwg list" <[email-masked]>
> Sent: Wednesday, November 03, 2010 1:46 PM
> 
>> Hi Tom,
>>
>> Apparently your comment from January about the mix of terms was missed
>> and not addressed.
>>
>> If I understand the English terms correctly, what we are describing that
>> IANA should do is Allocation, i.e. set aside identifiers for particular
>> usages. We are not giving over the number space to the ones that
>> request, thus Assignment would be wrong?
>>
>> I think we can mostly eliminate one of the terms assignment and
>> allocation. I think we will have more difficult to get rid of
>> registration. My personal thinking on this is at least the following
>> relationship between the terms: A Registrant performs a Registration
>> (process or request) so that IANA can perform an Allocation of a service
>> name and possibly ports.
> 
> Magnus
> 
> That would address my concern. As you say, assign has more of an overtone
> of a legal transfer of ownership, which allocate does not (even if my dictionary
> defines allocate as assign:-(  There is a lot of assignation in the current I-D
> but
> I think that most of it should be changed.
> 
> I like too the idea that registration is the request, and that IANA allocates,
> and
> again, there is a lot of registration and I think that most of it should be
> changed.
> 
> It is unfortunate that the end result of an allocation by IANA is a registry but
> I
> do not think that that can be helped:-(   Whatever terminology we agree on,
> I think that the I-D should spell it out early on.
> 
> I did scan a variety of I-Ds with IANA actions and see IANA allocating,
> registering
> and assigning values in registries, with perhaps the last as the most common,
> but that does
> not make it the right choice for me.
> 
> Tom Petch

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "t.petch" <[email-masked]>
Date: Fri, 3 Dec 2010 15:22:25 +0100

----- Original Message -----
From: "Magnus Westerlund" <[email-masked]>
To: "t.petch" <[email-masked]>
Cc: "tsvwg list" <[email-masked]>
Sent: Wednesday, December 01, 2010 3:44 PM
> hope that is still satisfactory.

Yes, it is a massive improvement in terms of clarity and readability; thanks for
that.

Tom Petch