Subject: <draft-carlberg-tsvwg-ecn-reactions-01.txt>

From: Gorry Fairhurst <[email-masked]>
Date: Sun, 25 Mar 2012 16:31:12 +0200

Ken et al., I have the following comments on this draft, as a TSVWG participant - no chair hat!

How much is known of the  3gpp reference to RFC 3448 rather than RFC 5348 - the issue stated was one of the key reasons for updating this RFC - experience with DCCP over wireless noted similar problems with the original spec. It would be really good to know more... And equally important from my perspective to say something of the changes in RFC 5348 to avoid any possible confusion by a reader.

That said, the rest of the draft describes approaches and issues , we're exploring similar threads from the perspective of a video codec, so it seems interesting ... What sort I'd document do you plan to finally make? One that offers advice, specs methods, or reports information ?

####

I suggest you avoid the ref citation within the abstract.

####

Gorry

---

From: ken carlberg <[email-masked]>
Date: Mon, 26 Mar 2012 03:28:57 -0400

Hi Gorry,

Thanks a lot for the comments 

> How much is known of the  3gpp reference to RFC 3448 rather than RFC 5348 - the issue stated was one of the key reasons for updating this RFC - experience with DCCP over wireless noted similar prob…

agreed, we can add some text that highlights some of the changes that took us from rfc-3448 to rfc-5348.  I think the 3gpp reference may be attributed to an old snapshot of referring to an IETF document that they'll probably update in time.  I'm not familiar with experience of DCCP over wireless, so perhaps we can discuss that in the hallway or offline.

> That said, the rest of the draft describes approaches and issues , we're exploring similar threads from the perspective of a video codec, so it seems interesting ... What sort I'd document do you p…

at present, we had envisioned the draft as being one that offers "advice", and thus informational in nature.  In private talks with some others, it seems helpful to have a relatively high-level discussion on the topic versus the detailed signaling ECN-for-RTP spec.  Method and report information can subsequently flow from this, but I think the first order of business after our presentation today will be to see if the draft can/should be accepted as a working group document.

as for video codec, we'd appreciate following up on this.  Piers did some earlier work on looking at backing off traffic using UCL's VIC, which gave us some food for thought.  And while the draft cites examples with respect to voice, our intent was to be a bit broader and include video as well, so we can probably improve the text to make this clearer.

> I suggest you avoid the ref citation within the abstract.

sure, can do.

-ken