Subject: Comments on draft-dreibholz-tsvwg-sctpsocket-sqinfo-03.txt

From: Gorry Fairhurst <[email-masked]>
Date: Sun, 25 Mar 2012 16:24:16 +0200

As a part of my effort to look at all active TSVWG drafts, I have the following comments on this draft, as a TSVWG chair with a focus on editorial/process.

I suggest you add an Updates line to the top of the draft, saying "Update RFC xxxx if approved"

If this is planned as experimental, then it would be good for the abstract to say this, and also explain why it is experimental (I.e. what needs to be confirmed before this could be judged safe for wide scale deployment)

I am not sure whether this particular document would then need to be EXP or another document type. Are there known issues with the recommended approach that could lead to operational concerns or interoperability failures? 

I think the rationale for adding this needs to be stronger, because if this is to be standardised, then it would need justification to update the spec. 

In some ways the basic information (clearly not all) supplied could be generic to other transports -is this feasible?

Best wishes

Gorry
(TSVWG co-chair)

---

From: Michael Tuexen <[email-masked]>
Date: Sun, 25 Mar 2012 23:09:01 +0200

Hi Gorry,

same comment as in my other mail. We might want that stuff in the loadsharing ID (part
of socket API section)... It is mainly useful for loadsharing...

Best regards
Michael