Subject: [tsvwg] FW: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

From: "Cheng-Jia Lai (chelai)" <[email-masked]>
Date: Sat, 9 Feb 2013 03:00:48 +0000

Hi all,

We have submitted a new Internet draft to describe a Normalization Marker (NM) for DiffServ AF PHB groups, based on our work at Cisco. The goal of NM deployment is to create a new incentive for video encoders to generate more discardable packets when using AF PHB in DIffServ. We are looking forward to your review comments.

Best regards,
CJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, February 08, 2013 6:25 PM
To: Cheng-Jia Lai (chelai)
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

A new version of I-D, draft-lai-tsvwg-normalizer-00.txt
has been successfully submitted by Cheng-Jia Lai and posted to the
IETF repository.

Filename:	 draft-lai-tsvwg-normalizer
Revision:	 00
Title:		 Normalization Marker for AF PHB Group in DiffServ
Creation date:	 2013-02-08
WG ID:		 Individual Submission
Number of pages: 15
URL:             http://www.ietf.org/internet-drafts/draft-lai-tsvwg-normalizer-00.txt
Status:          http://datatracker.ietf.org/doc/draft-lai-tsvwg-normalizer
Htmlized:        http://tools.ietf.org/html/draft-lai-tsvwg-normalizer-00

Abstract:
   This memo describes a Normalization Marker (NM) at DiffServ (DS)
   nodes to normalize the distribution of DS codepoint (DSCP) markings
   for an Assured Forwarding (AF) Per-Hop Behavior (PHB) group.  NM is
   useful for traffic conditioning with Active Queue Management (AQM)
   when the AF PHB group is deployed for multimedia service classes that
   carry video packets with advanced codec technologies.  Using NM can
   offer an incentive that is however missing in today's ecosystem of
   practical deployment, i.e., when congestion occurs in the AF PHB
   group, the network should allow a video codec to benefit from its
   effort of generating finer layers of intra-flow precedence (IFP) with
   discardable packets in a more balanced distribution.

The IETF Secretariat

---

From: "Cheng-Jia Lai (chelai)" <[email-masked]>
Date: Fri, 15 Feb 2013 19:03:15 +0000

Hi folks,

Will appreciate some comments on this new draft that we posted last week for NM in AF PHB groups of DiffServ.

Thanks,
CJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cheng-Jia Lai (chelai)
Sent: Friday, February 08, 2013 7:01 PM
To: [email-masked]
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: [tsvwg] FW: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

Hi all,

Best regards,
CJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, February 08, 2013 6:25 PM
To: Cheng-Jia Lai (chelai)
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

Abstract:

The IETF Secretariat

---

From: <[email-masked]>
Date: Tue, 19 Feb 2013 09:32:08 +0100

Hi CJ,

an important assumption for the draft to work seems to be video layer information availability, as AF PHBs are proposed to be assigned to a stream based on aggregate video flow frame properties. To gain this information, a video flow must not be encrypted and DPI may be applicable. The normalisation suggests to treat all flows equally in terms of percentage of assigned AF PHBs within a single AF class.

I'm working for a network provider and I'm not sure whether the approach would add sufficient value to a QoS based streaming service to justify the effort required. Might it be simpler to leave AF class PHB percentages to SLAs and accounting agreements between CDNs and network providers? In that case, your draft may be relevant for CDNs.

Regards,

Ruediger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cheng-Jia Lai (chelai)
Sent: Friday, February 15, 2013 8:03 PM
To: [email-masked]
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: Re: [tsvwg] FW: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

Hi folks,

Thanks,
CJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Cheng-Jia Lai (chelai)
Sent: Friday, February 08, 2013 7:01 PM
To: [email-masked]
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: [tsvwg] FW: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

Hi all,

Best regards,
CJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 08, 2013 6:25 PM
To: Cheng-Jia Lai (chelai)
Cc: Wenyi Wang (wenywang); Stan Yang (stanyang); Toerless Eckert (eckert); Fred Yip (fyip)
Subject: New Version Notification for draft-lai-tsvwg-normalizer-00.txt

Abstract:

The IETF Secretariat