Subject: [tsvwg] Some comments on draft-ietf-tsvwg-sctp-sack-immediately-01.txt (Implementation requirements)

From: [email-masked]
Date: Fri, 15 Mar 2013 16:45:07 -0000

This could look like a protocol update to RFC 4960.
- It seems to change a field in the receiver behaviour, I'm not sure
whether this should be seen as an update to the base spec or not, have you
thought about this?
- If it does, maybe you could add: updates="RFC 4960 (if published)".

There is  also one detail I think should be clear:
- I understand that it says this is backwards compatible.
- I therefore read this as the receiver side of this logic is optional, if
so, saying this is a backwards-compatible optional extension in the
abstract is good (no RFC 2119 language in the abstract).

Best wishes,

Gorry

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 15 Mar 2013 15:50:35 -0400

> - If it does, maybe you could add: updates="RFC 4960 (if published)".
Yes, you are right. We change the behavior of the receiver. So the next
revision will contain the "RFC 4960 (if published)" text.
> - I understand that it says this is backwards compatible.
Correct.
> abstract is good (no RFC 2119 language in the abstract).
OK, I added
Since unknown flags in chunk headers are ignored by SCTP implementations,
this extension does not introduce any interoperability problems.
Does that cover it?

Thanks a lot for your comments.

Best regards
Michael

---

From: [email-masked]
Date: Sat, 16 Mar 2013 13:56:02 -0000

Seems good to me.

Please publish a revised ID that includes this and any minor edits that
have been suggested to the authors.

I think this may then be ready for a WGLC to see if the WG has further
comments.

Gorry
(TSVWG Co-Chair)

---

From: Michael Tuexen <[email-masked]>
Date: Sat, 16 Mar 2013 20:19:18 +0100

> have been suggested to the authors.
Done.
> I think this may then be ready for a WGLC to see if the WG has further
Yes, I think this is ready for WG LC.

Best regards
Michael