Subject: [tsvwg] Query regarding heartbeat re-transmission pattern

From: Ankit Mahawar <[email-masked]>
Date: Wed, 20 Mar 2013 15:16:56 +0530

Hi All ,

I have a basic query regarding SCTP heartbeat re-transmission pattern .

As per the RFC 4960 :

Furthermore, when its peer is multi-homed, an endpoint SHOULD try to
retransmit a chunk that timed out to an active destination transport
address that is different from the last destination address to which the
DATA chunk was sent.

Also,
When retransmitting data that timed out, if the endpoint is multi-homed, it
should consider each source-destination address pair in its retransmission
selection policy.  When retransmitting timed-out data, the endpoint should
attempt to pick the most divergent source-destination pair from the
original source-destination pair to which the packet was transmitted.

Suppose if we have multihomed SCTP endpoints A and B .

A                      B

a.a.a.p               b.b.b.p
a.a.a.s               b.b.b.s

If we transmit heartbeat from a.a.a.s to b.b.b.s and it is not acknowledged
so does it re-transmit it using the same src and destination or with
a.a.a.p to b.b.b.s.

Please help to understand .

Thanks

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Wed, 20 Mar 2013 19:19:17 +0000

Hi Ankit,

is it only the heartbeat that failed (are there other packets flowing between A.p to B.p), in your scenario?

I would read the 2nd fragment of text, that if A.s to B.s failed, a retransmission (of data) should be checked between A.p to B.p first; other (possible) combinations, like A.p -> B.s, or A.s -> B.p later...

Regards,

Richard Scheffenegger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Ankit Mahawar
> Sent: Mittwoch, 20. März 2013 10:47
> To: [email-masked]
> Subject: [tsvwg] Query regarding heartbeat re-transmission pattern
> 
> 
> Hi All ,
>

---

From: Ankit Mahawar <[email-masked]>
Date: Thu, 21 Mar 2013 11:58:42 +0530

Hi Richard,

I wanted to know the scenario how SCTP behave when the heartbeat is not
acknowledged  and the timer expires  waiting for the acknowledgement.

Thanks

  From:       "Scheffenegger, Richard" <[email-masked]>                                                                                   
                                                                                                                                         
  To:         Ankit Mahawar <[email-masked]>, "[email-masked]" <[email-masked]>                                                   
                                                                                                                                         
  Date:       03/21/2013 12:49 AM                                                                                                        
                                                                                                                                         
  Subject:    RE: [tsvwg] Query regarding heartbeat re-transmission pattern                                                              

Hi Ankit,

is it only the heartbeat that failed (are there other packets flowing
between A.p to B.p), in your scenario?

I would read the 2nd fragment of text, that if A.s to B.s failed, a
retransmission (of data) should be checked between A.p to B.p first; other
(possible) combinations, like A.p -> B.s, or A.s -> B.p later...

Regards,

Richard Scheffenegger

---

From: Padmalochan Moharana <[email-masked]>
Date: Thu, 21 Mar 2013 12:09:34 +0530

Hi Ankit,

Please go through the below section in rfc4960.

8.3 <http://tools.ietf.org/html/rfc4960#section-8.3>.  Path Heartbeat

Thanks,
Padmalochan

---

From: Ankit Mahawar <[email-masked]>
Date: Thu, 21 Mar 2013 12:36:24 +0530

Hi All,

Thanks for your replies.

Actually I am a little confused as to whether heartbeats are re-transmitted
when the timer expire or it will be transmitted as per the HB.interval even
when the last heartbeat was not acknowledged.

Thanks

  From:       Padmalochan Moharana <[email-masked]>                                                                                  
                                                                                                                                         
  To:         Ankit Mahawar <[email-masked]>                                                                                      
                                                                                                                                         
  Cc:         "Scheffenegger, Richard" <[email-masked]>, "[email-masked]" <[email-masked]>                                                
                                                                                                                                         
  Date:       03/21/2013 12:10 PM                                                                                                        
                                                                                                                                         
  Subject:    Re: [tsvwg] Query regarding heartbeat re-transmission pattern                                                              

Hi Ankit,

8.3.  Path Heartbeat

Thanks,
Padmalochan

On Thu, Mar 21, 2013 at 11:58 AM, Ankit Mahawar <[email-masked]>
wrote:
  Hi Richard,

  Thanks

    To:         Ankit Mahawar <[email-masked]>, "[email-masked]" <
  [email-masked]>

    Subject:    RE: [tsvwg] Query regarding heartbeat re-transmission
  pattern

  Hi Ankit,

  I would read the 2nd fragment of text, that if A.s to B.s failed, a
  retransmission (of data) should be checked between A.p to B.p first;
  other
  (possible) combinations, like A.p -> B.s, or A.s -> B.p later...

  Regards,

  Richard Scheffenegger

  > When retransmitting data that timed out, if the endpoint is
  multi-homed,
  > it

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 21 Mar 2013 12:34:49 -0600

Ankit,

Transmitted on HB.interval, retransmitted on RTO.

--brian

Ankit Mahawar wrote:                (Thu, 21 Mar 2013 12:36:24)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/