Subject: [tsvwg] Comment on security considerations of draft-ietf-tsvwg-sctp-sack-immediately

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 11 Mar 2013 16:36:35 -0400

Michael,

Is there  potential extra remote processing/capacity of sending segments 
with the I-bit or not?

(Am I correct in thinking that there is actually little extra work that 
can be forced on a receiver using this bit?)

It may be worth explaining why this is an issue or non-issue in the 
security considerations. If we do this it may be worth noting this, this 
may be better than assuming reviewers are familiar with sctp.

Gorry

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 14 Mar 2013 13:09:38 -0400

On Mar 11, 2013, at 4:36 PM, Gorry Fairhurst wrote:

> Michael,
> 
> Is there  potential extra remote processing/capacity of sending segments with the I-bit or not?
> 
> (Am I correct in thinking that there is actually little extra work that can be forced on a receiver using this bit?)
> 
> It may be worth explaining why this is an issue or non-issue in the security considerations. If we do this it may be worth noting this, this may be better than assuming reviewers are familiar with sctp.
Hi Gorry,

what about adding:
It should be noted that an malicious sender can force its peer to send
packets containing SACK chunks for each received packet containing DATA chunks instead
of every other. However, every receiver has to be able to do this anyway.
It might be configured to do so or has to do this because of packet loss or reordering in the network.

Best regards
Michael