Subject: [tsvwg] [Technical Errata Reported] RFC6056 (3739)

From: RFC Errata System <[email-masked]>
Date: Thu, 26 Sep 2013 08:19:31 -0700 (PDT)

The following errata report has been submitted for RFC6056,
"Recommendations for Transport-Protocol Port Randomization".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6056&eid=3739

--------------------------------------
Type: Technical
Reported by: Jean-Yves Migeon <[email-masked]>

Section: Appendix A

Original Text
-------------
   NetBSD 5.0.1 does not obfuscate its ephemeral port numbers.  It
   selects ephemeral port numbers from the range 49152-65535, starting
   from port 65535, and decreasing the port number for each ephemeral
   port number selected [NetBSD].

Corrected Text
--------------
   NetBSD 5.0.1 does not obfuscate its ephemeral port numbers.  It
   selects ephemeral port numbers from the range 49152-65535, starting
   from port 65535, and decreasing the port number for each ephemeral
   port number selected [NetBSD].

   NetBSD 6.0 supports RFC 6056 Algorithms 1, 2, 3, 4 and 5 with port
   numbers from the range 49152-65535 as documented in [NetBSD-RFC6056].

Notes
-----
The project implemented the RFC 6056 algorithms last year to obfuscate the ephemeral port numbers.

[NetBSD-RFC6056] reference is:
The NetBSD Project, "NetBSD Miscellaneous Information Manual -- RFC 6056, Randomization Algorithms", man page - section 7, August 2011.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6056 (draft-ietf-tsvwg-port-randomization-09)
--------------------------------------
Title               : Recommendations for Transport-Protocol Port Randomization
Publication Date    : January 2011
Author(s)           : M. Larsen, F. Gont
Category            : BEST CURRENT PRACTICE
Source              : Transport Area Working Group
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: <[email-masked]>
Date: Thu, 26 Sep 2013 23:59:13 +0100

Sorry, clear reject.

RFC6056 was published Jan 2011, and its statement about NetBSD 5.0.1 remains true. I see the NetBSD 6.0 man page is dated August 2011 - after RFC6056 was published.

Errata are for corrections to errors, not for additions or updates to account for things that hadn't yet happened, or for advertising of capabilities. This doesn't change the BCP recommendations in RFC6056; RFC6056 doesn't need to change.

(Oh, either 'decreasing' should be 'decreases' or that second comma shouldn't be there. Subordinate clauses, people! Elide ', starting from 65535,' and it reads badly. But that's not worth filing an erratUM report on either.)

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of RFC Errata System [[email-masked]]
Sent: 26 September 2013 16:19
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [tsvwg] [Technical Errata Reported] RFC6056 (3739)

Section: Appendix A

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------