Subject: [tsvwg] TSVWG Status update, August 2014.

From: [email-masked]
Date: Mon, 11 Aug 2014 14:37:45 +0100

The list below shows the status of the working group documents as we see
it. Please check below and comment on drafts using the list. Please do
send any corrections/omissions to the chairs.

Gorry, David & James
(TSVWG Chairs)
August 2014

-------------------------------------------------------------------

Document recently published:
RFC 7141, formerly draft-ietf-tsvwg-byte-pkt-congest - Document Shepherd:
Gorry

-------------------------------------------------------------------

IDs in RFC Editor Queue (http://www.rfc-editor.org/queue.html) :
None

----------------------------------------------------------

IDs in IESG processing:
draft-ietf-tsvwg-rsvp-pcn - Document Shepherd: James/David
Document adopted, status will be EXP (IETF-84 due to dependencies on RSVP)
RSVP-DIR review received (BB, KC).
WGLC concluded Friday, August 23rd, 2013.
Nov 2013, Next step new ID required to address RSVP model and then repeat
WGLC Document revised. Francois added as author.
No noted disagreement from WG.
Mar 2014, WGLC started on the updated text. Scott Bradner commented on
document in WGLC.
Because this is intended to become an Experimental RFC (and not Proposed
Standard), it was necessary to perform the IANA actions prior to
submitting the RFC publication request. - Done.
Aug 2014 - IANA actions performed, write-up submitted;
RFC publication requested.
-------------------------------------------------------------------

New proposed work:
draft-fairhurst-tsvwg-circuit-breaker (adoption request on tsvwg list)
draft-eggert-tsvwg-rfc5405bis (adoption request soon)
draft-geib-tsvwg-diffserv-intercon-02.txt (next version expected to be
called for adoption)
draft-welzl-ecn-benefits (please read)

-------------------------------------------------------------------
WG Drafts with Chairs:
draft-ietf-tsvwg-sctp-dtls-encaps - PS - Document Shepherd: Gorry
Replaces: draft-tuexen-tsvwg-sctp-dtls-encaps-01
WG adopted 13/12/2013. Support {AB, IR, SL, MB, TD}
[Milestone: Jan 2014, PS] Implemented in Firefox (FF21).
Required by RTCweb. Comments received.
WGLC ended 28th February 2014.
Comments from Joe Touch (draft updated)
Review comments and revised ID published.
++ Eric Rescorla has reviewed this.
DUE: Security input needed to determine text describing DTLS version.

DUE: WG Shepherd write-up to be prepared.
---
draft-ietf-tsvwg-sctp-prpolicies - PS - Document Shepherd: Gorry
Replaces: draft-tuexen-tsvwg-sctp-prpolicies
Nov 2013, Adopted SCTP PR Polices intended for publication as a PS RFC
March 2014, Next revision expected for WGLC.
Gorry read 20-May-2014, needs to be PS, explain Info section in wrietup
Revised ID May 2014.
1-Jul-2014 Gorry reviewed standards language
WGLC started to end July 21st, 2014
- support JHS, KN, MB, IR, GF; comments from Karen Nielson, Brian
Bidulock, Gorry
DUE: Revised ID now needed after WGLC
DUE: WG Shepherd write-up to be prepared - Gorry
-------------------------------------------------------------------

WG Drafts
---
draft-ietf-tsvwg-port-use - Document Shepherd: Gorry
Replaces: draft-touch-tsvwg-port-use-00
- Intended to be advice to protocol designers needing a port.
5 people looked at this document, Prague IETF-80
Individual -01 July 2011
IETF-81 insufficient feedback from WG at this time.
IETF-82, discussed.
Adopted by WG Presented IETF-86, March 2013
Milestone updated to June 2014
Mar 2014, Chairs WGLC to be started after current WG actions.
- IANA review comments received
- Sent review requests to RAI, APPS, and SEC areas during 1st WGLC.
+ Comments May 2014: Paul Hoffman; Lars Eggert; IANA; David Black;
5 Jun 2014, WGLC completed - comments received.
DUE: Revised ID needed.
---
draft-ietf-tsvwg-rsvp-app-id-vv-profiles
Replaces: draft-polk-tsvwg-rsvp-app-id-vv-profiles
-01 Presented in Beijing, IETF-79.
-02, 14-Mar-2011
Presented IETF-80.
Seek to coordinate with music with partner ID:
draft-polk-mmusic-traffic-class-for-sdp
Gorry liaised with MMUSIC WG Chairs on companion draft (norm ref from this
tsvwg draft).
Adopted as a TSVWG work item, December 2013, [Milestone Jul 2013].
This will update a RFC 2872 (PS).
Presented at IETF-86,
Mar 2013 (no comments)
Expected ready for WGLC (waiting on MMUSIC)
DUE: Reviewers are needed to prepare for a WGLC
---
draft-ietf-tsvwg-natsupp-tsvwg - Document Shepherd: James
Replaces: draft-stewart-natsupp-tsvwg
Dependency from BEHAVE WG.
Adopted as a work item 21 Sept 2010 (Gorry).
WG -00, 29/11/2010 Uploaded as: draft-ietf-natsupp-tsvwg
Authors restructured draft (-03)
Added support for single and multi-homed support.
IETF-86: 3 people in meeting had read -04 or -05.
Feb 2014, Authors please update following comments and align to related
draft on SCTP NAT (conflicts found in language)
Authors expected to produce a single document to replace both.
++ Dan Wing has committed to review this.
++ Fred Baker has committed to review this.
Chairs: We plan to start a WGLC, but are expecting this document to be
restructured and merged with draft-ietf-tsvwg-sctpnat
---
draft-ietf-tsvwg-sctpnat - Document Shepherd: Gorry
Replaces: draft-ietf-behave-sctpnat-03.txt Adopted Nov 2013.
Former BEHAVE WG work item that defines SCTP NAT support
Feb 2014, Authors please update following comments and align to related
draft on SCTP NAT (conflicts found in language)
Chairs: - authors have requested a single document to replace both.
++ Fred Baker will review next version.
Separated the simpler case for single-homed use - this separation should
be clearer
Chairs: We plan to start a WGLC, but are expecting this document to be
restructured and merged with draft-ietf-tsvwg-sctpnat
---
draft-ietf-tsvwg-behave-requirements-update - Document Shepherd: David
Replaces: draft-ietf-behave-requirements-update-00
Nov 2013, Former BEHAVE WG work item intended for publication as a BCP
Mar 2014, Irene R reviewed this and found no conflict with SCTP drafts.
Some suggestions (in no particular order) for a shepherd:
++ Dave Thaler, may review, as former behave co-chair
++ David Harrington, has been around in behave, and he knows how to do
this and volunteered multiple times.
++ Ask Jana to review this.
++ Dan has committed to review this.
Chairs: Check intention and planned timeline.
DUE: Please comment on list
---
draft-ietf-tsvwg-sctp-failover - Document Shepherd: James
Replaces: draft-nishida-tsvwg-sctp-failover
Individual-00 Presented in Prague, IETF-80.
- Understood not to conflict with draft-tuexen-tsvwg-sctp-multipath
- PF has been coded into FreeBSD
Adopted by WG 26/6/2012. [Milestone: Jul 2013, EXP]
DUE: March 2014.
DUE: Please comment on list.
---
draft-ietf-tsvwg-sctp-ndata - PS
- replaces: draft-stewart-tsvwg-sctp-ndata-03 Nov 2013,
Adopted , intended for publication as a PS RFC
Mar 2014, 5-6 people had read.
DUE: Revised ID needed.
---
draft-tsvwg-gre-in-udp-encap - PS Document Shepherd: David
- replaces: draft-yong-tsvwg-gre-in-udp-encap
Dec 2013, Adopted , intended for publication as a PS RFC
Feb 2014, discussion of scope and applicability of circuit breakers
Mar 2014 consider MUST implement, SHOULD use in these environments for CB
DUE: Revised ID needed, waiting on RTG AD text inclusion with
draft-ietf-mpls-in-udp draft that will also be used in this draft.
---
draft-ietf-tsvwg-rtcweb-qos - PS - Document Shepherd: David
- Replaces: draft-dhesikan-tsvwg-rtcweb-qos
- RTCweb and QoS Markings
- Authors requested TSVWG adoption.
- Who has read the draft? (lots 10's of people)
25-Mar-2014, Adopted by tsvwg
- Who thinks it is important to do work in the IETF? (Many)
I-D updated after initial TSVWG feedback
Mar 2014, Adoption call (strong support in WG meeting London)
Adoption call concluded 24 Match 2014: intended as a PS RFC for Sept 2014
++ Magnus agreed to review this.
Mar 2014, Please subscribe to "DART" for other related discussions.
Aug 2014, DART draft (draft-ietf-dart-dscp-rtp) is now in WGLC; that draft
needs to be completed before we can WGLC this rtcweb-qos draft.
DUE: Please comment on list, see IETF DART WG.
---
draft-ietf-tsvwg-ecn-encap-guidelines - Document Contact: Gorry

replaced draft-briscoe-tsvwg-ecn-encap-guidelines
-00 Presented in Prague, IETF-80.
- comments at IETF-80 (see minutes)
New ID presented in Atlanta, IETF-85. ID presented in IETF-88,89
++ forward an appropriate message (perhaps your note to the mailing list
for approval to adopt) to [email-masked])
++ Reviewers: Andrew McGregor, Dirk Kutscher, Richard Scheffnegger, Brian
Tramwell.
Mar 2014, WG Call for adoption started, to end 4th March 2014
19 for, 1 against. 8 echoed on the list
Adoption call concluded and document adopted.
* ecn-encap-guidelines and AQM are the main new things they need to know
about.
on <http://www.ietf.org/proceedings/86/train-3.html>IEEE802.1Q)
DUE: Please comment on list.
-------------------------------------------------------------------
Expired WG documents:
draft-ietf-tsvwg-intserv-multiple-tspec - Document Shepherd: David
WG interest in this topic recorded at IETF-78.
Charter update needed to progress this work.
5 Reviews needed to determine energy/technical direction.
WG -05 (presented in Beijing, IETF-79)
WG -06 (presented in Prague, IETF-80)
2 reviews from RSVP-DIR received (Bruce Davie, ?)
2 additional reviews promised (Ken Carlberg, Francois LeF)
Chairs asked AD for a Charter update (IESG agreed)
Draft discussed at IETF-80, and request to update charter agreed
- AD advised 4 named reviewers will be required
Adopted for progression as PS, for May 2012
- New name: 'RSVP Multiple Instance'.
Draft is now expired and dead.
DUE: Draft authors will request replacement with
draft-polk-rsvp-multi-instance-object (and WG adoption of that draft in
Honolulu, IETF-91)

-------------------------------------------------------------------
The following have received recent discussion at TSVWG meetings or on
the list. Inclusion in the list below does not indicate support for
these specific drafts and other contributions are also warmly welcomed.
---------------------------------------------------------------
Authors request to be considered for adoption:
---
draft-geib-tsvwg-diffserv-intercon-02.txt - Document Contact: David
DiffServ interconnection classes
New ID presented in Atlanta, IETF-85.
ID presented in Orlando, IETF-86, Mar 2013. Mar 2014, intended scope
unclear at IETF London Adoption call to be considered, but scope needs to
be first refined and a revised draft is necessary to avoid implications of
broader applicability.
July 2014 - ID presented in Toronto. Strong hum of support to work on
this, but a revised draft is needed first.
DUE: revised draft required, WG adoption call expected on that next version.
---
draft-eggert-tsvwg-rfc5405bis
- Individual (Gorry & Lars)
Mar 2014, the ADs proposed the WG re-open the UDP Guidelines RFC for
update to include this work and other topics.
NOTE: Update milestone in charter, if adopted: ‘Multicast UDP Guidelines’
is being incorporated in this.
Presented IETF-90, Hum supporting adoption, none against.
++ Brian Tramwell and Jana agreed to review this.
Chairs:Adoption call to be started on list.

---
draft-fairhurst-tsvwg-circuit-breaker
- Individual (Gorry Fairhurst)
Call for WG adoption issued - August 2014
DUE: Please comment on list
---
draft-wing-tsvwg-turn-flowdata-00.txt
- Individual (no decision to adopt at this time)
- QoS-aspects to be discussed in tsvwg (thought to also be relevant to
TURN WG)
----
draft-welzl-ecn-benefits
- Individual (Michael Welzl)
- Thought to be within tsvwg or aqm WGs, to be proposed as a work item in
AQM.

+++ END OF LIST +++

---

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Sun, 24 Aug 2014 14:39:07 +0200

Hi,

> - PF has been coded into FreeBSD
[Karen] The feature is supported as well in Ericsson in-house SCTP SW
implementation.
The feature is partially implemented in Linux SCTP SW (July 2014)
with the intent to implement full support in accordance with most recent
version of the draft.
> DUE: Please comment on list.
[Karen] From the authors perspective we are looking for a WGLC assessment
of this work.

BR, Karen