Subject: Re: [tsvwg] [IANA #803160] FW: Port squatting

From: Joe Touch <[email-masked]>
Date: Tue, 17 Feb 2015 09:24:18 -0800

Hi, Pearl,

We don't have a mechanism for doing anything here, except that you might 
want to indicate that range as "unauthorized use".

Lars - does the TSV want to find someone to contact parties that do 
this? This sort of issue has come up before, and although we can't do 
much about defiance, it might be merely ignorance.

Joe

On 2/17/2015 9:17 AM, Pearl Liang via RT wrote:
> Joe and Lars,
>
> What do we need to do for this raised by Rick Bellingar?
>
> Thanks,
> ~pl
>
> On Mon Jan 12 13:49:31 2015, [email-masked] wrote:
>> Lars,
>>          Thanks for the response.
>>          A recent firewall change request in support of a Progress
>> database installation that I challenged surfaced the following -
>>
>> "Each remote server is assigned a port when it is initially spawned.
>> By default, the remote servers use the first available port in the
>> 1025-2000 range on UNIX (3000-5000 for Windows)."
>> http://knowledgebase.progress.com/articles/Article/P98541
>>
>> The article does also give instructions for assigning an "alternate"
>> port range.
>>
>> Rick Bellingar
>> Reed-Elsevier Information Security
>> 937-865-7005
>>
>> -----Original Message-----
>>   From: Eggert, Lars [mailto:[email-masked]]
>> Sent: Monday, January 12, 2015 6:16 AM
>> To: Bellingar, Richard J. (RET-DAY)
>> Cc: [email-masked]; [email-masked]
>> Subject: Re: [tsvwg] [IANA #800143] Port squatting
>>
>> Hi,
>>
>> On 2015-1-11, at 18:01, Bellingar, Richard J. (RET-DAY)
>> <[email-masked]> wrote:
>>>
>>> I really don't understand Pearl's answer (below). At one time, I
>>> found a means (an email address, I think) to report
>>> companies/applications that were using ports in the System &
>>> Registered ranges that were not reserved or were reserved by other
>>> companies/apps. Those then, presumably, were added to the IANA
>>> database and depicted in the "Known Unauthorized Uses" column of
>>> http://www.iana.org/assignments/service-names-port-numbers/service-
>>> names-port-numbers.xhtml . Has that practice ceased?
>>
>> no, but it involves the IETF and the area director. So raising it on
>> this list is the right thing to do, and then Martin and Spencer can
>> instruct IANA via the IESG as needed.
>>
>> Lars
>>
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 17 Feb 2015 17:29:17 +0000

Hi,

On 2015-2-17, at 09:24, Joe Touch <[email-masked]> wrote:
> 
> We don't have a mechanism for doing anything here, except that you might want to indicate that range as "unauthorized use".

right. The ADs/IESG would be the people to decide if this should be done.

> Lars - does the TSV want to find someone to contact parties that do this? This sort of issue has come up before, and although we can't do much about defiance, it might be merely ignorance.

Not sure if this is worth the trouble. It would be very difficult to identify someone to raise this with, and it's unlikely to make them change their practice.

Lars

PS: I would like to make it easier for people to report any squatting they see, however. Rick tracked down the TSVWG list, but maybe adding a paragraph to the IANA registry page would let others find this list, too.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 17 Feb 2015 17:36:39 -0000

I believe IANA has standard language to put in a registry for any code point
squat.

A

> From: tsvwg [mailto:[email-masked]] On Behalf Of Eggert, Lars
> Sent: 17 February 2015 17:29
> To: Joe Touch
> Cc: [email-masked]; [email-masked]
> Subject: Re: [tsvwg] [IANA #803160] Port squatting
> 
> Hi,
> 
> > Lars - does the TSV want to find someone to contact parties that do this?
This
> sort of issue has come up before, and although we can't do much about
defiance,
> it might be merely ignorance.
> 
> Not sure if this is worth the trouble. It would be very difficult to identify
someone
> to raise this with, and it's unlikely to make them change their practice.
> 
> Lars
> 
> PS: I would like to make it easier for people to report any squatting they
see,
> however. Rick tracked down the TSVWG list, but maybe adding a paragraph to
> the IANA registry page would let others find this list, too.
> 
> >
> > Joe
> >

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Tue, 17 Feb 2015 17:17:16 +0000

Joe and Lars,

Thanks,
~pl