Subject: [tsvwg] UDP usage guidelines and tunnels

From: Erik Nordmark <[email-masked]>
Date: Thu, 26 Mar 2015 14:36:16 -0500

Two questions on the draft.

In section 3.1.7 on tunnels there is a reference to circuit breaker in 
bullet #3.
It is intentional that circuit breaker is not mentioned in bullet #2? 
(which is about payload that isn't congestion controller).

The UDP tunnels I know that carry non-congestion controlled traffic also 
carry congestion-controlled traffic.
Would it be useful to include that level of detail? Basically the tunnel 
would carry a mixture of bullet #1 and bullet #2 traffic.
In such a case the different type of traffic can be treated differently 
by the tunneling mechanism.
AFAICT that wouldn't cause any issues, but I don't think it is obvious 
from the text in the section that such a flexibility exists.
One could argue that one could have two difference instances of the 
tunnel or sub-tunnels for the two types of traffic and bullet #1 and #2 
would apply to those separately.

Thoughts?
    Erik

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 26 Mar 2015 14:43:05 -0500

Thanks Erik,

We will look into this, and mention mixed traffic in the text.

Gorry

> On 26 Mar 2015, at 14:36, Erik Nordmark <[email-masked]> wrote:
> 
> In section 3.1.7 on tunnels there is a reference to circuit breaker in bullet #3.
> It is intentional that circuit breaker is not mentioned in bullet #2? (which is about payload that isn't congestion controller).
> 
> The UDP tunnels I know that carry non-congestion controlled traffic also carry congestion-controlled traffic.
> Would it be useful to include that level of detail? Basically the tunnel would carry a mixture of bullet #1 and bullet #2 traffic.
> In such a case the different type of traffic can be treated differently by the tunneling mechanism.
> AFAICT that wouldn't cause any issues, but I don't think it is obvious from the text in the section that such a flexibility exists.
> One could argue that one could have two difference instances of the tunnel or sub-tunnels for the two types of traffic and bullet #1 and #2 would apply to those separately.