Subject: [tsvwg] New draft: draft-khademi-alternativebackoff-ecn-00.txt

From: [email-masked]
Date: Tue, 30 Jun 2015 16:48:39 +0100

A group of us have been working together to get better than current ECN
using a simple sender side change (this is not intended to compete with
work on Accurate ECN) and only the existing router ECN marking.

Please see the draft below, and do send comments and questions to this
list. In particular we'd like to know if others have interest in this work
being presented to the TSV WG.

Gorry
(just an individual author)

> Begin forwarded message:
>
> Resent-From: <[email-masked]>
> From: <[email-masked]>
> To: Michael Welzl <[email-masked]>, Grenville Armitage
<[email-masked]>, Michael Welzl <[email-masked]>, Gorry
Fairhurst <[email-masked]>, Naeem Khademi <[email-masked]>,
Godred Fairhurst <[email-masked]>, Grenville Armitage
<[email-masked]>, "Naeem Khademi" <[email-masked]>
> Subject: New Version Notification for
draft-khademi-alternativebackoff-ecn-00.txt
> Date: 30. juni 2015 kl. 16.08.27 CEST
>
>
> A new version of I-D, draft-khademi-alternativebackoff-ecn-00.txt
> has been successfully submitted by Michael Welzl and posted to the
> IETF repository.
>
> Name:		draft-khademi-alternativebackoff-ecn
> Revision:	00
> Title:		TCP Alternative Backoff with ECN (ABE)
> Document date:	2015-06-30
> Group:		Individual Submission
> Pages:		6
> URL:           
https://www.ietf.org/internet-drafts/draft-khademi-alternativebackoff-ecn-00.txt
> Status:        
https://datatracker.ietf.org/doc/draft-khademi-alternativebackoff-ecn/
> Htmlized:      
https://tools.ietf.org/html/draft-khademi-alternativebackoff-ecn-00
>
>
> Abstract:
>   This memo updates the TCP sender-side reaction to a congestion
>   notification received via Explicit Congestion Notification (ECN).
>   The updated method is less conservative than the TCP reaction in
>   response to loss.  The intention is to achieve good throughput when
>   the queue at the bottleneck is smaller than the bandwidth-delay-
>   product of the connection.  This is more likely when an Active Queue
>   Management (AQM) mechanism has ECN-marked a packet than when a packet
>   was lost.  Future versions of this document will discuss SCTP as well
>   as other transports using ECN.
>
>
>
>
> Please note that it may take a couple of minutes from the time of
submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 1 Jul 2015 06:56:29 +0000

How does this interact with DCTCP?