Subject: Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update

From: Lloyd Wood <[email-masked]>
Date: Mon, 30 Nov 2015 01:08:32 +0000 (UTC)

blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important;  padding-left:1ex !important; background-color:white !important; }  sigh. _directly_ over physical without intervening layers.

Lloyd Wood [email-masked]

On Monday, November 30, 2015, 11:38, Greg Shepherd <[email-masked]> wrote:

Sent from my iPhone
On Nov 29, 2015, at 15:47, <[email-masked]> <[email-masked]> wrote:

As an analogy, that doesn't work well.In practice, that won't work well either.

Bridging frames via e.g. PWE3 rather messes things up.

The Eth frame is tunnelled over part of its path,so doesn't need a checksum by your thinking, because it'snot just above physical layer. Until it's bridged, andit is.

But tunnelling thinking is that reliability is a payloadproblem, so that underlying checksums can be turned offfor performance. Leading to no checksums throughout thestack at any scope.

While collapsing the stack suggests that you should onlyneed error checks just above physical errors and as anend-to-end guarantee, with nothing needed inbetween, ina complex heterogenous world where you can't be sureyou're running over physical

In what world will we not be running over physical?
Greg

and can't trust thereliability of other devices, error insertion andcorrection is never that simple.

 Lloyd Wood [email-masked] http://about.me/lloydwood 
     From: Joe Touch <[email-masked]>
 To: [email-masked] 
Cc: Tom Herbert <[email-masked]>; Tsvwg IETF List <[email-masked]>
 Sent: Sunday, 29 November 2015, 13:22
 Subject: Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update

On Nov 28, 2015, at 6:19 PM, <[email-masked]> <[email-masked]> wrote:

Joe,
> When UDP is used as a tunnel, it isn't an E2E transport anymore - it's a
> link layer for some other protocol (e.g., the tunneled packet).

That would make UDP without checksum a link layer without checksumsfor the protocols it carries.

Correct. 

Ethernet is a link layer.Are you advocating that we turn off Ethernet checksums as well?

If it is not the first layer above physical, yes. Otherwise, no. 

Joe

 Lloyd Wood [email-masked] http://about.me/lloydwood 
     From: Joe Touch <[email-masked]>
 To: [email-masked] 
Cc: [email-masked]; Tom Herbert <[email-masked]>; Tsvwg IETF List <[email-masked]>
 Sent: Saturday, 28 November 2015, 17:28
 Subject: Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update

On 11/27/2015 10:14 PM, [email-masked] wrote:
> "That's exactly why IPv6 requires UDP checksums."
> 
> 
> RFC6935 is standards track. It changes IPv6. IPv6 no longer
> requires UDP checksums.
> RFC7510 is standards track. It changes IPv6. IPv6 no longer
> requires UDP checksums.
> 
> Stop saying something absolute that is no longer true. 

IPv6 requires E2E transport checksums.

When UDP is used as a tunnel, it isn't an E2E transport anymore - it's a
link layer for some other protocol (e.g., the tunneled packet).

None of this is inconsistent with the original intent of how IPv6 was
designed.

> I expect
> these 'special cases' to be extended so that the
> UDP checksum requirement is relaxed further. In each case,
> the document will be written from the perspective and needs
> of the special case, rather than from the perspective of
> the Internet as a whole, and host and port pollution from
> misdelivered zero-checksum packets will eventually be recognised
> as problem side-effects.

You should consider that both of these special cases have something in
common - that what is used as a "transport" is really just a tunnel
encapsulation protocol, not an E2E transport for a user application.

Will we see more of those? Yes.

Will we see cases where UDP checksums can be ditched for true E2E apps?
I doubt it.

> IPv6 designers thought an end-to-end check was so important
> they... thought they could leave it up to transport designers.
> That's not working well.

It's actually working out exactly as it was intended.

> Do distinguish between a hop-by-hop header check over
> mutable and non-mutable fields (IPv4) and an end-to-end pseudo-
> header check of non-mutable fields...
> 
> 
> UDP Lite can offer benefits for tunnel headers not checked in
> payload checks, e.g. endtoend checking of MPLS stacks that
> the tunnelled payloads don't check. The demultiplexing
> check it provides matters, and complements a payload that
> checks itself - not just a raw errored stream of bits.

UDPlite goes back to IPv4-style protection of network headers. Unless we
think that the L2-above-physical or (true)E2E layers aren't doing the
job IPv6 expects, we (still) won't be needing it for tunnels.

Joe

---

From: Greg Shepherd <[email-masked]>
Date: Sun, 29 Nov 2015 17:46:43 -0800

sigh - why is 'directly' relevant?

On Sun, Nov 29, 2015 at 5:08 PM, Lloyd Wood <[email-masked]> wrote:

> sigh. _directly_ over physical without intervening layers.
>
>
> As an analogy, that doesn't work well.
> In practice, that won't work well either.
>
>
> The Eth frame is tunnelled over part of its path,
> so doesn't need a checksum by your thinking, because it's
> not just above physical layer. Until it's bridged, and
> it is.
>
>
> But tunnelling thinking is that reliability is a payload
> problem, so that underlying checksums can be turned off
> for performance. Leading to no checksums throughout the
> stack at any scope.
>
>
> While collapsing the stack suggests that you should only
> need error checks just above physical errors and as an
> end-to-end guarantee, with nothing needed inbetween, in
> a complex heterogenous world where you can't be sure
> you're running over physical
>
>
> and can't trust the
> reliability of other devices, error insertion and
> correction is never that simple.
>
>
>
> ------------------------------
> *From:* Joe Touch <[email-masked]>
> *To:* [email-masked]
> *Cc:* Tom Herbert <[email-masked]>; Tsvwg IETF List <[email-masked]>
> *Sent:* Sunday, 29 November 2015, 13:22
> *Subject:* Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update
>
>
>
> Ethernet is a link layer.
> Are you advocating that we turn off Ethernet checksums as well?
>
>
> ------------------------------
> *From:* Joe Touch <[email-masked]>
> *To:* [email-masked]
> *Cc:* [email-masked]; Tom Herbert <[email-masked]>; Tsvwg IETF List <
> [email-masked]>
> *Sent:* Saturday, 28 November 2015, 17:28
> *Subject:* Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update
>
>
>

---

From: <[email-masked]>
Date: Mon, 30 Nov 2015 02:24:16 +0000 (UTC)

Because Joe brought up 'not the first layer above physical'.

which is to say, layers that are not directly above physical suddenly gettreated differently to layers that aren't in terms of needing checksums.

Which I think is bogus, so I'm just pointing out the holes in that argument.

L.

are you spending as much time reading on your iPhone as you do writing on it?

Lloyd Wood [email-masked] http://about.me/lloydwood 
      From: Greg Shepherd <[email-masked]>
 To: Lloyd Wood <[email-masked]> 
Cc: Joe Touch <[email-masked]>; Tsvwg IETF List <[email-masked]>
 Sent: Monday, 30 November 2015, 12:46
 Subject: Re: [tsvwg] UDP guidelines draft (5405bis) -07 - update

Sent from my iPhone

Joe,

Correct. 

Joe

Joe