Subject: [tsvwg] [Technical Errata Reported] RFC3390 (4569)

From: RFC Errata System <[email-masked]>
Date: Tue, 22 Dec 2015 02:18:25 -0800 (PST)

The following errata report has been submitted for RFC3390,
"Increasing TCP's Initial Window".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3390&eid=4569

--------------------------------------
Type: Technical
Reported by: Nikolai Malykh <[email-masked]>

Section: 8.1

Original Text
-------------
   A second set of experiments explored TCP performance over dialup
   modem links.  In experiments over a 28.8 bps dialup channel [All97a,
   AHO98], a four-segment initial window decreased the transfer time of
   a 16KB file by roughly 10%, with no accompanying increase in the drop
   rate.  A simulation study [RFC2416] investigated the effects of using
   a larger initial window on a host connected by a slow modem link and
   a router with a 3 packet buffer.  The study concluded that for the
   scenario investigated, the use of larger initial windows was not
   harmful to TCP performance.

Corrected Text
--------------
   A second set of experiments explored TCP performance over dialup
   modem links.  In experiments over a 28.8 Kbps dialup channel [All97a,
   AHO98], a four-segment initial window decreased the transfer time of
   a 16KB file by roughly 10%, with no accompanying increase in the drop
   rate.  A simulation study [RFC2416] investigated the effects of using
   a larger initial window on a host connected by a slow modem link and
   a router with a 3 packet buffer.  The study concluded that for the
   scenario investigated, the use of larger initial windows was not
   harmful to TCP performance.

Notes
-----
Error bit rate - bps instead of Kbps.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3390 (draft-ietf-tsvwg-initwin-04)
--------------------------------------
Title               : Increasing TCP's Initial Window
Publication Date    : October 2002
Author(s)           : M. Allman, S. Floyd, C. Partridge
Category            : PROPOSED STANDARD
Source              : Transport Area Working Group
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: <[email-masked]>
Date: Wed, 23 Dec 2015 00:17:56 +0000 (UTC)

Should actually be lower case k kbps (for 1000, not 1024 or Kibps.)

Lloyd Wood
 [email-masked]
 http://about.me/lloydwood 

--------------------------------------------
On Tue, 22/12/15, RFC Errata System <[email-masked]> wrote:

 Subject: [tsvwg] [Technical Errata Reported] RFC3390 (4569)
 To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
 Cc: [email-masked], [email-masked], [email-masked]
 Date: Tuesday, 22 December, 2015, 21:18
 
 The following errata report has been
 submitted for RFC3390,
 "Increasing TCP's Initial Window".

 
 Section: 8.1
 
 Original Text
 -------------
    A second set of experiments explored TCP
 performance over dialup
    modem links.  In experiments over a
 28.8 bps dialup channel [All97a,
    AHO98], a four-segment initial window
 decreased the transfer time of
    a 16KB file by roughly 10%, with no
 accompanying increase in the drop
    rate.  A simulation study [RFC2416]
 investigated the effects of using
    a larger initial window on a host
 connected by a slow modem link and
    a router with a 3 packet buffer.  The
 study concluded that for the
    scenario investigated, the use of larger
 initial windows was not
    harmful to TCP performance.
 
 Corrected Text
 --------------
    A second set of experiments explored TCP
 performance over dialup
    modem links.  In experiments over a
 28.8 Kbps dialup channel [All97a,
    AHO98], a four-segment initial window
 decreased the transfer time of
    a 16KB file by roughly 10%, with no
 accompanying increase in the drop
    rate.  A simulation study [RFC2416]
 investigated the effects of using
    a larger initial window on a host
 connected by a slow modem link and
    a router with a 3 packet buffer.  The
 study concluded that for the
    scenario investigated, the use of larger
 initial windows was not
    harmful to TCP performance.
 
 Notes
 -----
 
 Instructions:
 -------------
 This erratum is currently posted as "Reported". If
 necessary, please
 use "Reply All" to discuss whether it should be verified or
 rejected. When a decision is reached, the verifying party
 (IESG)
 can log in to change the status and edit the report, if
 necessary. 
 
 --------------------------------------
 RFC3390 (draft-ietf-tsvwg-initwin-04)
 --------------------------------------
 Title           
    : Increasing TCP's Initial Window
 Publication Date    : October 2002
 Author(s)           : M.
 Allman, S. Floyd, C. Partridge
 Category            : PROPOSED
 STANDARD
 Source              :
 Transport Area Working Group
 Area               
 : Transport
 Stream              :
 IETF
 Verifying Party     : IESG