Subject: Re: [tsvwg] Comments on draft-szigeti-tsvwg-ieee-802-11

From: Cullen Jennings <[email-masked]>
Date: Tue, 12 Jul 2016 12:05:26 -0400

Just wanted to say that all my concerns have been resolve in latest version of this draft. Thank you Tim.

---

From: "Tim Szigeti (szigeti)" <[email-masked]>
Date: Mon, 18 Jul 2016 21:49:13 +0000

Thank you Cullen.

Also - to follow-up on a request from David, I'm summarizing your comments made to the group and their corresponding resolutions.

Cheers!

-tim

---

Comment: "We should consider CS5 mapping to same things as EF (6) but should map to at least 5 so that it is not less than the video flows."-C. Jennings (7/7/15 & 5/4/16)

Resolution: Changed Signaling (CS5) mapping to UP 5 in Sections 4.2.2 and 4.3
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-00#section-4.2.2 

---

Comment: "The practical use of AF4 vs CS4 for video phone calls has always been confusing.  Over the past 4 years we have spent a huge amount of time getting the direction to be AF4. If this spec put CS4 above AF4, that would be a cause multiple manufactures to re-examine all of that and likely move to CS4 completely resetting the work we have done on this. The one thing I feel really strongly about is CS4 can't map higher than AF4. This draft will be downright harmful if it continues to map CS4 above AF4." -C. Jennings (7/7/15 & 5/4/16)

Resolution: All video classes (including Multimedia-Conferencing, Real-Time Interactive, Multimedia-Streaming and Broadcast Video) are now being mapped to the same UP value (UP 4) and thus admitted to the same Video Access Category (AC_VI), with no distinction in servicing between them.
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-00#section-10.2   
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-00#section-4.2.6 

---

Comment: "CS3 is particularly tricking. The thing that is tricky about it is it got labeled Broadcast video.  On unmanaged networks running default configurations, it is very unlikely to be broadcast video and is much more likely to be surveillance video. This is probably best mapped to 3 with configuration that allows it to be mapped to 4 instead. Of course there are networks where the surveillance traffic is more important than everything else (same as broadcast video) but if the consumer WIFI camera puts in wireless traffic at UP 5, users will not be happy." -C. Jennings (7/7/15 & 5/4/16)

Resolution: All video classes (including Multimedia-Conferencing, Real-Time Interactive, Multimedia-Streaming and Broadcast Video) are now being mapped to the same UP value (UP 4) and thus admitted to the same Video Access Category (AC_VI), with no distinction in servicing between them.
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-00#section-10.2    
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-00#section-4.2.6 

---

Comment: "In the actual use of interactive video, some bits are far more important than others and we want to be able to indicate this inside the AF4 class so some should map to 4 and some should map to 5. I would suggest  something like AF41 and AF42 map to 5 and AF43  map to 4." -C. Jennings (7/7/15 & 5/4/16)

Resolution: No change in draft, as this is a potential DiffServ PHB Violation. Specifically, such treatment could result in out-of-order packets; however the Assured Forwarding PHB (RFC 2597) clearly defines that "A DS node does not reorder IP packets of the same microflow if they belong to the same AF class." Since this recommendation would conflict with this intent expressed in RFC 2597, then it cannot be introduced in this draft (which has as its stated purpose the reconciliation of existing IETF and IEEE QoS standards, and not any new interpretation or modification of these standards).