Subject: [tsvwg] Enhanced ECN support in 5G

From: Ingemar Johansson S <[email-masked]>
Date: Sun, 7 May 2017 09:52:16 +0000

Hi
To whom it may concern.
The submission below is posted to 3GPP RAN2. The intention is to add support for timely and efficient ECN marking in NR (5G) . This will make it easier to eventually implement support for L4S in 5G.

http://www.3gpp.org/ftp/TSG_RAN/WG2_RL2/TSGR2_98/Docs/R2-1704368.zip

Regards
Ingemar

==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

A mistake is to commit a misunderstanding
                     Bob Dylan
==================================

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 10 May 2017 16:00:12 +0100

Ingemar, [repeating and adding to my reply to your posting on iccrg, cos 
I overlooked your identical message to tsvwg]

Thanks for this. The proposal to do ECN-marking at the RLC layer is 
important. It will need to consider incremental deployment though, cos 
there will be loads of user equipment for some years that don't contain 
any logic to understand ECN at the RLC layer. Incremental ECN deployment 
at L2 has been solved in various ways. Probably the neatest is how it is 
being done in TRILL (draft-ietf-trill-ecn-support) (see 
ecn-encap-guidelines for pointers to other approaches).

I've sent you a marked up corrected copy offlist, cos the ECN deployment 
statements are misleading.
* Apple's ECN deployment is primarily on Ethernet and Wifi (50% on 
latest OSs, 5% on previous).
* On mobile-connected devices, Apple enables ECN solely for 3 carriers: 
T-Mobile, Three, Telstra
    See video of conference: Networking for the Modern Internet 
<https://developer.apple.com/videos/play/wwdc2016/714/> (video requires 
Safari, or you can look it up in the iOS WWDC app 
<https://itunes.apple.com/us/app/wwdc/id640199958?mt=8>).

Cheers

Bob

On 07/05/17 10:52, Ingemar Johansson S wrote:
>
> Hi
>
> To whom it may concern.
>
> The submission below is posted to 3GPP RAN2. The intention is to add 
> support for timely and efficient ECN marking in NR (5G) . This will 
> make it easier to eventually implement support for L4S in 5G.
>
> [email-masked] <mailto:[email-masked]>
>
> www.ericsson.com
>

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 12 May 2017 13:05:33 +0000

Hi

Yes, I hope that it will be possible to land this, we will know more by the end of next week.
And thanks for the clarifications around Apple´s ECN deployment.

/Ingemar

From: Bob Briscoe [mailto:[email-masked]]
Sent: den 10 maj 2017 17:00
To: Ingemar Johansson S <[email-masked]>
Cc: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]>; tsvwg IETF list <[email-masked]>; Black, David ([email-masked]) <[email-masked]>
Subject: Re: Enhanced ECN support in 5G

Ingemar, [repeating and adding to my reply to your posting on iccrg, cos I overlooked your identical message to tsvwg]

Thanks for this. The proposal to do ECN-marking at the RLC layer is important. It will need to consider incremental deployment though, cos there will be loads of user equipment for some years that don't contain any logic to understand ECN at the RLC layer. Incremental ECN deployment at L2 has been solved in various ways. Probably the neatest is how it is being done in TRILL (draft-ietf-trill-ecn-support) (see ecn-encap-guidelines for pointers to other approaches).

I've sent you a marked up corrected copy offlist, cos the ECN deployment statements are misleading.
* Apple's ECN deployment is primarily on Ethernet and Wifi (50% on latest OSs, 5% on previous).
* On mobile-connected devices, Apple enables ECN solely for 3 carriers: T-Mobile, Three, Telstra
   See video of conference: Networking for the Modern Internet<https://developer.apple.com/videos/play/wwdc2016/714/> (video requires Safari, or you can look it up in the iOS WWDC app<https://itunes.apple.com/us/app/wwdc/id640199958?mt=8>).

Cheers

Bob

Regards
Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289

--

---

From: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>
Date: Fri, 12 May 2017 13:34:26 +0000

Hi Ingemar, all,

Just a thought - we've presented before on the opportunity for end-to-end congestion controls to account for the highly-volatile radio access link. With ECN marking proposed at the RLC, does this create that opportunity? i.e. include the current radio conditions as a factor in the 'when to mark' L4S algorithm.

'Volatility' could be gleaned from the same logic used to determine the Reception buffering, or possibly from the UE's Channel Quality Indicators that are reported to the MAC scheduler.

What do you reckon?

All best,
Kevin

From: tsvwg [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: 12 May 2017 14:06
To: Bob Briscoe <[email-masked]>
Cc: Black, David ([email-masked]) <[email-masked]>; tsvwg IETF list <[email-masked]>
Subject: Re: [tsvwg] Enhanced ECN support in 5G

Hi

/Ingemar

From: Bob Briscoe [mailto:[email-masked]]
Sent: den 10 maj 2017 17:00
To: Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>
Cc: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; tsvwg IETF list <[email-masked]<mailto:[email-masked]>>; Black, David ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: Enhanced ECN support in 5G

Cheers

Bob

Regards
Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289

--

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 12 May 2017 18:52:31 +0000

Hi

Yes, the potentially very varying throughput characteristics of 5G makes L4S technology very attractive. Initial experiments have shown that L4S can track fast changing throughput very well, I have so far only mustered with some initial experiments but they are very promising, others may have better results to show.

How to do the actual L4S ECN marking is implemented (in 5G) is likely subject to research work and  may be proprietary implementation details, I am not sure that a standards text will go into details around ECN marking, in some form it resembles scheduling and link adaptation algorithms, which are both proprietary.

The important part standards wise as I see it is to enable that the ECN marking is carried efficiently. The proposed 3GPP contribution enables this for 5G-NR so that it is possible to ECN mark packets on the RLC layers.

Regards
/Ingemar

From: Smith, Kevin, (R&D) Vodafone Group [mailto:[email-masked]]
Sent: den 12 maj 2017 15:34
To: Ingemar Johansson S <[email-masked]>; Bob Briscoe <[email-masked]>
Cc: Black, David ([email-masked]) <[email-masked]>; tsvwg IETF list <[email-masked]>
Subject: RE: Enhanced ECN support in 5G

Hi Ingemar, all,

What do you reckon?

All best,
Kevin

From: tsvwg [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: 12 May 2017 14:06
To: Bob Briscoe <[email-masked]<mailto:[email-masked]>>
Cc: Black, David ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; tsvwg IETF list <[email-masked]<mailto:[email-masked]>>
Subject: Re: [tsvwg] Enhanced ECN support in 5G

Hi

/Ingemar

Cheers

Bob

Regards
Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289

--