Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-ieee-802-11-04.txt

From: [email-masked]
Date: Mon, 03 Jul 2017 14:53:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group of the IETF.

        Title           : Diffserv to IEEE 802.11 Mapping
        Authors         : Tim Szigeti
                          Jerome Henry
                          Fred Baker
	Filename        : draft-ietf-tsvwg-ieee-802-11-04.txt
	Pages           : 34
	Date            : 2017-07-03

Abstract:
   As internet traffic is increasingly sourced-from and destined-to
   wireless endpoints, it is crucial that Quality of Service be aligned
   between wired and wireless networks; however, this is not always the
   case by default.  This document specifies a set Differentiated
   Services Code Point (DSCP) to IEEE 802.11 User Priority (UP) mappings
   to reconcile the marking recommendations offered by the IETF and the
   IEEE so as to maintain consistent QoS treatment between wired and
   IEEE 802.11 wireless networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-ieee-802-11/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-tsvwg-ieee-802-11-04
https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-ieee-802-11-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-ieee-802-11-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Tim Szigeti (szigeti)" <[email-masked]>
Date: Mon, 3 Jul 2017 22:13:14 +0000

What's new/changed:

- all recommendations to drop codepoints have been completely removed
- all recommendations to remark codepoints have been completely removed, with the sole exception of recommending wireless client operating systems to remark packets requesting CS6 or CS7 marking values to be remarked to DSCP 0 (as CS6/CS7 marking values are intended solely for network control protocols, and such, these should not be sourced from wireless client endpoint devices)--Section 5.1 & 8.2
- a single mapping recommendation is presented for all wireless deployments (Section 4.3); however, some additional security recommendations are offered for Wifi-at-the-edge deployment models, including mapping all codepoints not-in-use to UP 0 (but again, no dropping nor DSCP-remarking)--Section 8.2

Additionally, all other recommendations, additions and nits from previous reviews have been incorporated.

Thanks for the reviews and guidance. Looking forward to moving this forward in Prague.

-tim

> -----Original Message-----
> From: tsvwg [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Monday, July 03, 2017 2:54 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-ieee-802-11-04.txt
> 
>

---

From: "Tim Szigeti (szigeti)" <[email-masked]>
Date: Mon, 3 Jul 2017 22:17:50 +0000

What's new/changed:

-tim

-----Original Message-----
From: tsvwg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 03, 2017 2:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-ieee-802-11-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.