Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-rlc-fec-scheme-00.txt

From: [email-masked]
Date: Mon, 17 Jul 2017 06:34:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Area Working Group of the IETF.

        Title           : Sliding Window Random Linear Code (RLC) Forward Erasure Correction (FEC) Scheme for FECFRAME
        Author          : Vincent Roca
	Filename        : draft-ietf-tsvwg-rlc-fec-scheme-00.txt
	Pages           : 23
	Date            : 2017-07-17

Abstract:
   This document describes a fully-specified FEC scheme for the Sliding
   Window Random Linear Codes (RLC) over GF(2^^m), where m equals 1
   (binary case), 4 or 8, that can be used to protect arbitrary media
   streams along the lines defined by FECFRAME extended to sliding
   window codes.  These sliding window FEC codes rely on an encoding
   window that slides over the source symbols, generating new repair
   symbols whenever needed.  Compared to block FEC codes, these sliding
   window FEC codes offer key advantages with real-time flows in terms
   of reduced FEC-related latency while often providing improved erasure
   recovery capabilities.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-tsvwg-rlc-fec-scheme-00
https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rlc-fec-scheme-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Xiaomeng Shi <[email-masked]>
Date: Wed, 19 Jul 2017 18:54:03 +0000

Dear Vincent and all,

Thank you very much for the great effort.  This is my first post to the group, and I hope my message has come at an appropriate time during the pipeline.  I work with Code On Technologies in Cambridge, MA, where our focus is in the application of random linear network codes in different layers of the network stack to achieve performance improvements when possible.

We are delighted to see that the sliding window approach has become a working group item and we are in full support of the initiative.  To this extent, we thought it might be of interest to the group to see some past research work in this area, either from us, or that we are aware of.  Below is a quick list, and we look forward to future discussions within tsvwg.

1) Network Coding Overview, IETF 86, 2013, Code On Technologies, https://www.ietf.org/proceedings/86/slides/slides-86-nwcrg-5.pdf.
2) T. Ho, et al., "A random linear network coding approach to multicast," IEEE Transactions on Information Theory, vol. 52, no. 10, pp. 4413-4430, 2006.
3) JK, Sundararajan et al., "Network coding meets TCP," INFOCOM 2009, IEEE. IEEE, 2009.
4) M. Kim et al., "Modeling network coded TCP throughput: A simple model and its validation," Proceedings of the 5th International ICST Conference on Performance Evaluation Methodologies and Tools. ICST (Institute for Computer Sciences, Social-Informatics and Telecommunications Engineering), 2011.
5) S. Wunderlich et al., We don't need no generation-a practical approach to sliding window RLNC. In Wireless Days, 2017 (pp. 218-223). IEEE.

Best regards,
Shirley Shi

On Jul 17, 2017, at 9:34 AM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

---

From: "Black, David" <[email-masked]>
Date: Mon, 24 Jul 2017 00:39:52 +0000

Shirley,

Thank you for your interest, and the timing is fine.  The background information is useful - beyond that, if you and/or your colleagues are interested in reviewing this draft (and the supporting framework extension draft,
draft-ietf-tsvwg-fecframe-ext-00.txt), comments would be welcome at any time.  In particular, there's no need to wait for Working Group Last Call to send comments to the list.

Thanks, --David

From: tsvwg [mailto:[email-masked]] On Behalf Of Xiaomeng Shi
Sent: Wednesday, July 19, 2017 2:54 PM
To: [email-masked]
Subject: Re: [tsvwg] I-D Action: draft-ietf-tsvwg-rlc-fec-scheme-00.txt

Dear Vincent and all,

Best regards,
Shirley Shi

Abstract:

---

From: Xiaomeng Shi <[email-masked]>
Date: Thu, 27 Jul 2017 17:08:01 +0000

Dear David,

Thank you for the note!  I will relay the message to my colleagues as well.

Best,
Shirley

On Jul 23, 2017, at 8:39 PM, Black, David <[email-masked]<mailto:[email-masked]>> wrote:

Shirley,

Thank you for your interest, and the timing is fine.  The background information is useful – beyond that, if you and/or your colleagues are interested in reviewing this draft (and the supporting framework extension draft,
draft-ietf-tsvwg-fecframe-ext-00.txt), comments would be welcome at any time.  In particular, there’s no need to wait for Working Group Last Call to send comments to the list.

Thanks, --David

From: tsvwg [mailto:[email-masked]] On Behalf Of Xiaomeng Shi
Sent: Wednesday, July 19, 2017 2:54 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [tsvwg] I-D Action: draft-ietf-tsvwg-rlc-fec-scheme-00.txt

Dear Vincent and all,

Best regards,
Shirley Shi

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

---

From: Vincent Roca <[email-masked]>
Date: Fri, 28 Jul 2017 09:20:15 +0200

Dear Shirley,

Thanks a lot for your interest and support. Yes, we’ll need reviewers and you are more than welcome.
This I-D on sliding window FEC codes focusses on a specific application/use-case, but we can also regard
it as the first concrete initiative for using such codes in IETF standards. 

The NWCRG remains the main place where discuss research topics related to sliding window codes, and
several directions / design teams have already been identified during last week IETF’99 meeting. Do not
hesitate to have a look at the NWCRG meeting minutes:
https://www.ietf.org/proceedings/99/minutes/minutes-99-nwcrg-00.txt <https://www.ietf.org/proceedings/99/minutes/minutes-99-nwcrg-00.txt>

Best regards,

  Vincent

> Le 27 juil. 2017 à 19:08, Xiaomeng Shi <[email-masked]> a écrit :
> 
> Dear David,
> 
>> On Jul 23, 2017, at 8:39 PM, Black, David <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Shirley, <>
>>  
>> From: tsvwg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Xiaomeng Shi
>> To: [email-masked] <mailto:[email-masked]>
>> 1) Network Coding Overview, IETF 86, 2013, Code On Technologies, https://www.ietf.org/proceedings/86/slides/slides-86-nwcrg-5.pdf <https://www.ietf.org/proceedings/86/slides/slides-86-nwcrg-5.pdf>.
>> On Jul 17, 2017, at 9:34 AM, [email-masked] <mailto:[email-masked]> wrote:
>>  
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/ <https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rlc-fec-scheme/>
>> 
>> https://tools.ietf.org/html/draft-ietf-tsvwg-rlc-fec-scheme-00 <https://tools.ietf.org/html/draft-ietf-tsvwg-rlc-fec-scheme-00>
>> https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rlc-fec-scheme-00 <https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rlc-fec-scheme-00>
>> 
>> 
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>

---

From: Xiaomeng Shi <[email-masked]>
Date: Tue, 1 Aug 2017 02:15:58 +0000

Dear Vincent,

Thank you for the pointer!  Again, I will relay the information to my colleagues as well, and come back to you with questions if any.

Best regards,
Shirley

> On Jul 28, 2017, at 3:20 AM, Vincent Roca <[email-masked]> wrote:
> 
> Dear Shirley,
> 
> https://www.ietf.org/proceedings/99/minutes/minutes-99-nwcrg-00.txt
> 
> Best regards,
> 
>   Vincent
>  
> 
>>> On Jul 23, 2017, at 8:39 PM, Black, David <[email-masked]> wrote:
>>> 
>>> Shirley,
>>>  
>>> On Jul 17, 2017, at 9:34 AM, [email-masked] wrote:
>>>  
>>>