Subject: Re: [tsvwg] WGLC on ecn-encap-guidelines

From: Magnus Westerlund <[email-masked]>
Date: Tue, 11 Sep 2018 13:19:54 +0200

Hi,

I have reviewed ecn-encap-guidelines and have the following two comments:

1. Section 1:

    Therefore, the capitalised term 'SHOULD' or 'SHOULD NOT' are often
    used in preference to 'MUST' or 'MUST NOT', because it is difficult
    to know the compromises that will be necessary in each protocol
    design.  If a particular protocol design chooses to contradict a
    'SHOULD (NOT)' given in the advice below, it MUST include a sound
    justification.

So the meaning of the capatilized words are later defined by reference in Section 2.
However, that is after this text. Maybe a reference in this context?

2. Section 5.4:

    2.  If the outer header does not support explicit congestion
        notification (a Not-ECN-PDU), but the inner header does (an ECN-
        PDU), the inner header SHOULD be forwarded unchanged.

So this is an example of one of these cases where SHOULD is chosen as it might
be needed if there is a good reason and thus this bullet doesn't use MUST forward
the inner header unchanged? Asking as I don't quite see a reason why the egress
should change the inner header?

Otherwise I think the document is in good shape and ready to be published.

Cheers

Magnus

Den 2018-08-08 kl. 06:11, skrev Black, David:
>
> This email announces a TSVWG Working Group Last Call (WGLC) on two 
> drafts:
>
> [1] Guidelines for Adding Congestion Notification to Protocols that
>
>                              Encapsulate IP
>
> draft-ietf-tsvwg-ecn-encap-guidelines-10
>
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-ecn-encap-guidelines/
>
> This draft is intended to become a Best Current Practice RFC
>
> [2] Propagating Explicit Congestion Notification Across IP Tunnel Headers
>
>                           Separated by a Shim
>
> draft-ietf-tsvwg-rfc6040update-shim-06
>
> This draft is intended to become a Proposed Standard RFC.
>
> This WGLC will run through the end of the day on Friday, September 7.
>
> This WGLC is longer than usual to allow for WG members taking vacation
>
> in August.
>
> Comments should be sent to the [email-masked] <mailto:[email-masked]> 
> list, although purely
>
> editorial comments may be sent directly to the author. Please cc: the
>
> WG chairs at [email-masked] <mailto:[email-masked]> if 
> you would like the chairs to
>
> track such editorial comments as part of the WGLC process.
>
> No IPR disclosures have been submitted directly on either draft
>
> Thanks,
>
> David, Gorry and Wes
>
> (TSVWG Co-Chairs)
>

-- 

Magnus Westerlund

----------------------------------------------------------------------
Network Architecture & Protocols, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Black, David" <[email-masked]>
Date: Wed, 26 Sep 2018 20:40:38 +0000

Hmm - I've only seen WGLC review comments from one person on one of these two drafts (thank you, Magnus).  I'm part of this situation as I was not able to review these drafts, despite my best intentions :-(.

That does not suffice for WGLC review.  At or before the Bangkok meeting, I think we (WG chairs) are going to need to find some committed reviewers for these two drafts and run another WGLC on them.

Suggestions for alternative courses of action are welcome and encouraged.

Thanks, --David

From: tsvwg [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, August 8, 2018 12:12 AM
To: [email-masked]
Subject: [tsvwg] WGLC on ecn-encap-guidelines and rfc6040-update-shim drafts, closes 7 September 2018

This email announces a TSVWG Working Group Last Call (WGLC) on two drafts:

                             Encapsulate IP

                          Separated by a Shim

in August.

Comments should be sent to the [email-masked]<mailto:[email-masked]> list, although purely

WG chairs at [email-masked]<mailto:[email-masked]>  if you would like the chairs to

Thanks,

David, Gorry and Wes

(TSVWG Co-Chairs)