Subject: [tsvwg] MISSREF*R(1G) document in C238 has been overtaken by draft in IESG Evaluation - what now? :-)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 Feb 2019 14:59:07 -0600

Dear Heather,

The IESG has https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/ in
IESG Evaluation for this week's telechat, and this draft
updates draft-ietf-tsvwg-rtcweb-qos, which I'm sure you recognize because
it's in Cluster C238, and has been hanging in the RFC Editor queue for some
number of years.

We THINK we don't want to have draft-ietf-tsvwg-rtcweb-qos published as an
RFC and immediately have another RFC published that updates it - right?

We THINK the instructions in
https://tools.ietf.org/html/draft-ietf-tsvwg-le-phb-09#section-12 describe
the changes to draft-ietf-tsvwg-rtcweb-qos clearly.

What is the proper way for the IESG to tell the RFC Editor to go ahead and
make the changes to draft-ietf-tsvwg-rtcweb-qos?

Our guesses include, but are not limited to,

   - Adding an RFC Editor Note to draft-ietf-tsvwg-le-phb (the draft with
   instructions about updating draft-ietf-tsvwg-rtcweb-qos)
   - Adding an RFC Editor Note to draft-ietf-tsvwg-rtcweb-qos (the draft to
   be updated)
   - Sending an e-mail to the RFC Editor requesting that the text changes
   be applied to draft-ietf-tsvwg-rtcweb-qos before it is published

but I bet that you know what will make live easiest for you and the RFC
editor staff ... please let me know.

Thanks,

Spencer

Spencer

---

From: Heather Flanagan <[email-masked]>
Date: Wed, 20 Feb 2019 13:49:18 -0800

Hi Spencer,

I know it’s rude to answer a question with a question… but I have a few questions.

Draft-ietf-tsvwg-le-phb is not in our queue yet, right? Will it become part of C238 when it is in our queue? 

When the text in draft-ietf-tsvwg-rtcweb-qos is changed, will that text then be removed from draft-ietf-tsvwg-le-phb? 

Will there still be any kind of Updates relationship between draft-ietf-tsvwg-le-phb and draft-ietf-tsvwg-rtcweb-qos when this change is made?

If draft-ietf-tsvwg-le-phb is not in our queue and will not be part of C238, then I think an RFC Editor Note would be very useful for that draft. If we haven’t started editing draft-ietf-tsvwg-rtcweb-qos, then an RFC Editor Note there would be useful to. I defer to Sandy, though, as to what the editors will find most useful to make sure this change is captured during the editing process.

Thanks,
Heather

> On Feb 20, 2019, at 12:59 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Dear Heather,
> 
> The IESG has https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/ <https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/> in IESG Evaluation for this week's telechat, and this draft updates draft-ietf-tsvwg-rtcweb-qos, which I'm sure you recognize because it's in Cluster C238, and has been hanging in the RFC Editor queue for some number of years. 
> 
> We THINK we don't want to have draft-ietf-tsvwg-rtcweb-qos published as an RFC and immediately have another RFC published that updates it - right?
> 
> We THINK the instructions in https://tools.ietf.org/html/draft-ietf-tsvwg-le-phb-09#section-12 <https://tools.ietf.org/html/draft-ietf-tsvwg-le-phb-09#section-12> describe the changes to draft-ietf-tsvwg-rtcweb-qos clearly.
> 
> What is the proper way for the IESG to tell the RFC Editor to go ahead and make the changes to draft-ietf-tsvwg-rtcweb-qos? 
> 
> Adding an RFC Editor Note to draft-ietf-tsvwg-le-phb (the draft with instructions about updating draft-ietf-tsvwg-rtcweb-qos)
> Adding an RFC Editor Note to draft-ietf-tsvwg-rtcweb-qos (the draft to be updated)
> Sending an e-mail to the RFC Editor requesting that the text changes be applied to draft-ietf-tsvwg-rtcweb-qos before it is published
> but I bet that you know what will make live easiest for you and the RFC editor staff ... please let me know.
> 
> Thanks,
> 
> Spencer
> 
> Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 Feb 2019 16:09:11 -0600

Hi, Heather,

> part of C238 when it is in our queue?

draft-ietf-tsvwg-le-phb is on the telechat agenda for tomorrow.

I believe the only connection with draft-ietf-tsvwg-rtcweb-qos are the
instructions in Section 12 - so if those instructions are carried out by
the RFC Editor, draft-ietf-tsvwg-le-phb shouldn't need to be part of C238.

>
> When the text in draft-ietf-tsvwg-rtcweb-qos is changed, will that text
> then be removed from draft-ietf-tsvwg-le-phb?
>

That would make sense to me.

> Will there still be any kind of Updates relationship between
> draft-ietf-tsvwg-le-phb and draft-ietf-tsvwg-rtcweb-qos when this change is
> made?
>

I don't believe so. The theory I'm using is that TSVWG is changing the text
of a draft that hasn't been issued as an RFC yet (with instructions in
another draft that will be removed), so no kind of Updates relationship
would exist - there won't be any text in draft-ietf-tsvwg-le-phb that
updates draft-ietf-tsvwg-rtcweb-qos.

>
> If draft-ietf-tsvwg-le-phb is not in our queue and will not be part of
> C238, then I think an RFC Editor Note would be very useful for that draft.
> If we haven’t started editing draft-ietf-tsvwg-rtcweb-qos, then an RFC
> Editor Note there would be useful to. I defer to Sandy, though, as to what
> the editors will find most useful to make sure this change is captured
> during the editing process.
>

Hi, Sandy :-)

I can add the RFC Editor Note to draft-ietf-tsvwg-le-phb. Could you let me
know if I should also add an RFC Editor note to draft-ietf-tsvwg-rtcweb-qos?

Thanks!

Spencer

Thanks,
> https://tools.ietf.org/html/draft-ietf-tsvwg-le-phb-09#section-12
> describe the changes to draft-ietf-tsvwg-rtcweb-qos clearly.
>
>    - Adding an RFC Editor Note to draft-ietf-tsvwg-rtcweb-qos (the draft
>    to be updated)

---

From: "Black, David" <[email-masked]>
Date: Wed, 20 Feb 2019 22:20:28 +0000

One small addition on the relationship between the two drafts …

Thanks, --David

From: tsvwg <[email-masked]> On Behalf Of Spencer Dawkins at IETF
Sent: Wednesday, February 20, 2019 5:09 PM
To: Heather Flanagan
Cc: Sandy Ginoza; [email-masked]; IESG; tsvwg-chairs
Subject: Re: [tsvwg] MISSREF*R(1G) document in C238 has been overtaken by draft in IESG Evaluation - what now? :-)

[EXTERNAL EMAIL]
Hi, Heather,

On Wed, Feb 20, 2019 at 3:49 PM Heather Flanagan <[email-masked]<mailto:[email-masked]>> wrote:
Hi Spencer,

I believe the only connection with draft-ietf-tsvwg-rtcweb-qos are the instructions in Section 12 - so if those instructions are carried out by the RFC Editor, draft-ietf-tsvwg-le-phb shouldn't need to be part of C238.
[David>] In addition. draft-ietf-tsvwg-rtcweb-qos will acquire a normative reference to draft-ietf-tsvwg-le-phb as a result of these edits.  Fortunately, that will *not* make draft-ietf-tsvwg-le-phb part of C238.

I don't believe so. The theory I'm using is that TSVWG is changing the text of a draft that hasn't been issued as an RFC yet (with instructions in another draft that will be removed), so no kind of Updates relationship would exist - there won't be any text in draft-ietf-tsvwg-le-phb that updates draft-ietf-tsvwg-rtcweb-qos.

If draft-ietf-tsvwg-le-phb is not in our queue and will not be part of C238, then I think an RFC Editor Note would be very useful for that draft. If we haven’t started editing draft-ietf-tsvwg-rtcweb-qos, then an RFC Editor Note there would be useful to. I defer to Sandy, though, as to what the editors will find most useful to make sure this change is captured during the editing process..

Hi, Sandy :-)

I can add the RFC Editor Note to draft-ietf-tsvwg-le-phb. Could you let me know if I should also add an RFC Editor note to draft-ietf-tsvwg-rtcweb-qos?

Thanks!

Spencer

Thanks,
Heather

On Feb 20, 2019, at 12:59 PM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:

Dear Heather,

The IESG has https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/ in IESG Evaluation for this week's telechat, and this draft updates draft-ietf-tsvwg-rtcweb-qos, which I'm sure you recognize because it's in Cluster C238, and has been hanging in the RFC Editor queue for some number of years.

We THINK the instructions in https://tools.ietf.org/html/draft-ietf-tsvwg-le-phb-09#section-12 describe the changes to draft-ietf-tsvwg-rtcweb-qos clearly.

  *   Adding an RFC Editor Note to draft-ietf-tsvwg-le-phb (the draft with instructions about updating draft-ietf-tsvwg-rtcweb-qos)
  *   Adding an RFC Editor Note to draft-ietf-tsvwg-rtcweb-qos (the draft to be updated)
  *   Sending an e-mail to the RFC Editor requesting that the text changes be applied to draft-ietf-tsvwg-rtcweb-qos before it is published
but I bet that you know what will make live easiest for you and the RFC editor staff ... please let me know.

Thanks,

Spencer

Spencer

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 20 Feb 2019 14:40:28 -0800

Hi all,

In this case, sending email to the RFC Editor or adding an RFC Editor note both work for us.  In the note or email for draft-ietf-tsvwg-rtcweb-qos, please also include the addition of a normative reference to draft-ietf-tsvwg-le-phb that David mentioned.

Is it correct that you want the updates from Section 12 draft-ietf-tsvwg-le-phb to be included in draft-ietf-tsvwg-rtcweb-qos and that Section 12 of draft-ietf-tsvwg-le-phb should be removed from the document?  If that’s the case, I think having an additional RFC Editor note in draft-ietf-tsvwg-le-phb asking us to remove Section 12 would be helpful.  

Does this work?

Thanks,
Sandy

> On Feb 20, 2019, at 2:09 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Heather, 
> 
> On Wed, Feb 20, 2019 at 3:49 PM Heather Flanagan <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Spencer,
> 

>> On Feb 20, 2019, at 12:59 PM, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear Heather,
>>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 Feb 2019 15:45:39 -0800

Hi, Sandy,

On Wed, Feb 20, 2019, 14:40 Sandy Ginoza <[email-masked] wrote:

> Hi all,
>
> In this case, sending email to the RFC Editor or adding an RFC Editor note
> both work for us.  In the note or email for draft-ietf-tsvwg-rtcweb-qos,
> please also include the addition of a normative reference to
> draft-ietf-tsvwg-le-phb that David mentioned.
>
> Is it correct that you want the updates from Section 12
> draft-ietf-tsvwg-le-phb to be included in draft-ietf-tsvwg-rtcweb-qos and
> that Section 12 of draft-ietf-tsvwg-le-phb should be removed from the
> document?  If that’s the case, I think having an additional RFC Editor note
> in draft-ietf-tsvwg-le-phb asking us to remove Section 12 would be helpful.
>
>

That is the case.

I'll include all these details in the RFC Editor Note in
draft-ietf-tsvwg-le-phb.

And thank you for your help!

Spencer

Does this work?
> [David>] In addition. draft-ietf-tsvwg-rtcweb-qos will acquire a normative
> reference to draft-ietf-tsvwg-le-phb as a result of these edits.
> Fortunately, that will **not** make draft-ietf-tsvwg-le-phb part of C238.
>
>
>
>
> I don't believe so. The theory I'm using is that TSVWG is changing the
> text of a draft that hasn't been issued as an RFC yet (with instructions in
>> The IESG has https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/
>> in IESG Evaluation for this week's telechat, and this draft
>> We THINK we don't want to have draft-ietf-tsvwg-rtcweb-qos published as
>> an RFC and immediately have another RFC published that updates it - right?
>>
>> What is the proper way for the IESG to tell the RFC Editor to go ahead
>> and make the changes to draft-ietf-tsvwg-rtcweb-qos?
>>
>>    - Adding an RFC Editor Note to draft-ietf-tsvwg-le-phb (the draft
>>    with instructions about updating draft-ietf-tsvwg-rtcweb-qos)
>>    - Sending an e-mail to the RFC Editor requesting that the text
>>    changes be applied to draft-ietf-tsvwg-rtcweb-qos before it is published
>>