Subject: [tsvwg] Fwd: New Version Notification for draft-roca-tsvwg-tinymt32-00.txt

From: Vincent Roca <[email-masked]>
Date: Mon, 11 Feb 2019 12:34:04 +0100

Dear Spencer, Mirja, Wes, David, all,

In accordance with previous discussions, we:

- removed TinyMT32 source code from the draft-ietf-tsvwg-rlc-fec-scheme I-D
  to move it to an I-D of its own that is now a normative dependence
  (we also fixed a few typos identified by Greg Skinner in -12 version, thanks).

- submitted the new draft-roca-tsvwg-tinymt32-00 individual I-D that focusses on
  the core PRNG specification and mostly contains the C-language specification
  under the IETF Trust copyright and licence. It is co-authored with M. Saito and
  M. Matsumoto that we warmly thank for the constructive discussions we add.

We think we thereby addressed all comments received so far by IESG.

Cheers,

  Vincent, on behalf of the authors.

> De: [email-masked]
> Objet: New Version Notification for draft-roca-tsvwg-tinymt32-00.txt
> Date: 11 février 2019 à 11:03:00 UTC+1
> À: "Makoto Matsumoto" <[email-masked]>, "Vincent Roca" <[email-masked]>, "Emmanuel Baccelli" <[email-masked]>, "Emmanuel Baccelli" <[email-masked]>, "Mutsuo Saito" <[email-masked]>
> 
> 
> A new version of I-D, draft-roca-tsvwg-tinymt32-00.txt
> has been successfully submitted by Vincent Roca and posted to the
> IETF repository.
> 
> Name:		draft-roca-tsvwg-tinymt32
> Revision:	00
> Title:		TinyMT32 Pseudo Random Number Generator (PRNG)
> Document date:	2019-02-11
> Group:		Individual Submission
> Pages:		10
> URL:            https://www.ietf.org/internet-drafts/draft-roca-tsvwg-tinymt32-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-roca-tsvwg-tinymt32/
> Htmlized:       https://tools.ietf.org/html/draft-roca-tsvwg-tinymt32-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-roca-tsvwg-tinymt32
> 
> 
> Abstract:
>   This document describes the TinyMT32 Pseudo Random Number Generator
>   (PRNG) that produces 32-bit pseudo-random unsigned integers and aims
>   at having a simple-to-use and deterministic solution.  This PRNG is a
>   small-sized variant of Mersenne Twister (MT) PRNG, also designed by
>   M.  Saito and M.  Matsumoto.  The main advantage of TinyMT32 over MT
>   is the use of a small internal state, compatible with most target
>   platforms including embedded devices, while keeping a reasonably good
>   randomness.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 11 Feb 2019 10:13:09 -0600

Hi, Vincent,

I'll ask Wes/shepherd and the other TSVWG chairs to confirm that this draft
(and the new draft with the PRNG) are ready to move forward.

Thanks for chasing this down. I know it wasn't easy!

Spencer

On Mon, Feb 11, 2019 at 5:34 AM Vincent Roca <[email-masked]> wrote:

> *De: [email-masked]
> *Objet: **New Version Notification for draft-roca-tsvwg-tinymt32-00.txt*
> *Date: *11 février 2019 à 11:03:00 UTC+1
> *À: *"Makoto Matsumoto" <[email-masked]>, "Vincent
> Roca" <[email-masked]>, "Emmanuel Baccelli" <
> [email-masked]>, "Emmanuel Baccelli" <
> [email-masked]>, "Mutsuo Saito" <
> [email-masked]>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-roca-tsvwg-tinymt32-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-roca-tsvwg-tinymt32/
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-roca-tsvwg-tinymt32
>
>
> Abstract:

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 18 Feb 2019 12:36:20 +0100

Hi Vincent,

this addresses for sure the licensing issue. I’m ready to clear my discuss but I’m wondering if the document (draft-ietf-tsvwg-rlc-fec-scheme) now needs another WG and/or IETF last call. David/Spencer?

Also there are still two discusses by Ekr and Benjamin. The document (draft-ietf-tsvwg-rlc-fec-scheme) can’t move forward without having all discusses cleared, so you need to follow up with them as well.

Thanks!
Mirja

> Am 11.02.2019 um 12:34 schrieb Vincent Roca <[email-masked]>:
>