Subject: Re: [tsvwg] travel funds for ietf for the next SCE talk?

From: Dave Taht <[email-masked]>
Date: Fri, 10 May 2019 11:17:11 +0200

On Mon, Apr 29, 2019 at 5:32 PM Magnus Westerlund
<[email-masked]> wrote:
>
> Hi Dave,
>
> Thanks for bring this work to the IETF. Yes, I would also like to encourage you to discuss your proposal in TSVWG using the mailing list and eventually present this work at the next TSVWG meeting. However, there is not required to participate in-person. We frequently have remote presentations and from my experience that works well. I’m sure the TSVWG chairs can further advise you on this.

This is one of those replies that I had to sit on for a while because
it was so mind-boggling.

If you haven't noticed a few hundred messages about reforming the ietf
on the IETF mailing list to allow remote participants to have *a vote*
in how the ietf operates, you might want to review those.

A remote presentation is not enough to get a vote in how the ietf operates.

Remote participation on the mailing lists, in this case, was certainly
not enough. Externally it looked like the l4s/dualpi/tcpprague effort
was spiraling down the drain with a pesky FRAND patent, no integrated,
running code, and 4 as-yet unresolved theoretical problems weighing it
down.

But... it really did feel like matters were being settled in smoky
back rooms when this set of drafts, pitched to the IETF as a (rather
dubious) experiment, when it came out (hours after we submitted our
SCE draft) that cablelabs had announced their new standard (no doubt
expecting a rubber stamp from the ietf) a few weeks prior, and had,
indeed, been working in secret for 16 months to take over the "last
half bit" of the ECN header for their own use.

Radically enough, I do tend to think that the open source community
does need MUCH better *representation* within the ietf, and to
leverage Thomas Paine's writings, there should be "no standardization
without representation", particularly in cases where the code has to
be universally deployed. This requires actual IETF attendance, by the
coders or their representatives, at least presently.

Unlike all the other conferences we attend, speakers are not
recompensed for their costs in the IETF, either.

I still doubt that our new competing, backwards compatible alternate
proposal, will get any pull in various smoky backrooms, but being
there in person, giving a preso, and wandering the hallways still
seems to help. Especially... when the ideas and their implications are
so difficult to express to people outside the narrow field of
congestion control in the first place, and don't fit easily into an
RFC format without useful code, repeatable benchmarks, public
experiments and graphs as guides.

> Cheers
>
> Magnus Westerlund
>
>
>
> On 2019-04-28 15:54, Dave Taht wrote:
> > Several members of the open source "bufferbloat.net" group do
> > regularly participate in ietf mailing lists and remote meetings, but
> > it is rare that any of us
> > can actually afford to attend IETF. In fact, we've had no travel
> > budget for 3 years running. I'd mostly reduced my involvement to BABEL
> > after the AQM wg closed, and that remotely only.
> >
> > This past IETF, we had to hold a bake sale on the bloat mailing list
> > as well as melt all my credit cards in order to get our new SCE "Some
> > Congestion Experienced" AQM concept in front of the tsvwg and iccrg
> > working groups in contrast to the cablelabs dualpi proposal.
> >
> > (if anyone cares, the TSVWG talk and slides are here:
> > https://www.youtube.com/watch?v=JQmWyr0JDJM&t=1h3m50s ) -
> >
> > The controversy in the open source community, covered here:
> > https://lwn.net/Articles/783673/
> >
> > We've been *very strongly encouraged* to present again at the upcoming
> > ietf in montreal, but I'm now in no position to sponsor the 2-3 core
> > people again that need to present the follow-on results in the 5 or so
> > related wgs. Is there an org, a fund, a means, a way, to get a bunch
> > of rather poor, but innovative, open source devs and theorist, out
> > there, that we can apply to? raise the ~9k needed? isoc? Something?
> >
> > (and if it were possible i'd rather like to have what I had had to
> > spend back, so I can pour it into recreating a network testbed for
> > this work. I'm not planning to attend, myself. The one trip alone
> > wiped out ecn-sane's budget for the year)
> >
>
> --
>
> Magnus Westerlund
>
> ----------------------------------------------------------------------
> Network Architecture & Protocols, Ericsson Research
> ----------------------------------------------------------------------
> Ericsson AB                 | Phone  +46 10 7148287
> Torshamnsgatan 23           | Mobile +46 73 0949079
> SE-164 80 Stockholm, Sweden | mailto: [email-masked]
> ----------------------------------------------------------------------
>

-- 

Dave Täht
CTO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-831-205-9740

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 10 May 2019 11:35:29 +0000

Hi Dave,

Please see inline.

> in how the ietf operates, you might want to review those.

I have noticed that discussion. Process changes are hard, and the one
thing I am certain over is that we need to have an open discussion about
what changes should happen to facilitate remote only participants to
have nomcom eligibility, right to sign recall petitions etc. Remote
participants are most definitely not on equal footing on that part. If
you think the IESG is obstructionist in this discussion, then it comes
from the position that if we would simply jump on something without
ensuring consensus on things we equally would be called bad things. We
can facilitate the discussion and ensure that it is given room. For
example a virtual BOF for these topics do make sense.

> A remote presentation is not enough to get a vote in how the ietf operates.

However, when it comes to be able to influence the technical work in a
WG a remote participant do have a fair chance. The one to one
discussions that happens in the hallways are hard to cover. That
requires spending a lot of time trying to reach out to people between
the meeting for those conversations. 

> running code, and 4 as-yet unresolved theoretical problems weighing it

I don't know what your expectations where here from what I would
consider a rather limited engagement you have had so far on the TSVWG
mailing list. I don't share the same view of L4S, although I would have
hoped for more rapid progress and more available running code.

> half bit" of the ECN header for their own use.

I have no insight into what has happened in CableLabs. However, it
fairly obvious from mailing list traffic and presentations that
Cablelabs had an interest in L4S. What I know is that we have discussed
L4S for a significant time in IETF. There was a BOF at IETF 96 which
resulted in the inclusion of the work in TSVWG. The framework for the
experiment was discussed, documented and approved in RFC 8311. Yes, the
specification of L4S as being developed have made slow progress, but it
has been making progress.

> coders or their representatives, at least presently.

I definitely like more participation from people implementing the
protocols in the IETF and Open Source contributors are important part of
that. Certain things can most definitely be done on the mailing list and
interacting with authors and being an author of proposals, even if not
present. There are challenges of not being present at meetings when
topics becomes controversial. Building a contact network is also more
challenging when not present at the meetings.

> recompensed for their costs in the IETF, either.

IETF is not a conference. We don't have speakers, we have participants
that drives proposals. I do not know of any standardization forum where
participants get reimbursed for contributing to the specifications.

> experiments and graphs as guides.

Yes, it is an alternative proposal. Where both SCE and L4S desires to
use the same half-bit of the ECN codepoint space. That is what makes
this topic really hard as it appears difficult to run the solutions in
parallel, at least outside of specific DSCPs, and thus especially for
the Best Effort class.

Your proposal has its challenges in respect to providing a clear
specification of what SCE are and provide that supportive material that
would sway people that your proposal are a better one.  To my
understanding the TSVWG chairs have been encouraging a constructive
discussion on the matter.

It might be that to reach maximum efficiency from your perspective on
this matter you need to have representatives attend the upcoming meeting
in person. Remote participant is an option as the previous email pointed
out and will have some impact. However, I hope you see that there are a
significant fairness issue for IETF as organization to provide monetary
support to some participants and implicitly their proposals. I wish you
luck in finding financial support, however I would kindly request that
you don't use IETF's mailing lists for such requests.

Cheers

Magnus Westerlund 
(as TSV AD responsible for TSVWG)

---

From: Dave Taht <[email-masked]>
Date: Fri, 10 May 2019 14:01:39 +0200

> you think the IESG is obstructionist in this discussion, then it comes

I don't consider the IESG to be an entity with one mind.

> example a virtual BOF for these topics do make sense.

Reform from within moves slowly.

> mailing list.

Most of my interactions pre-date that work, on the aqm mailing list,
that we closed in part, because it seemed the aqm work had moved to
maintenence mode. We were off creating and shipping code, in qty (10s)
of millions, based on the accepted standards. Things had got stable
enough after releasing sch_cake to start considering an rfc8290bis
with what we'd learned from shipping all that code, in real products,
particularly on wifi, and to take a harder look at ecn, in general.

> I don't share the same view of L4S, although I would have

It was the total lack of any integrated useful code from the L4S
people, the dodgy benchmarks, lack of third party verification of the
benchmarks, and the long-nagging issues never resolved on the IETF AQM
mailing list that kicked off the ecn-sane design group (
https://www.bufferbloat.net/projects/ecn-sane/wiki/ ) and its charter
last august. SCE is just the first of several outputs of that project.
There are several other projects going on in various states of
completion which we'll bring to the ietf once the code is in a usuable
state, or the papers gone through peer review.

> that.

And I would like more representation. I've largely stayed out of those
threads, because, really, I vastly prefer to just do the technical
stuff. I hope that progress is made.

>Certain things can most definitely be done on the mailing list and

Yes.
> participants get reimbursed for contributing to the specifications.

To clarify, I should not have said recompense. Elsewhere, speakers are
usually not charged conference fees when speaking. Their other costs
they eat.

> discussion on the matter.

Yes, but 'round here, it's running code first, specs later. Usually.

> you don't use IETF's mailing lists for such requests.

My request here was informational. We got offers of airmiles from two
ietfers, and that's a help. We're pursuing other sources of travel
funds.

There will be no further financial requests by us here, and this ends
this thread, as far as I'm concerned.

-- 

Dave Täht
CTO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-831-205-9740

---

From: Joe Touch <[email-masked]>
Date: Fri, 10 May 2019 06:47:06 -0700

Although this is a side issue....

> On May 10, 2019, at 2:17 AM, Dave Taht <[email-masked]> wrote:
> 

Speakers at conferences are not compensated. They register like everyone else - that has been ACM, IEEE, IFiP, and OSA policy - I know because in some cases, I *wrote* the policy. Students are typically required to register at the full rate if they present. In the majority of cases, even the chairs pay their own way or at best are comp’d registration.

Speakers at trade shows are paid, as are some (but not all) keynotes and tutorial presenters.  The latter often get only honoraria and a comp’d reg, not enough for travel/lodging in most cases.

The only  people who get a fully free ride that I know of are the IEEE Comsoc Board. 

Joe

---

From: Ted Lemon <[email-masked]>
Date: Fri, 10 May 2019 10:00:00 -0400

> The only  people who get a fully free ride that I know of are the IEEE Comsoc Board. 

Hm.  I’ve never paid to attend IETF.  Granted, this is not because IETF comped me, but because I was fortunate enough to have an employer who could afford to send me at no cost to me.

This model unfortunately doesn’t work for open source developers who are not on the payroll of a company with deep pockets.

---

From: Joe Touch <[email-masked]>
Date: Fri, 10 May 2019 07:12:24 -0700

> On May 10, 2019, at 7:00 AM, Ted Lemon <[email-masked]> wrote:
> 
> On May 10, 2019, at 9:47 AM, Joe Touch <[email-masked] <mailto:[email-masked]>> wrote:

Nor academics. I stopped coming because I couldn’t find a gov’t agency interested in supporting my participation either (and my current employer doesn’t either).

This is a problem not only for general attendance but also for the IESG - which impacts some decisions being made as well.

Joe

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 10 May 2019 07:23:53 -0700

On Fri, May 10, 2019 at 6:47 AM Joe Touch <[email-masked]> wrote:

> Speakers at conferences are not compensated. They register like everyone
> else - that has been ACM, IEEE, IFiP, and OSA policy - I know because in
> some cases, I *wrote* the policy. Students are typically required to
> register at the full rate if they present. In the majority of cases, even
> the chairs pay their own way or at best are comp’d registration.
>

It actually varies. I have been comped where I was asked to give an Invited
Talk.

That said, the IETF is very different from an academic conference, and i
think it would clearly be impractical for the IETF to comp registration for
everyone who presented.

-Ekr

>
> Speakers at trade shows are paid, as are some (but not all) keynotes and
> tutorial presenters.  The latter often get only honoraria and a comp’d reg,
> not enough for travel/lodging in most cases.
>

---

From: Tom Herbert <[email-masked]>
Date: Fri, 10 May 2019 08:10:57 -0700

On Fri, May 10, 2019, 7:00 AM Ted Lemon <[email-masked]> wrote:

> Hm.  I’ve never paid to attend IETF.  Granted, this is not because IETF
> comped me, but because I was fortunate enough to have an employer who could
> afford to send me at no cost to me.
>

Ted,

I have paid to attend IETF. It is expensive. In fact, for Prague IETF
registration alone plus VAT cost twice as much as the airfare to get there
from US! I was only able to justify the trip only because we ran Netdev
conference at the same location a week before.

>
> This model unfortunately doesn’t work for open source developers who are
> not on the payroll of a company with deep pockets.
>

Yes, and I hope this is considered a bad thing lest IETF becomes an elitist
organization with only a handful of bigger players running the show.

Maybe there should be a "non-sponsored" registration tier with a discount
to help make it affordable for the little guys.

Tom

---

From: Ted Lemon <[email-masked]>
Date: Fri, 10 May 2019 11:53:10 -0400

On May 10, 2019, at 11:10 AM, Tom Herbert <[email-masked]> wrote:
> Maybe there should be a "non-sponsored" registration tier with a discount to help make it affordable for the little guys.

The problem is figuring out a sustainability model for IETF that doesn’t rely on attendance fees and hotel stays.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 May 2019 08:33:54 +1200

On 11-May-19 02:12, Joe Touch wrote:
> 
> 
>> On May 10, 2019, at 7:00 AM, Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
>>

Of course. But none of this is new and the world is a hard place. I missed one of the vital meetings of the IPng Directorate in 1994, the meeting that was the last chance for a major change of direction for what would become IPv6, because my then employer (CERN) had limited travel funds. I've always regretted missing that meeting. Too bad for me.

On 11-May-19 06:19, Keith Moore wrote:

> On 5/10/19 11:53 AM, Ted Lemon wrote:
> 
>> On May 10, 2019, at 11:10 AM, Tom Herbert <[email-masked] <mailto:[email-masked]>> wrote:
> And this has been a problem since the early 1990s when the US government stopped subsidizing the meetings (and perhaps also the secretariat?).   But I wish we'd try harder to find that sustainability model rather than constantly punting the problem, because the Internet has been suffering for all that time from a lack of diverse participation in IETF.

I don't see how the IETF is supposed to fix the fact that independent open source developers are, um, independent. There is no money tree. And if you change the model such that funded attendees are subsidising unfunded attendees in significant numbers, guess what? The number of funded attendees will rapidly decline. It seems to me that the current focus on improving remote attendance facilities is really the best we can do, but again: if remote attendance really becomes as good as on-site attendance, the number of funded atttendees will rapidly decline.

I think that if there was a viable answer to this problem, we'd already have found it.

    Brian

---

From: "Rodney W. Grimes" <[email-masked]>
Date: Sat, 11 May 2019 10:24:32 -0700 (PDT)

> >>> The only ?people who get a fully free ride that I know of are the IEEE Comsoc Board.?
> >>
> >> Hm. ?I?ve never paid to attend IETF. ?Granted, this is not because IETF comped me, but because I was fortunate enough to have an employer who could afford to send me at no cost to me.
> >>
> >> This model unfortunately doesn?t work for open source developers who are not on the payroll of a company with deep pockets.
> > 
> > Nor academics. I stopped coming because I couldn?t find a gov?t agency interested in supporting my participation either (and my current employer doesn?t either).
> > 

Since the ietf is in the standards business, and making good standards means making good decisions, and making good decisions requires being informed, it seems this exclusionary nature of a large critical mass of "smart people" with valid inputs is self defeating.

> >> The problem is figuring out a sustainability model for IETF that doesn?t rely on attendance fees and hotel stays.
> > 
> > 

I concur.  This problem *must* be solved, but until it comes onto the table as an official problem it well continue to be un-resolvd.

> I don't see how the IETF is supposed to fix the fact that independent open source developers are, um, independent. There is no money tree. And if you change the model such that funded attendees are…

One path forward is to try to lower the cost of the conference through other means.

> I think that if there was a viable answer to this problem, we'd already have found it.

You can only find things that you look for, from reading this thread
it sounds as if there are people who would like this problem solved,
but they are not empowered to solve it, and those that are empowered
to solve it are not looking for a solution.

This is the endless complaint, no action taken cycle.

Now that I have responded to the prior comments, rather than just rant, try to offer some positive possible impacts.

A)  Lower cost to attend.  I saw at least one person mention cost of conference exceeding the air-fair, I am going to assume that was an international flight.  The Ietf by having its meetings around the globe has infact done some mitigation on this, though it is expensive to attend all meetings, some are usually within reach of many.  However the Hotel choice due to size needs is often expensive.  I could suggest what I have seen in smaller conferences to help offer a lower cost housign solution, team up with universities, especially over the summer months, many of them have empty dormatories that are available for very low cost.  I shall be at an Ottawa, Canada conference next week and my total housing cost based on a shared 2 bd room doorm suite is $250 USD for 5 nights!.

B)  Create an independent travel grant program, and/or solicite entities that already have a travel grant program that would consider the IETF an appropriate to their needs use of that grant.  List these programs on a "need helping attending IETF" web site.

C)  Continue to improve the remote attendance program, try to bring it on par with actual attendance.  We are in the era of remote "work from home, work anyplace on the planet" businesses, this technology is become more and more common place, the IETF *should* commit resources to this.

-- 
Rod Grimes                                                 [email-masked]

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 12 May 2019 15:27:00 -0700

> On May 10, 2019, at 07:00, Ted Lemon <[email-masked]> wrote:
> 

That's an odd definition of having never paid.  At the point of registration, you either provided a credit card or requested an invoice. The nominal cost of your involvement in the IETF borne on the part of you or your employer(s) is no doubt considerable, especially during your term on the IESG when the time commitment was also considerable..  

For most  of the 4 years I spent on the IESG I paid the costs of attending out of my own pocket. I did that, because it was what i signed up for, because it needed to get done and because I believed there was value in the work being done in the operations and management area.  Back as an individual contributor I come when I have something to do and some way to pay for it otherwise I wouldn't be there.

joel

---

From: Ted Lemon <[email-masked]>
Date: Sun, 12 May 2019 19:02:05 -0400

This is the precise distinction I was making. I didn’t pay. Someone paid, but not me. It’s amazing that you were willing to make it work out of pocket, but that’s just not scalable. 

Sent from my iPhone

> On May 12, 2019, at 6:27 PM, Joel Jaeggli <[email-masked]> wrote:
> 
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 May 2019 15:11:47 +1200

> Since the ietf is in the standards business, and making good standards means making good decisions, and making good decisions requires being informed, it seems this exclusionary nature of a large c…

We've moved forward considerably since 1994, when the remote participation facility was extremely weak (remember the MBONE?), conference calls were all over clunky POTs equipment, etc. But what we haven't done is changed the 4-monthly meeting calendar, which is our principal tool for causing work to advance. Nor have we changed the rule that consensus decisions must be based on mailing list discussion. That included the decision to charter IPv6, and the decision to charter homenet, and and every decision to advance the resulting standards track documents.

I'm not suggesting that everything should stay as it is; far from it. But even if the results are not always as we'd like them, we do have an existing remote participation model where, in theory, your voice is worth exactly the same as mine.

Let me give you an example. I'm co-author of a certain draft in a certain WG. At the last IETF, there was a short in-person discussion and the consensus in the room was to advance the draft to the IESG. The WG chair then sent a message to the WG list to confirm this. I can't give you an exact count of the number of subsequent messages on that thread, but it exceeds 150. I have no idea of the final outcome, but the fate of this document will be decided by remote participants.
 
> One path forward is to try to lower the cost of the conference through other means.

It's a _meeting_ not a conference, and the semantics matter. Even though we have sponsors, it's a not a conference with primary marketing or educational value. As others have commented, we're also constrained to venues with large enough facilities and nearby airports. So both squeezing out cost and obtaining additional sponsorship are challenging.

> This is the endless complaint, no action taken cycle.

Not really. We've recently reformatted our admin, with one of the goals being more professional and focused fund-raising. We've also done a lot of work on criteria for venue selection. We've done a lot to improve remote participation, which is now largely viable, with relatively rare glitches.

What we haven't done is change our basic 4-monthly cycle, as noted above.

   Brian