Subject: [tsvwg] IPR Declarations on draft-ietf-tsvwg-aqm-dualq-coupled

From: "De Schepper, Koen (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 10 Jun 2019 23:47:12 +0000

Dear Chairs,

After careful consideration, Nokia has decided to change two IPR Statements made by Alcatel Lucent in 2015 (#2679) and in 2017 (#2952):

These two IPR Statements provided assurance that Alcatel Lucent, which is now part of Nokia, would ensure access to its disclosed patented technology - relating to the DualQ technology included as part of the proposed L4S architecture - on  fair, reasonable and non-discriminatory terms and conditions.   This is the normal basis on which both Nokia and Alcatel Lucent have and continue to contribute their patented technologies both to IETF and other standard development bodies.

The DualQ feature and our patented technology is an integral part of the proposed L4S architecture, which we believe is necessary to enable a truly low latency Internet.  It is therefore important to both us and the industry at large that this architecture is recognised and adopted by IETF, and that the ECT(1) codepoint header in the Internet Protocol is assigned to enable L4S.

To this end and recognising its importance, Nokia wishes to inform you that Alcatel Lucent has submitted changes to the IPR Statements made in 2015 and 2017, as regards the two patent families it still owns/controls, to provide assurance that we will not assert our patents against users of our patented DualQ technology who fully implement draft-ietf-tsvwg-aqm-dualq-coupled.  As regards the remaining patent family no longer owned/controlled by Nokia or Alcatel Lucent, we understand that this is directed to an optional and not recommended part of the IETF draft.

We hope that this gesture and change of IPR Statements will help alleviate any concerns regarding our previous Statements and the use of the ECT(1) codepoint header in the Internet Protocol to enable L4S.

Kind regards,
Koen.

---

From: Lars Eggert <[email-masked]>
Date: Wed, 12 Jun 2019 08:43:57 +0300

Hi Koen,

thank you (and Nokia/Alcatel-Lucent) for providing a rationale and context for this (IMO positive) change.

I wish more companies would post similar messages when they post or change IPR claims.

Thanks,
Lars

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 12 Jun 2019 23:46:29 +0100

Yes, Thank you Koen for all the work I'm sure you must have had to put 
in to making this happen. We can now focus solely on technical matters.

Bob

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Greg White <[email-masked]>
Date: Thu, 13 Jun 2019 15:46:34 +0000

+1  

Thanks Koen, this is a very positive development that eliminates a concern that some had expressed relative to the DualQ draft.

-Greg

On 6/12/19, 4:46 PM, "tsvwg on behalf of Bob Briscoe" <[email-masked] on behalf of [email-masked]> wrote:

    Bob

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Thu, 20 Jun 2019 08:04:39 -0400

Hi Koen

> To this end and recognising its importance, Nokia wishes to inform you
> that Alcatel Lucent has submitted changes to the IPR Statements made
> in 2015 and 2017, as regards the two patent families it still
> owns/controls, to provide assurance that we will not assert our
> patents against users of our patented DualQ technology who fully
> implement draft-ietf-tsvwg-aqm-dualq-coupled. As regards the remaining
> patent family no longer owned/controlled by Nokia or Alcatel Lucent,
> we understand that this is directed to an optional and not recommended
> part of the IETF draft.
>
> We hope that this gesture and change of IPR Statements will help
> alleviate any concerns regarding our previous Statements and the use
> of the ECT(1) codepoint header in the Internet Protocol to enable L4S.

I was delighted to hear this. However, looking at the new disclosures,
they do not alleviate the concerns. Quoting from
https://datatracker.ietf.org/ipr/3562/ :

> "Reciprocity" includes retaining the right to assert the Disclosed
> Patents against any entity, and its Affiliates, that asserts any
> patent(s) that it owns or controls (directly or indirectly) either
> against the Covenantor, or any of its Affiliates or any successor in
> title to them, or against any products, or portions thereof, of the
> Covenantor, its Affiliates or supplied by the Covenantor, or its
> Affiliates, to their customers either alone or in combination with
> other products.

This termination clause is a non-starter. This clause is triggered by
*any* assertion of *any* patent against the patent holder. This means
that if dualq becomes an internet standard that is incorporated into
vital infrastructure, this will in practice prevent others from
defending themselves against any patent assertions made by the patent
holder, unless they wish to be subject to additional litigation over the
patent covered by the IPR statement. Which is a level of leverage I
don't think the IETF should be helping *anyone* obtain.

-Toke

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 21 Jun 2019 22:00:32 +0100

tsvwg,

On 20/06/2019 13:04, Toke Høiland-Jørgensen wrote:
> This termination clause is a non-starter.

I've replied to Toke off list cc the chairs, cos I don't think the 
merits of different licence clauses are in scope for this list. I 
believe Toke has misunderstood, but until we resolve it, I don't think 
tsvwg is the right place for opinions from non-lawyers about legal matters.

Does the IETF have a list for this type of discussion? I don't think 
[email-masked] or [email-masked] are appropriate.

Bob

---

From: "Black, David" <[email-masked]>
Date: Fri, 21 Jun 2019 21:04:12 +0000

> merits of different licence clauses are in scope for this list

With my WG chair hat on, could I ask that people hold off on responding to this while the WG chairs (including yours truly) deal with the offline thread.  Outcome will be summarized here - we're likely to get to a conclusion faster if we don't have to try to follow two parallel threads ...

Thanks, --David

> -----Original Message-----
> From: tsvwg <[email-masked]> On Behalf Of Bob Briscoe
> Sent: Friday, June 21, 2019 5:01 PM
> To: [email-masked]
> Subject: Re: [tsvwg] IPR Declarations on draft-ietf-tsvwg-aqm-dualq-coupled
> 
> 
> [EXTERNAL EMAIL]
> 
> tsvwg,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 22 Jun 2019 12:07:18 +1200

https://tools.ietf.org/html/rfc3669 is still good reading. The essence
of our IPR disclosure requirements have not changed since then.

(I'm not aware of a current discussion venue for this topic.)

Regards
   Brian