Subject: Re: [tsvwg] [saag] TSVWG WGLC: draft-ietf-tsvwg-transport-encrypt-08, -> logging

From: "Scharf, Michael" <[email-masked]>
Date: Sun, 13 Oct 2019 20:49:32 +0000

Yep, but that assumes that an undergraduate student already understands the notion of a „key“ when learning Internet Transport for the first time. That is not necessarily compatible with the table of content of many current networking textbooks.

And, yes, also such „running code“ (in various text formats) can be modified, e.g., to introduce crypto much earlier. That may be as trivial as changing any other widely deployed „running code“...

Michael

Von: Lars Eggert<mailto:[email-masked]>
Gesendet: Sonntag, 13. Oktober 2019 22:06
An: Scharf, Michael<mailto:[email-masked]>
Cc: Gorry Fairhust<mailto:[email-masked]>; Christian Huitema<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [tsvwg] [saag] TSVWG WGLC: draft-ietf-tsvwg-transport-encrypt-08, -> logging

Hi,

On 2019-10-13, at 7:58, Scharf, Michael <[email-masked]> wrote:
> I guess many generations of young engineers and future software developers have learnt TCP/IP by looking at the IP and TCP headers in PCAP files.

my guess is that most students would be in control of one of the endpoints (sending or receiving the traffic of interest), in which case they can still dissect the protocol. Wireshark can decode QUIC traffic just fine if you provide it with the keys.

Lars

---

From: Joe Touch <[email-masked]>
Date: Sun, 13 Oct 2019 17:17:39 -0700

Michael,

If that’s an issue, have them turn it off in their first tests.

No, students do not have a “right” to paw through Internet logs taken at access points - even to examine transport headers only. That’s still user data, still subject to IRB review, and still of a private enough nature that they shouldn’t be doing that without specific training on data privacy under controlled conditions.

Joe

> On Oct 13, 2019, at 1:49 PM, Scharf, Michael <[email-masked]> wrote:
> 
> Von: Lars Eggert <mailto:[email-masked]>
> An: Scharf, Michael <mailto:[email-masked]>
> Cc: Gorry Fairhust <mailto:[email-masked]>; Christian Huitema <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On 2019-10-13, at 7:58, Scharf, Michael <[email-masked] <mailto:[email-masked]>> wrote: