Subject: Re: [tsvwg] New Version Notification for draft-fairhurst-tsvwg-udp-options-dplpmtud-00.txt

From: <[email-masked]>
Date: Fri, 20 Dec 2019 07:37:48 +0000

Hi Gorry, Chairs, all,

Given the content was extracted from a WG-adopted I-D, wouldn't be appropriate to publish this piece as draft-ietf-tsvwg-*?

Also, can we move the definition of RES/REQ from the udp-options I-D to this one?

Thank you.  

Cheers,
Med

> -----Message d'origine-----
> De : tsvwg [mailto:[email-masked]] De la part de Gorry Fairhurst
> Envoyé : jeudi 25 avril 2019 17:51
> À : [email-masked]
> Objet : Re: [tsvwg] New Version Notification for draft-fairhurst-tsvwg-udp-
> options-dplpmtud-00.txt
> 
> 
> Following discussions at the last IETF with my co-chairs, I was asked to
> resubmit the UDP Options text for DPLPMTUD as a separate draft.  This
> removes dependencies on completing the UDP-Options work before the
> DPLPMTUD I-D can be published, which is hoped to allow earlier publication.
> 
> This will allow new methods to be developed to work with DPLPMTUD in
> pararllel with the completion of the work on UDP-Options.
> 
> We'll publish a new revision of the DPLPMTUD draft shortly that removes
> this text.
> 
> Gorry
> 
> Best wishes, Gorry and Tom.
> > A new version of I-D, draft-fairhurst-tsvwg-udp-options-dplpmtud-00.txt
> > has been successfully submitted by Godred Fairhurst and posted to the
> > IETF repository.
> >
> > Name:		draft-fairhurst-tsvwg-udp-options-dplpmtud
> > Revision:	00
> > Title:		Datagram PLPMTUD for UDP Options
> > Document date:	2019-04-25
> > Group:		Individual Submission
> > Pages:		8
> > URL:            https://www.ietf.org/internet-drafts/draft-fairhurst-
> tsvwg-udp-options-dplpmtud-00.txt
> > Status:         https://datatracker.ietf.org/doc/draft-fairhurst-tsvwg-
> udp-options-dplpmtud/
> > Htmlized:       https://tools.ietf.org/html/draft-fairhurst-tsvwg-udp-
> options-dplpmtud-00
> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-fairhurst-
> tsvwg-udp-options-dplpmtud
> >
> >
> > Abstract:
> >     This document describes how a UDP Options sender may implement
> >     Datagram Packetization Layer Path Maximum Transmission Unit Discovery
> >     (DPLPMTUD) as a robust method for Path Maximum Transmission Unit
> >     Discovery.
> >
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat

---

From: "Gorry (erg)" <[email-masked]>
Date: Fri, 20 Dec 2019 13:09:36 +0000

In this case, I will take advice for this from my co-chairs...

Gorry

> On 20 Dec 2019, at 07:38, [email-masked] wrote:
> 
> Hi Gorry, Chairs, all,
>

---

From: "C. M. Heard" <[email-masked]>
Date: Sat, 21 Dec 2019 09:54:49 -0800

I would like to ask the chairs not to do that. in my opinion, there are
significant unresolved issues with UDP options, and it would be premature
to publish the definitons of RES/REQ until those issues are resolved. Also,
in addition to  RES/REQ ,DLPMTUD needs a padding option.

I'll do my best to post some long-delayed comments on the most recent UDP
options draft and IETF presentation.

Mike Heard

On Fri, Dec 20, 2019 at 5:09 AM Gorry (erg) <[email-masked]> wrote:

> > Given the content was extracted from a WG-adopted I-D, wouldn't be
> appropriate to publish this piece as draft-ietf-tsvwg-*?
> >
> >>> Status:
> https://datatracker.ietf.org/doc/draft-fairhurst-tsvwg-
> >> udp-options-dplpmtud/

---

From: Joe Touch <[email-masked]>
Date: Sat, 21 Dec 2019 10:20:28 -0800

Mike,

UDP options already has a pad option; this issue was addressed at the last IETF. 

DPLPMTUD doesn’t define its own options; they were broken out as a separate doc. DPLOMTUD previously included the definition of the UDP options specific to that feature (PAD is more generic).

Joe

> On Dec 21, 2019, at 9:54 AM, C. M. Heard <[email-masked]> wrote:
> 
> I would like to ask the chairs not to do that. in my opinion, there are significant unresolved issues with UDP options, and it would be premature to publish the definitons of RES/REQ until those issues are resolved. Also, in addition to  RES/REQ ,DLPMTUD needs a padding option.
> 
> I'll do my best to post some long-delayed comments on the most recent UDP options draft and IETF presentation.
> 
> Mike Heard
> 
> On Fri, Dec 20, 2019 at 5:09 AM Gorry (erg) <[email-masked] <mailto:[email-masked]>> wrote:
> > On 20 Dec 2019, at 07:38, [email-masked] <mailto:[email-masked]> wrote:
> > 
> > Hi Gorry, Chairs, all,
> > 
> >> De : tsvwg [mailto:[email-masked] <mailto:[email-masked]>] De la part de Gorry Fairhurst
> >> À : [email-masked] <mailto:[email-masked]>
> >>> URL:            https://www.ietf.org/internet-drafts/draft-fairhurst- <https://www.ietf.org/internet-drafts/draft-fairhurst->
> >>> Status:         https://datatracker.ietf.org/doc/draft-fairhurst-tsvwg- <https://datatracker.ietf.org/doc/draft-fairhurst-tsvwg->
> >> udp-options-dplpmtud/
> >>> Htmlized:       https://tools.ietf.org/html/draft-fairhurst-tsvwg-udp- <https://tools.ietf.org/html/draft-fairhurst-tsvwg-udp->
> >> options-dplpmtud-00
> >>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-fairhurst- <https://datatracker.ietf.org/doc/html/draft-fairhurst->
> >>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> >>> 
> >>> The IETF Secretariat
> > 
>

---

From: <[email-masked]>
Date: Mon, 23 Dec 2019 06:51:43 +0000

Hi Mike,

Pending issues should be addressed as part of udpt-option and the (hopefully adopted) DLPMTUD I-Ds. That is just business as usual.

Cheers,
Med

De : tsvwg [mailto:[email-masked]] De la part de C. M. Heard
Envoyé : samedi 21 décembre 2019 18:55
À : TSVWG
Objet : Re: [tsvwg] New Version Notification for draft-fairhurst-tsvwg-udp-options-dplpmtud-00.txt

Mike Heard

On Fri, Dec 20, 2019 at 5:09 AM Gorry (erg) <[email-masked]<mailto:[email-masked]>> wrote:
In this case, I will take advice for this from my co-chairs...

Gorry

> On 20 Dec 2019, at 07:38, [email-masked]<mailto:[email-masked]> wrote:
>
> Hi Gorry, Chairs, all,
>
>> De : tsvwg [mailto:[email-masked]<mailto:[email-masked]>] De la part de Gorry Fairhurst
>> À : [email-masked]<mailto:[email-masked]>
>>> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>>>
>>> The IETF Secretariat
>