Subject: Re: [tsvwg] I-D Action: draft-ietf-tsvwg-udp-options-08.txt

From: "C. M. Heard" <[email-masked]>
Date: Sat, 28 Dec 2019 14:53:40 -0800

Hi Joe,

These comments address only the changes in version -08, as you requested.
I am sorry that they are so late, but my day job has required all my
attention.

On Thu, Sep 12, 2019 at 9:14 PM Joe Touch wrote

> Hi, all,
>
> This is a quick update to cover the following:
>
> - update conventions to cite "standard" caps-only text (was that
> seriously necessary?)
>

Thanks for doing that as someone will insist during eventual IESG review

> - remove 'experimentally' throughout; this is standards-track
>

Changes look good.

> - add the extended length format
>

Changes look good, but I would recommend that another figure,
to accompany Figure 22, be added to make it clear that the EXP
option is allowed to use the extended length format.

> - correct the lengths in the summary table
>

Changes look good, except for inconsistent capitalization of RESERVED.

- require post-options area of surplus to be zero-fill

Change looks good.

- fix the figure and description of OCS to use a 16-bit checksum

The work on this section is incomplete, as it does not specify
that a two-byte pseudo header containing the length of the surplus
area be conceptually prefixed to the surplus area data. As noted in
https://tools.ietf.org/html/draft-fairhurst-udp-options-cco-00,
that pseudo-header is necessary to fix the most common middlebox
traversal issue that has been found (i.e., calculating the UDP
checksum based in the IP payload length instead of the UDP length).
Since the result will not be an overall ones-complement sum of
zero, that language needs to be dropped from the draft.

I would also recommend that the next version of the draft
explicitly mention that for the purpose of the checksum
calculation the surplus area needs to be conceptually
padded by zero bytes that are not actually transmitted
if its start and/or end are on odd boundaries relative
to the start of the UDP data area.

> - define OCS as required when UDP CS != 0
>

Changes look good.

> - change ACS from a 16-bit CRC to CRC32c
>

Changes look good, but it should be explicitly stated whether it is
REQUIRED that an option-aware receiver discard a packet with
an incorrect ACS (which I believe is the intent of the draft) or
whether it is at the receiver's discretion (presumably not, since
ACS is listed as one of the options that an options-aware
implementation is required to support).

> There are more than a few other changes underway based on feedback from
> the last meeting. The concept behind those changes will be posted for
> feedback when developed further for WG feedback before being included in
> the next update.
>
> I.e., please don't treat the fact that the rest hasn't changed as
> anything beyond "TBD".
>
> Comments on *these changes* welcome, of course.
>

Editorial: section numbers for Echo (6.) and Experimental (6.1) are
incorrect.

Substantive comments later on the proposed path forward presented at IETF
106.

 Mike Heard

---

From: Joe Touch <[email-masked]>
Date: Tue, 31 Dec 2019 07:11:22 -0800

Hi, Mike,

Many thanks for these detailed comments. They’ll be incorporated in the next rev.

Joe

> On Dec 28, 2019, at 2:53 PM, C. M. Heard <[email-masked]> wrote:
> 
> Hi Joe,
> 
> I am sorry that they are so late, but my day job has required all my attention.
> 
> Changes look good, except for inconsistent capitalization of RESERVED..
> 
> https://tools.ietf.org/html/draft-fairhurst-udp-options-cco-00 <https://tools.ietf.org/html/draft-fairhurst-udp-options-cco-00>,
> Editorial: section numbers for Echo (6.) and Experimental (6.1) are incorrect.
> 
> Substantive comments later on the proposed path forward presented at IETF 106.
> 
>  Mike Heard