Subject: [tsvwg] Transport Area Working Group (tsvwg) WG Virtual Meeting: 2020-02-20 CHANGED

From: IESG Secretary <[email-masked]>
Date: Thu, 06 Feb 2020 11:35:21 -0800

MEETING DETAILS HAVE CHANGED.  SEE LATEST DETAILS BELOW.

The Transport Area Working Group (tsvwg) Working Group will hold
a virtual interim meeting on 2020-02-20 from 09:00 to 11:00 America/New_York.

Agenda:
1. Agenda bashing (chairs - 5 min)
2. Update on status and near-term plans for the set of L4S drafts (Bob? - 5 min)
     - Chair request: Think about adding an explicit &quot;Open Issues / Future Work&quot; type of section in the architecture draft to consolidate a list of things still being worked in the context of TCP Prague and/or caveats and unknowns people should be aware of when deploying this Experimental work.
3. Update on L4S &amp; TCP Prague implementation, test, evaluation (Greg/Bob/Koen? - 15 min)
4. L4S Issues List Discussion (goal is to see if we can agree on what more needs to be done on each issue to suffice for Experimental/Informational RFCs):
    4.1 Discuss status on (Bob - ~30 min):
          #16 on classic ECN interaction
          #21 CE codepoint semantics (closely related to #16)
          #20 ECT(1) codepoint usage
    4.2  Discuss plans forward to address (Bob - ~15 min):
           #26 on admission control
           #27 on terminology
           #22 on deployment feasibility
            #24 on evaluation &amp; testing results
     4.3 (We will try to handle the issues below by mailing list prior to the meeting)
           If needed, discuss close-out of (~15 min):
           #25 on IPR
           #18 on loss detection in time-units
           #23 on implementation status
           #19 on the single codepoint
           #17 on FQ interaction  
5. SCE Update (Morton/Heist/etc. - ~30 min)

Information about remote participation:
Remote participation information will be obtained at the time of approval.  Plan to use IETF WebEx.

---

From: Sebastian Moeller <[email-masked]>
Date: Sun, 9 Feb 2020 19:30:12 +0100

Dear All,

great that we have the rescheduled agenda, thanks a lot.

I would respectfully like to make the following comments on the agenda:

1) I am delighted to see a full 30 minutes slot for getting an update on SCE, as I am quite interested to learn about progress/challenges there (and it unfortunately, fell off the end at the last ietf meeting)

2) I would ask whether we could add a dedicated topic to discuss #28 whether dualq is up to the task it was designed to solve and whether the current level of achieving said design tasks is sufficient to merit roll-out as part of an ietf-endorsed experiment

3) Regarding point 4.1 "#20 ECT(1) codepoint usage", I wonder whether we could get a recap of how the ietf/wg reached consensus on ECT(1) as a combined heuristic label for flows promising a 1/p type marking response as well as a request for sorting into the L4S-low latency queue? And how we can mitigate the side-effects of that overloading to make any experimentation safe for the existing internet.

4) Should we not also explicitly discuss how to make the L4S safe for experimental roll-out, including mitigation strategies for the already known side-effects and how to implement a roll-back in case the experiment does not achieve its goals (including an explicit list of measurable goals)?

Best Regards
	Sebastian

> On Feb 6, 2020, at 20:35, IESG Secretary <[email-masked]> wrote:
>