Subject: [tsvwg] rrul yet?

From: Dave Taht <[email-masked]>
Date: Sat, 08 Feb 2020 19:34:04 -0800

I do kind of miss the days when we were all in this bloat together, and
a variety of metrics mattered. So far I've been following along only a
bit, I've just gone through the simplistic 2 or so flow ones again just now.

Is there any chance these benchmarks, using L4S (or SCE) style traffic
(dctcp and bbrv2), can be repeated? Specifically fig 14-16, 24, and 28
tracking metrics like loss also?

https://www-res.cablelabs.com/wp-content/uploads/2019/02/28094118/Active_Queue_Management_Algorithms_DOCSIS_3_0.pdf

There were a few things wrong with this benchmark string as turned out
afterwards - the projection for the growth of a webpage was way off,
quic didn't exist, pacing didn't exist - but they did stress out more
than two flows at a time - and merely seeing a shot
through that code with these new variables applied vs as things existed then would be of comfort.

Secondly...

Has anyone done a rrul style benchmark yet? (flooding the uplink and
 downlink with mixed traffic, especially one with asymmetric bandwidth)

Probably my greatest concern with either approach was the gradual rate
 reduction stuff would be too gradual when the return path is inflated
 by other traffic.

My testbed is mostly focused on wifi where things like hardware retries
dominate the impacts of new algorithms.

---

From: Pete Heist <[email-masked]>
Date: Sun, 9 Feb 2020 17:18:30 +0100

> On Feb 9, 2020, at 4:34 AM, Dave Taht <[email-masked]> wrote:
> 

We have run rrul in a few different ways, one of which was a 50:1 asymmetric link with higher flow counts in the ‘wrong' direction.

With SCE, the existing multiplicative backoff CE signal is still available as a backstop, when the SCE signal alone either isn’t enough or isn’t being responded to, without necessarily having to resort to drop. In a test like this, you’ll typically see both heavy SCE marking and CE marks as well.

---

From: Sebastian Moeller <[email-masked]>
Date: Mon, 10 Feb 2020 17:05:26 +0100

> On Feb 9, 2020, at 17:18, Pete Heist <[email-masked]> wrote:
> 
> 

Okay, any information on how L4S' dualq and TCPPrague deal with the same load?

Best Regards
	Sebastian