Subject: [tsvwg] UDP Options: REQ/RES

From: <[email-masked]>
Date: Thu, 30 Jul 2020 11:35:10 +0000

Hi Joe,

Given that the plan for -09 is to not mandate the support of REQ/RES and that only kind values are defined in the UDP option draft without specifying the behavior for handling these options, I reiterate a comment I made in the past: remove these options from -09 and leave them to draft-fairhurst-tsvwg-udp-options-dplpmtud.

Also, please update the list of kind values in Section 5 to indicate that 255 is for extended UDP option format.

Thank you.

Cheers,
Med

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Joseph Touch <[email-masked]>
Date: Thu, 30 Jul 2020 09:27:09 -0700

Hi, Med,

The 255 length for the extended format was in -08 already. Did you mean something else?

As to REQ/RES, although they’re used for dplpmtud they’re not intended as exclusive to that mechanism; they’re more generically useful and that’s why they’re defined - in detail - in the UDP options draft already (in -08 in section 6, which was incorrectly a level-1 heading and is now fixed).

Joe

> On Jul 30, 2020, at 4:35 AM, [email-masked] wrote:
> 
> Hi Joe,
>