Subject: Re: [tsvwg] 回复：Takeaways for HPCC++

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 28 Oct 2020 17:47:42 +0000

Hi all,
An editorial comment: ICCRG has published RFC 6077 about ten years ago. Obviously, the document may be a bit dated, but it is has specifically taken into account lessons learnt from protocols such as XCP or Quick-Start. Not all content of RFC 6077 may apply to current data centers. Nonetheless, some of the content in RFC 6077 is quite generic, and it could be useful to better explain in a description of HPC++ how this architecture addresses the challenges.
Best regards
Michael (as co-author of RFC 6077)

From: tsvwg <[email-masked]> On Behalf Of Rui, Miao
Sent: Friday, September 11, 2020 10:53 AM
To: Miao, Rui(缪睿) <[email-masked]>; tsvwg <[email-masked]>
Cc: Barak Gafni <[email-masked]>; tsvwg-chairs <[email-masked]>
Subject: [tsvwg] 回复：Takeaways for HPCC++

Dear WG members,

At IETF 108, we presented HPCC++, a new architecture for congestion control designed for high-speed networks. We have modified the draft according to the feedback from the meeting. The newer version is available at https://tools.ietf.org/html/draft-pan-tsvwg-hpccplus-02

Thanks, and please feel free to let us know if you have more comments.

Thanks,
Rui

------------------------------------------------------------------
发件人：Miao, Rui(缪睿) <[email-masked]<mailto:[email-masked]>>
发送时间：2020年8月2日(星期日) 11:21
收件人：tsvwg <[email-masked]<mailto:[email-masked]>>
抄　送：tsvwg-chairs <[email-masked]<mailto:[email-masked]>>; Wesley Eddy <[email-masked]<mailto:[email-masked]>>; "Pan, Rong" <[email-masked]<mailto:[email-masked]>>; Barak Gafni <[email-masked]<mailto:[email-masked]>>
主　题：Takeaways for HPCC++

Hello TSVWG members,

It was our pleasure to present HPCC++ in the IETF-108 meeting this week. We appreciate your valuable feedback. Our current draft is located at https://tools.ietf.org/html/draft-pan-tsvwg-hpccplus-01.
Here, we have summarized a list of takeaways to further improve the draft.

1. HPCC++ is a generic congestion control scheme that works for high-speed networks. It requires to have window limit and ACK self-clocking, which is out of the definition of RoCEv2 but should instead work well for TCP/iWRAP. In addition, HPCC++ conforms to the paradigm of existing TCP congestion control, such as switch marking, receiver feedback, and sender enforcement. The major changes are using inband telemetry as the congestion feedback and it is incremental. In the next revision, we describe clearly how it works for TCP/UDP and related protocols.

2. HPCC++ works for both data centers and the Internet. We will add descriptions and results for the Internet-scale size and latency in the next revision.

Thanks again for the comments. Please feel free to let us know if you have more thoughts.

All the best,
Rui, Rong, Barak

---

From: "Pan, Rong" <[email-masked]>
Date: Fri, 30 Oct 2020 01:32:07 +0000

Michael,

Thanks for your comments. We will take a look of RFC6077 and revise our draft accordingly.

Best,

Rong

From: tsvwg <[email-masked]> on behalf of "Scharf, Michael" <[email-masked]>
Date: Wednesday, October 28, 2020 at 10:48 AM
To: "Rui, Miao" <[email-masked]>, tsvwg <[email-masked]>
Cc: Barak Gafni <[email-masked]>, tsvwg-chairs <[email-masked]>
Subject: Re: [tsvwg] 回复：Takeaways for HPCC++

Hi all,

Dear WG members,

Thanks,
Rui

Hello TSVWG members,

All the best,
Rui, Rong, Barak