Subject: [tsvwg] fairness topic at IRTF open meeting this week

From: Wesley Eddy <[email-masked]>
Date: Thu, 19 Nov 2020 13:25:57 -0500

Relevant to some of the recent discussion around RTT fairness, safety, etc., there is a paper being presented at the IRTF meeting this week that may be of interest.

Ranysha Ware will be giving an ANRP talk on Friday, on the paper "Beyond Jain’s Fairness Index: Setting the Bar For The Deployment of Congestion Control Algorithms” from HotNets 2019.

https://www.cs.cmu.edu/~rware/assets/pdf/ware-hotnets19.pdf

https://datatracker.ietf.org/meeting/109/materials/agenda-109-irtfopen-00

---

From: Jonathan Morton <[email-masked]>
Date: Thu, 19 Nov 2020 23:20:27 +0200

> On 19 Nov, 2020, at 8:25 pm, Wesley Eddy <[email-masked]> wrote:
> 

Indeed, this does look like a worthwhile approach.  I encourage everyone to read through the paper, even if you don't attend the talk.

 - Jonathan Morton

---

From: Sebastian Moeller <[email-masked]>
Date: Thu, 19 Nov 2020 22:23:00 +0100

Hi Wes,

thanks for posting this. Interesting.

Here is the gist in one sentence:

If the amount of harm caused by flows using a new algorithm α on flows using an algorithm β is within a bound derived from how much harm β flows cause other β flows, we can consider α deployable alongside β.

This is pretty much what Pete's recent data demonstrated that TCP Prague + DualPI2 does NOT compared to CUBIC + DualPI2. The systematic biases pro L4S in both rate and latency make it clear that L4S flows will "harm" non-L4S flows more than non-L4S flows will harm each other. 
	Sure, harm is slightly more flexible than simple equitable rate sharing, but since for normal bulk flows throughput still seems the most relevant metric, and latency wise we know for a fact that TCP Prague will get latency priority, at the expense of Cubic (in my simple comparison). It is hence clear that L4S does harm to the existing CCs. But even without a new way of describing this, it was clear that L4S is not competing fairly...
	The question is, is the amount of harm acceptable for the WG or not. And how is the rest of the internet going to react to the WG's decision after deployment starts.

Best Regards
	Sebastian

> On Nov 19, 2020, at 19:25, Wesley Eddy <[email-masked]> wrote:
>